BONUS CHAPTER 6

Importing and
Coordinating Models

It’s amazing that we’re up to Bonus Chapter 6, and yet I'm sure many
readers are still unclear about how BIM fits in here. Yes, most of the previous
chapters showed how you benefit from BIM when you change an item in one
place and it changes in another—yada, yada, yada .... But you were probably
sold on the whole “coordinating with your consultants” thing back when you
were considering purchasing the Autodesk® Revit® Architecture software.
Well, here we are. It’s time to tackle that mystical ideology that has put our
industry in a loose headlock.

Linking a Revit Structure model
Activating Copy/Monitor
Running interference detection

Importing and exporting CAD formats

Linking a Revit Structure Model

The first section of this chapter will focus on the actual event of import-
ing a Revit Structure model. As you start the process, you'll see that this
procedure isn’t unfamiliar if you have any CAD background whatsoever. If
you don’t have a CAD background, I think you'll find these procedures to be
intuitive enough to get through importing Revit models.

As you proceed into design development, you must get your structural
engineer on board. This consultant may be an external or an in-house
resource. Either way, this individual will have a different model with which
you need to coordinate.

This section will focus on the procedures involved with importing a Revit
Structure model. We'll also cover the concept of creating a live monitoring
system with the structure as well as interference detection.
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. N O T E  Metricusers should not type in mm or other metric abbreviations when
% entering amounts suggested in the exercises. Revit will not accept such abbreviations.
Simply enter the number provided within the parentheses.

To get started, open the model on which you've been working. If you missed the
previous chapter, go to the book’s web page at www.sybex.com/go/revit2017ner.
From there, you can browse to the BC6 folder and open the NER-BC6. rvt file.
You'll also need to locate the model called NER-BC6_STRUCTURAL. rvt. Save both
files in a location where you can retrieve them.

The objective of the following procedure is to import and link a Revit
Structure model. Follow these steps:

1. In the Project Browser, go to the Level 1 floor plan.

2. Delete every structural column. (Keep the canopy framing intact.
Don’t delete the beams and columns in these two areas.)

% N O T E  Whyare you deleting these structural members you worked so hard to

; add? Because the structural consultant laid out their grid based on yours. You'll copy their
grid back in and monitor any movement that may occur throughout the life of the project.
As far as the columns go, you're going to use the structural engineer’s columns for your
elevations, plans, and sections from this point forward.

3. On the Link panel of the Insert tab, click the Link Revit button, as
shown in Figure BC6.1.
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FIGURE BCG6.1: ThelinkRevit button on the Link panel of the Insert tab

4. Browse to the NER-BC6_STRUCTURAL. rvt file, but don’t click Open just
yet.

5. Select the file.

6. At the bottom of the dialog, you have a choice of Positioning. Select
Auto — Origin To Origin, as shown in Figure BC6.2.
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FIGURE BCG6.2: Payattention tothe choices provided before you click Open.

7. Click Open. Your structural model is now linked.

8. Because this structural model was created independent of your archi-
tectural model, you need to align the structural grid with the archi-
tectural grid. Use the Align function to do this.

9. Open the 3D view East Entry Corridor.

You can now see the wood framing the structural engineer added to support
the cantilevered slab, as shown in Figure BC6.3.

FIGURE BC6.3: Thesupporting framing under the cantilevered slab at the
east link
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Already you're seeing the benefits of a collaborative model, and you’ve done
nothing more than insert one model into another. This isn’t new technology,
and you're certainly not doing anything profound. The real benefit comes from
how you can keep track of what the structural model is doing underneath your
model. You can copy items from the structural model and then monitor any
changes made from the linked model. This is the definition of BIM.

Activating Copy/Monitor

I can almost sum up BIM in one command: Copy/Monitor. I hate to break down
the most important acronym in our industry since CAD into such simple terms,
but BIM is the process of monitoring and tracking change, and that process
starts right here.

In the next procedure, you'll copy the structural grids and apply a monitoring
system that will alert you when the grids have moved. Although this chapter will
focus solely on copying and monitoring the grids, your takeaway will be the expe-
rience required to recognize the procedure and the importance of this function.

To create a copying and monitoring system, follow these steps:

1. Go to the Level 1 floor plan.

2. On the Coordinate panel of the Collaborate tab, select Copy/
Monitor > Select Link, as shown in Figure BC6.4.
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FIGURE BCG6.4: TheCopy/Monitor button on the Coordinate panel of the
Collaborate tab

3. Hover your pointer over one of the grids. You see an outline of
the Revit Structure model that you've linked in. Pick the grid (see
Figure BC6.5).
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FIGURE BCG6.5: Selectingthelink to Copy/Monitor

. On the Copy/Monitor tab, click the Copy button, as shown in
Figure BC6.6.
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FIGURE BC6.6: C(lickingthe Copy button

. On the Options bar, select the Multiple option.
. While pressing the Ctrl key, select all the grids in the linked model.

. When you're finished, click Finish on the Options bar, as shown in
Figure BC6.7.

. You may get a warning saying, “The following types already exist
but are different.” Close the warning. Your grids should look like
Figure BC6.8.

It's often overlooked,
but you must click
Finish on the Options
bar or the copying and
monitoring process
won't take effect.
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FIGURE BCG6.7: TheFinishbutton onthe Options bar
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FIGURE BCG6.8: Thecopiedgrids

9. Close out of any warnings stating that new items have been renamed.
This is inconsequential information.

10. Click Finish, as shown in Figure BC6.9.
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FIGURE BC6.9: C(lickingFinish
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You now have a relationship with the structural model. Next, you’ll put this
relationship to the test and generate a coordination alert. I suppose you could
say that the honeymoon is over!

Coordination Alert

Suddenly you've been thrust into a completely different way of working. You
have a structural model inserted into your architectural model that will bark
at you every time something changes. There’s nothing wrong with that. Sure,
occasionally there will be some annoyances, but these irritations are a small
concession for being truly tied in with the structure.

When something changes in the structural model that is involved with an
active monitor, you’ll be alerted. This alert will occur either when you open your
model or when you reload the linked Revit file.

To review the coordination alert, follow this procedure:

1. Save and close your model.
2. Open the NER-BC6_STRUCTURAL. rvt model.

3. Open the Level 1 structural view, and rename grid A to z, as shown in
Figure BC6.10.

FIGURE BC6.10: RenaminggridA

4. Save the model and close it.

5. Open the architectural model. You may see the warning shown in
Figure BC6.11.

6. Click OK to continue opening the model.
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Warning - can be ignored

Instance of linked .rvt file needs Coordination Review -
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FIGURE BC6.11: Coordinationalert

7. Go to Level 1.

8. Select the link. (You may have to hover your mouse over one of the
grids and press the Tab key.)

9. On the Monitor panel of the Modify | RVT Links tab, click the
Coordination Review button, as shown in Figure BC6.12.
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FIGURE BC6.12: TheCoordination Review button on the Monitor panel of
the Modify | RVT Links tab

10. In the Coordination Review dialog, expand the Grids category (under
the New/Unresolved category), as shown in Figure BC6.13.

11. Expand the Maintain Name category.

” T I P The category that says Grid Moved is the actual alteration that occurred in the
)9 structural model. Finally! Somebody is telling us what they changed without fear of us
getting mad at them.



Activating Copy/Monitor

Group by:

Revi
In host project

Status, Category, Rule N7

Message

& Grids

=]

= New/Unresolved

= Maintain Name

- Grids : Grid : A:id 216913

NER-20_STRUCTURAL.rvt: Grids : Grid : z: id

212581

Comment

Rename Elegnem A

Show:
Postponed

Rejected

[ Show

H Create Report ]

[

0K

J

poply | [ cancel |

J

FIGURE BC6.13: TellingRevittorename the grid automatically

12. To the right of the Name Changed category is the Action column.
Click into the cell that says Postpone, and look at the list. You'll see

four categories.

Reject Reject postpones the change. Each time you run a coor-
dination review, this instance is listed as rejected. You’ll have a
chance to modify the instance at a later date.

Accept Difference Accept Difference basically skips the error.
You can change it at a later date.

Rename Element ‘A’ This choice takes action. If the difference is
the name (which it is in this case), Revit renames the grid. If the
grid moves or if it’s deleted, Revit moves or removes the grid for
you. (Basically, any necessary modification can be made automati-
cally right here.)

Postpone This allows you to wait until later to make a decision.

13. Select Rename Element ‘A’

14. Click Apply.
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Re N O T E  Youcanalso add a comment pertaining to the change. Typically, it’s a
% note to yourself, but in some situations, you'll need such a comment when you're involved
in friendly discussions about who started a chain of events.

15.
16.
17.

18.

19.
20.
21.

22.

Click the Create Report button at the bottom of the dialog.
Save the HTML file to a location where you can find it.

Click OK in the Coordination Review dialog. (Notice that grid A is
changed.)

Open Windows Explorer, find the HTML report, and open it. It’s an
uneditable report about the coordination effort that just occurred.

Close the report.
Save the model.

To check whether there are any more issues, select the structural
link, and click the Coordination Review button on the Modify | RVT
Links tab, as shown in Figure BC6.14.
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FIGURE BC6.14: C(licktheCoordination Review button.

Select the linked structural model. The report should be empty.

A coordination report is an excellent way to track changes, but you're alerted to
these changes only if you have the elements copied and monitored. How are you
supposed to know if other elements are colliding with one another? This question
is answered by using the Interference Detection function built into Revit.

Running Interference Detection

What came first, the chicken or the egg? That’s a tough call. Another tough call
is whether the beam comes before the duct or wall. Ask a structural engineer
and they will answer that the beam does in fact come before the wall, the door,
or any other architectural appointment. On the other hand, an architect will ask
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the structural engineer to move or eliminate a structural component. But the
fact is, if the architect and the structural engineer are having this argument,

that means they know there is an interference, and their disagreement about

the chicken and the egg is actually a good thing.

You can use interference detection in Revit to keep the contractor from asking
such questions. If the contractor is asking questions, then you have a problem,
don’t you? It means a collision has occurred that nobody caught. Don’t worry—
you can still have the chicken argument, only now it’s called litigation.

To use interference detection, you don’t have to do anything more than open
a single dialog. There, you can select specific elements that you're worried about
colliding. And in true Revit form, you can create a report and even zoom in on
the issue.

The objective of the following activity is to find some clashes between the
architectural model and the structural model:

1. On the Coordinate panel of the Collaborate tab, select Interference
Check > Run Interference Check, as shown in Figure BC6.15.

Collaborate
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Show Restore Copy/ , Coordination _ Reconcile | Interference
History Backup Monitor”  Review  Hosting | Check
Run Interference Check
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Synchronize + Coordinate

FIGURE BC6.15: Runlnterference Check on the Coordinate panel of the
Collaborate tab

2. In the panel to the left of the Interference Check dialog that opens,
select Current Project as the Categories From setting.

3. Select Doors and Stairs from the list, as shown in Figure BC6.16.

4. In the Categories From menu, select the NER-BC6_STRUCTURAL. rvt
file.

5. Select Structural Framing and Structural Columns (see Figure BC6.16).

6. Click OK.

7. The Interference Report dialog shows that you have a stair issue.
Expand the first Structural Framing category under Stairs, and click
Stairs > Stairs: Assembled Stairs.

11
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FIGURE BC6.16: Selectingthe components to find in the interference report

8. At the bottom of the dialog, click the Show button (see Figure BC6.17).
You may have to go through a couple of good views to find the inter-
ference (by clicking the Show button). Get used to this.
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9. You can set the visual style any way you want it, but you may have to
hide some items (as I did) to see the collision.

10. Revit zooms right in on the issue. Click the Export button.
11. Save the report in the same directory as the coordination report.

12. Click Close.

WHAT Do You MEAN, CLOSE? WE DIDN’T FIX ANYTHING!

Yes, that's right—you only identified the issue. Revit doesn’t breach another
model to fix your consultant’s work. It does, however, give you a specific, detailed
report for your meeting. Remember, using Revit doesn’t negate the need for open
discussion during a project.

That is some good stuff. Lucky for you, your consultants are all up and run-
ning on Revit. Oh, they aren’t? What kind of world are you living in?

It’s true. Your consultants won’t all be on Revit. If you're lucky, 1 in 10
uses Revit in such a capacity that they’re ready to share a model with you.
This is OK—don’t panic. You're still in a great position. You can easily
import from AutoCAD (or MicroStation), and you can export your model just
as easily.

Importing and Exporting CAD Formats

The first process we’ll delve into is importing an AutoCAD structural floor plan.
Although you've imported CAD in this book numerous times, you have yet to
do so in the context of a coordinated floor plan. The mindset for this is a little
different. And why is that? Because you now care about where this AutoCAD
drawing lands in relation to your model; you care also about maintaining that
relationship.

For the CAD file used in the following procedure, go to the book’s web page,
browse to the Chapter BC6 folder, and find the NER-BC6_STRUCTURAL . dwg file.
Save this file in a location where you can retrieve it.

Now, let’s import an AutoCAD 2D floor plan and pin down its coordinates.
Follow these steps:

1. Go to the Level 1 floor plan.

13
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2. Right-click the Level 1 view in the Project Browser, and click
Duplicate View > Duplicate With Detailing, as shown in
Figure BC6.18.
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FIGURE BC6.18: Duplicating the view

Rename the new view Level 1 CAD Coordination.

If you have view refer-
ences, Revit won't
paste them into the
new view. Click Delete
Element(s), and Revit
will let you proceed.

Open the new view.

Type VG (for Visibility Graphics).

Click the Revit Links tab.

Uncheck the NER-BC6_STRUCTURAL. rvt model.
Click OK.

On the Link panel of the Insert tab, click the Link CAD button,
and then browse to the location where you saved the NER-BC6_
STRUCTURAL . DWG file.

o ® N S VAW

10. At the bottom of the Link CAD Formats dialog, select the Current
View Only check box.

11. Set Colors to Black And White.

12. Set Layers/Levels to All.

13. Set Import Units to Auto-Detect.

14. Set Positioning to Auto — Origin To Origin (see Figure BC6.19).
15. Click Open.
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FIGURE BC6.19: Configuring the link

16. On the View Control bar, click the Wireframe button so you can see
the AutoCAD structure, as shown in Figure BC6.20.
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FIGURE BC6.20: Unpinningand aligning the reference
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17. As you can see, the underlay isn’t positioned correctly. Select the

linked CAD, and unpin it (see Figure BC6.20).

18. Align column lines A and 1.

The next step is to make sure the coordinates in the Revit model stay true in
the DWG file. With one simple procedure, you can publish the coordinates of the
Revit model to the DWG file to ensure accuracy while importing because you
had to move the link. Follow these steps:

1.

w

O N SN N A

On the Project Location panel of the Manage tab, click Coordinates
> Publish Coordinates, as shown in Figure BC6.21.
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FIGURE BC6.21: Publishing the coordinates

. Select the AutoCAD link by left-clicking it in the view.

On the Site tab of the Location Weather And Site dialog, click the
Duplicate button.

Call the new location Revit Position, and click OK.

. Click OK.

. Press Esc, and then select the AutoCAD link.

. In the Properties dialog, verify that Shared Site is now Revit Position.
. Save the Revit model.

. After you save the Revit model, you're prompted to save the new

coordinates in the DWG file. Click the Save button, as shown in
Figure BC6.22.

So that’s importing. Now, suppose you need to send your model to clients
and consultants who don’t have Revit. This can be addressed quickly and
deliberately.
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You have changed the "current” Position in
NER-20_STRUCTURAL.dwg. What do you want to do?
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FIGURE BC6.22: Savingthe coordinates to the AutoCAD file

Exporting a Model to CAD

For some of you, this is a nice-to-know subject. But for most of you, this is a
need-to-know subject. Taking the plunge into Revit may be something you’re
doing alone. Even if you're using Revit, you may still need the ability to provide
CAD drawings based on your models.

This section will focus on the process of exporting your Revit model to both
2D and 3D CAD.

Exporting a 2D Model

Most of the time, your deliverable to your clients will be a 2D model. If your
consultants aren’t on Revit, usually they aren’t using 3D CAD either. The 2D
CAD format is the lowest common denominator. Not that a 2D model is bad—it
means you need to export your model in a way that the client can pick it up and
run with it.

The objective of this procedure is to export your model to a 2D AutoCAD
drawing file. Follow these steps:

1. In the Project Browser, open the Level 1 floor plan.

2. Click the Application button, and select Export > CAD Formats
> DWG Files, as shown in Figure BC6.23.

3. Click the [...] button to the right of the Select Export Setup drop-
down, as shown in Figure BC6.24.

4. You have all sorts of CAD options. Click OK in this dialog.

17
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FIGURE BC6.23: Exportingthe model to CAD
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FIGURE BC6.24: Lookatallthe CAD choices!

5. Click OK.

6. Click the Next button, and save the file. You can open it and check it
out if you want.
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Now that you can export to a flat 2D file, it’s time to export your model as a
full 3D entity. The process is similar to exporting as 2D.

Exporting the Model to 3D CAD

It’s a shame to dumb down a 3D model to flat 2D CAD. It feels as though you're
taking a step backward each time you do it. When you find yourself in a situa-
tion where your consultants are using CAD but are using 3D modeling, you can
give them the gift of 3D. Follow these steps:

1. Go to the Default 3D view.

2. Select Export > CAD Formats > DWG Files.

3. Set the Export option to Current View/Sheet Only.
4. Click the Next button.

5. Find a place to save the 3D model, and click OK.
6. Save the model.

As you can see, it’s not a difficult process, but it’s important to know. You’ll
often find yourself exporting all your hard work and data to a lesser CAD format
as you wait for the rest of the industry to catch up to you!

Are You Experienced?
Now you can...

v/ import a Revit Structure model
v/ copy and monitor the Revit model
v/ run interference checking on a linked Revit model

v/ export a Revit model to CAD formats (2D and 3D)

19

The most important
step in exporting to a
3D CAD format is to be
ina 3D view.



