Now that the exterior shell is up and the rooms are basically laid out, it’s time to start considering the interiors. As it stands, you have a bunch of rooms with the same wall finish, the same floor finish, and no ceilings to speak of. The restrooms don’t have any fixtures, and the other rooms are going to be useless without furniture.

Another issue is that you don’t have any separate views such as furniture plans or finish plans. This chapter dives into all these items—and then some!

Creating ceilings
Creating ceiling openings and soffits
Adding interior design
Adding alternate floor materials

Creating Ceilings

Placing a ceiling is quite easy; the hard part is finding the view in which to do it. As you’ve probably noticed, the Project Browser is divided into categories. The categories for plans are Floor Plans and Ceiling Plans. Whereas floor plans show the views standing at that level looking down, ceiling plans show the view standing at that level looking up. In the Autodesk® Revit® platform, you’re looking at a true reflected ceiling plan.

**NOTE**  Metric users should not type in mm or other metric abbreviations when entering amounts suggested in the exercises. Revit will not accept such abbreviations. Simply enter the number provided within the parentheses.

To begin, open the file you’ve been using to follow along. If you didn’t complete Chapter 8, “Structural Items,” go to the book’s web page at www.sybex.com/go/revit2017ner. From there, you can browse to Chapter 9 and find the file called NER-09.rvt. Then, continue with these steps:

1. Go to the Level 1 ceiling plan, as shown in Figure 9.1 (remember, this is a ceiling plan, not a floor plan).
2. On the Architecture tab, click the Ceiling button.

3. With the Ceiling command active, choose 2’ × 4’ ACT System (600 mm × 1200 mm Grid) from the Type Selector, as shown in Figure 9.2.
4. Hover your mouse over the room shown in Figure 9.3. Notice that the perimeter is outlined in red. This indicates that the ceiling has found at least four walls you can use as a layout.

**Figure 9.3**: The Ceiling command finds bounding items such as walls.

5. When you see the red outline, pick a point in the middle of the room. Your ceiling should now look like Figure 9.4.

**Figure 9.4**: Placing the 2 × 4 tiled ceiling
6. Have at it! Add a ceiling to every room in the east wing except the bathrooms, the east radial entry, and, of course, the elevator shafts, as shown in Figure 9.5.

![Figure 9.5: Adding 2 × 4 ACT ceilings to the specified rooms](image)

7. With the Ceiling command still running, select Compound Ceiling: GWB On Mtl. Stud from the Type Selector.

8. Pick the bathrooms (not the chases) and the hallway.


**NOTE** If you notice that some of the grids are running in the wrong direction, don’t worry. You’ll change that in a moment.

*That* was just too easy! Too good to be true, right? All right, it was. You always have to make adjustments to this type of item. You probably noticed that you had no control over the direction in which the grids were running. Also, you have no clue as to the height of these ceilings. Let’s start modifying the ceilings.
Transferring Project Standards

At times, you won’t have the system families you need to carry out the task at hand. Ceiling types seem to be the number-one system family to be inadvertently deleted from a model before being used. If you find that you don’t have the ceiling types shown earlier, do the following:

1. Click the Application icon, and choose New ➢ Project.
2. In the New Project dialog box, click OK to start a new project using the default template.
3. On the View tab, click Switch Windows in the Windows panel, and select Reflected Ceiling Plan from the flyout to get back to the No Experience Required project.
4. On the Manage tab, click Transfer Project Standards in the Settings panel.
5. In the Select Items To Copy dialog box (see the following graphic), click the Check None button.
6. Click Ceiling Types.
7. Click OK.
Modifying Ceiling Grids

To be honest, a ceiling consists of nothing more than a basic hatch pattern applied to a material. Actually, everything in Revit is a basic hatch pattern applied to a material. That sure does make it easy to understand!

The one unique thing about hatch patterns in Revit is that you can modify them onscreen. That means you can move and rotate a hatch pattern. That also means you can move and rotate a grid pattern. Let’s give it a shot.

1. Press Esc or Modify to cancel the command you’re in.

2. Pick a ceiling grid line, as shown in Figure 9.6. (Make sure you’re zoomed in close enough to make the Rotate command active.)

3. On the Modify | Ceilings tab, click the Rotate button (see Figure 9.6).

4. Rotate the grid 45° by using the two-pick method, as shown in Figure 9.7.

Your ceiling should now look like Figure 9.8.
Now that the ceiling is in, let’s look at the ceiling’s properties before you go too far. As a matter of fact, it’s a good idea to investigate the ceiling’s properties before you place it in the model.
Setting Ceiling Element Properties

As I mentioned earlier, ceilings are set up in a fashion similar to floors. So, it stands to reason that you’ll see many similar properties.

Before you get started, let’s make some modifications to the west wing. The objective of this procedure is to add a hard ceiling with metal framing, gypsum, and a 3/4” (18 mm) cherry finish. To do so, however, you need to modify some of the walls.

1. Go to a 3D view of the model.

2. Select the sloped roof that covers the west wing, as shown in Figure 9.9.

3. Right-click.

4. Select Override Graphics In View ➡ By Element (see Figure 9.9).

5. In the View-Specific Element Graphics dialog box, select the small downward-pointing arrow in the Surface Transparency row, and slide Transparency to 50 percent. See Figure 9.10.

6. Click OK. The roof is now transparent by 50 percent.
You can set an object to be ghosted—that is, semitransparent—on the fly with the Transparent option. This helps especially with roofs and floors.

You made the roof transparent because some of the walls have to be attached to the roof. It’s much easier to attach the walls in a 3D view. But to do so, you need to see the walls on which you’ll be working.

1. Select the wall shown in Figure 9.11.
2. On the Modify | Walls tab, click the Attach Top/Base button.

3. Pick the roof.

Your wall should look like Figure 9.11.

The next step is to constrain the partition walls in this area to Level 3. The ceilings you’ll add to these rooms will be much higher than those in the rest of the building. Follow these steps:

1. While still in a 3D view, select the partitions shown in Figure 9.12.

   ![Selecting the partitions](image)

2. In the Properties dialog box, set the Top constraint to Up To Level: Level 3.
   The walls are now constrained to Level 3.

3. Select the roof that is transparent, right-click, select Override Graphics In View ➢ By Element, click the Reset button, and then click OK.

4. Go to Level 1 under Ceiling Plans.

   The next procedure is a tad off the beaten path, but it fits squarely within this process. Because you’ve specified the walls in this area to be of a greater height
than the rest of the walls in the model, you’re obviously adding ceilings higher than 8’–0” (2400 mm). This poses a problem in terms of the Level 1 ceiling plan view range.

**Creating a Plan Region**

Sometimes you’ll need to set your view range in a specific area that differs from the view range in the plan as a whole. In this example, you’ll add a ceiling at 14’–6” (4350 mm) above the finish floor. If you do this with the current view range settings, Revit won’t display the ceiling. If you modify the view range for the entire view, you’ll see the 14’–6” (4350 mm) ceilings, but you won’t see the regular 8’–0” (2400 mm) ceilings in the rest of the building in that view.

In the following procedure, you’ll create a region that has a different view range as compared to the view range in the Level 1 ceiling plan:

1. In the Project Browser, make sure you’re in the Level 1 ceiling plan.

   **WARNING** Double-check to be absolutely sure you aren’t in a floor plan. You want to be in the ceiling plan! If you don’t see the ceilings you placed earlier, you’re in the wrong view.

2. Zoom into the west wing.

3. On the View tab, select Plan Views ➢ Plan Region.

4. Pick the inside, finished face of the exterior walls around the north portion of the west wing (see Figure 9.13).

![Figure 9.13: Defining the limits of the plan region by drawing a rectangle around a specific area](image-url)
5. For the lower-left corner, draw a couple of straight lines, as shown in Figure 9.13, and trim them up if they do not intersect. (Unfortunately you can’t have radial perimeter lines in a plan region.)

Notice that the View tab has now switched to the Modify | Create Plan Region Boundary tab. You need to define the view range for this region.

1. In the Properties dialog box, click the Edit button in the View Range row.

2. In the View Range dialog box, set Top to Level 3.

3. Set Cut Plane Offset to 14’–6” (4350 mm).

4. Set Bottom Offset to 7’–6” (2250 mm).

5. Set View Depth Level to Level 2 with an Offset value of 16’–0” (4800 mm), as shown in Figure 9.14.

6. Click OK.

7. On the Mode panel, click Finish Edit Mode.

You now have a plan region. Although it may not seem as though you did anything in the plan, when you place a ceiling at 14’–6” (4350 mm), you’ll be able to see it.

**Note** The dotted line you see represents the border of the plan region. Although these borders can get annoying (especially if you collect several plan regions), I recommend you keep them turned on. It’s helpful to know where a plan region is in the model, and it’s more important for others to know that there is a plan region in that area. Also, these borders won’t plot.
With the plan region in place, you can now place a ceiling at a higher distance from the finish floor. Because you’re going to the trouble of placing a high ceiling, you might as well make the ceiling something special.

Creating a Custom Ceiling

So, what do you do if your ceiling isn’t an acoustical tile ceiling or a gypsum system? This is Revit! You make a new one.

As mentioned earlier, creating a ceiling is similar to creating a floor or a roof. The Properties dialog boxes are exactly the same. This procedure guides you through the process of creating a custom ceiling:

1. Be sure you’re in the Level 1 ceiling plan, and zoom in on the northwest room.
2. On the Architecture tab, click the Ceiling button.
3. In the Type Selector, select GWB On Mtl. Stud. To the right and below the picture of the ceiling is the Edit Type button. Click it.
4. Click Duplicate.
5. Name the new ceiling Wood Veneer on Metal framing, and then click OK.
6. In the Structure row, click the Edit button, as shown in Figure 9.15.

![FIGURE 9.15: Clicking the Edit button in the Structure row to gain access to the ceiling's structural composition](image)

7. In the Layers field, as shown in Figure 9.16, click row 4. This is the Finish 2 [5] Gypsum Wall Board row. The entire row should be highlighted in black when you have it selected properly.
8. Just below the Layers field is the Insert button. Click it.
9. Click the Down button to move the new row to the bottom.
10. Change the function from Structure to Finish 2 [5].
11. Click in the Material cell, and click the [...] button (see Figure 9.16).
12. In the top of the Material Browser dialog box, type Cherry, as shown in Figure 9.17.
13. In the Material Editor dialog box to the right, click the field next to Pattern in the Surface Pattern category. The field contains the word <none>.

14. A new dialog box opens. Scroll down until you see the Wood 1 pattern, and select it. Click OK.

15. Below the Surface Pattern category, expand the Cut Pattern category. Change the Pattern field to Plywood. Click OK. (See Figure 9.17.)

16. In the Shading category, click the Use Render Appearance box (see Figure 9.17).

17. In the Material Browser, click OK.

18. Change the Layer 5 thickness to 3/4" (18 mm).

19. Click OK twice.

20. In the Properties dialog box, change Height Offset From Level to 14’–6” (4350 mm), as shown in Figure 9.18.

21. Place the ceiling in the room shown in Figure 9.18.
NOTE Don’t get discouraged if your final result isn’t the same as shown in the figure. You took 21 steps to get to this wonderful cherry ceiling; any one of those steps could have gone wrong. Going back through the steps and retracing your path is something you may be doing quite often until you get used to the program. But remember, you’re now set up for plans, sections, and even 3D views and renderings by completing one small task!

For the adjacent rooms, add the same ceiling. You can keep the same height. You can follow along with these steps, but I encourage you to try to put in the ceilings from memory.

1. In the Project Browser, be sure you’re in the Level 1 ceiling plan.
2. On the Architecture tab, click the Ceiling button.
3. In the Change Element Type menu on the Element panel, find the ceiling called Compound Ceiling: Wood Veneer On Metal Framing. (It will probably be the current selection.)
4. In the Properties panel, set the height above the floor to 14’–6” (4350 mm).
5. Pick the rooms shown in Figure 9.19. When you’ve finished, press Esc a couple of times or click Modify to clear the command.

FIGURE 9.19: The north row of rooms will receive cherry ceilings.

Now that you have experience placing ceilings and creating custom ceiling systems, it’s time to start adding features. The first items that come to mind are lighting fixtures, but you need to go back even further and figure out how to “cut holes” in the ceilings and add soffits.
Creating Ceiling Openings and Soffits

Unless you're in a residential dwelling, a prison, or a subway, you can look up and notice that a ceiling is merely serving as a host for electrical, mechanical, and architectural components. Seldom will you find a ceiling that doesn't require a modification in some capacity. This section of the chapter deals with this issue, starting with creating a ceiling opening.

Creating a Ceiling Opening

The objective of the next procedure is to cut an opening into a ceiling, into which you'll drop a soffit later:

1. Open the Level 1 ceiling plan.
2. Zoom into the wood ceilings in the west wing, as shown in Figure 9.20.
3. Select the ceiling in the northwest corner of the building, and click the Edit Boundary button.

Tip

Ceilings can be difficult to select. If you hover your cursor over the perimeter of the ceiling, you'll see it highlight. If the wall or some other overlapping geometry highlights instead, tap the Tab key on your keyboard to filter through until you find the ceiling. When the ceiling highlights, pick it.
4. Click the Ref Plane button on the Work Plane panel, as shown in Figure 9.21.

5. Draw two reference planes (see Figure 9.21). Be sure to snap to the midpoints of the magenta sketch lines.

6. Press Esc a couple of times or click Modify to clear the Ref Plane command.

7. On the Draw panel, click the Boundary Line button. You see an expanded list of sketch choices. Pick the Circle choice, as shown in Figure 9.22.
8. Draw a 4’–0” (1200 mm) radius circle at the intersection of the reference planes (see Figure 9.22).


10. Verify that your ceiling looks like Figure 9.23.
With the cutout in place, you need to think about closing this feature with a soffit and, perhaps, another ceiling.

**Creating a Soffit**

Soffits are nothing more than walls with a base offset. This makes sense if you think about it. If your floor level moves, you certainly want the distance from the finish floor to the bottom of the soffit to remain consistent. This one is going to be easy! Here are the steps:

1. On the Architecture tab, click the Wall button.

2. In the Type Selector, select Basic Wall: Interior – 3 1/8” Partition (1-hr) (79 mm), as shown in Figure 9.24.

3. In the Properties dialog box, set Base Offset to 14’–0” (4200 mm), as shown in Figure 9.25.

4. Set Top Constraint to Up To Level: Level 3 (see Figure 9.25).
You’re now ready to place the soffit. You’ll add it to the radial hole in the ceiling. If you had nothing to guide you, you would need to draw the wall physically by using the Arc Sketch function. In this case, you can simply pick the radial portion of the ceiling opening.

1. With the Wall command still running, click the Pick Lines icon on the Draw panel.

2. Mouse over the radial ceiling opening. A blue alignment line appears. Make sure it’s to the inside of the opening, and then press the Tab key twice.

3. The entire circle is selected, and the blue alignment line is facing the inside of the hole (see Figure 9.26). When you see this, pick a point to the inside of the hole.
4. Press Esc twice, or click Modify.

Your soffit is complete.

Next you’ll add a secondary ceiling to the inside of the soffit. This procedure is carried out exactly as it was when you added a ceiling to the entire room.

1. In the Project Browser, go to the Level 1 ceiling plan, and zoom in on the ceiling with the soffit if you aren’t there already.

2. On the Architecture tab, click the Ceiling button.

3. Select Compound Ceiling: Wood Veneer On Metal Framing (if it isn’t the current selection).

4. Click the Edit Type button.

5. Click Duplicate.

6. Call the new ceiling Mahogany Veneer on Metal Framing, and then click OK.

7. Click the Edit button in the Structure row.

8. Click in the bottom layer’s (5) Material column, and click the [...] button to change the material that is now Cherry, as shown in Figure 9.27.

![Figure 9.27: Click the button to change the material.](image)

9. In the Material Browser, type mahogany in the search box, as shown in Figure 9.28.

10. Now that Mahogany is current, make sure you’re on the Graphics tab, and make the values match Figure 9.29.
FIGURE 9.28: Adding a new material to the project

FIGURE 9.29: Making mahogany
11. Click OK twice.
12. Click OK one more time to get back to the model.
13. In the Properties dialog box, change Height Offset From Level to 14’–1” (4225 mm).

14. Place the ceiling inside the soffit. Press Esc, or click Modify.

You need to adjust your plan region. It has to be set so the cut plane is either below or equal to 14’–1” (4225 mm) so you can see the lower ceiling.

1. Pick the dotted rectangle surrounding the rooms. This is the plan region.
2. On the Modify | Plan Region tab, click the View Range button.
3. Change the Offset value for the cut plane to 14’–1” (4225 mm).
4. Click OK.

Your ceiling plan should look like Figure 9.30.

---

**Figure 9.30:** The completed ceiling
**Never Assume Anything!**

They say you should never assume anything, and in this case “they” are right! Let’s add a section through this entire row of rooms to gain a perspective on what is going on here.

1. On the View tab, click the Section button.
2. Cut a horizontal section through the entire side of the building, as shown here:

![Diagram](image)

3. Select the section if it isn’t still selected.
4. In the Properties dialog box, change Detail Level to Fine.
5. Change the name to Section at West Training. (Yes, these are eventually going to be training rooms.)
6. Open the new section. You now have a clear perspective of what is going on with this area.

You’re getting there with this ceiling, that’s for sure! The only task left is to add some light fixtures.

### Adding Light Fixtures to Ceilings

Adding lighting fixtures to a Revit Architecture model isn’t a difficult task, but you must follow a few guidelines to achieve success in installing lighting. For example, you must work with the Ribbon to find a face in which to insert the component:

1. Go to the Level 1 ceiling plan where you’ve been adding the wood ceilings.
2. On the Architecture tab, click the Component button, as shown in Figure 9.31.

![Figure 9.31: Click the Component button on the Architecture tab.](image)

3. On the Mode panel of Modify | Place Component, click Load Family, and then browse to Lighting ➤ Architectural ➤ Internal ➤ Pendant Light – Disk.

4. Open the file Pendant Light - Disk.rfa (M_Pendant Light – Disk.rfa).

5. Place the light approximately in the center of the radial mahogany soffit (you’ll have to move it in a second).

6. Press Esc twice.

7. Select the fixture.

8. Click the Move button.

9. Type SC (for Snap Center).

10. Pick a point in the center of the fixture.

11. Type SC again.

12. Hover your cursor over one of the inside radial walls. A center snap appears. Pick the radial wall. Your fixture should snap to the center of the soffit (see Figure 9.32).

**NOTE** There are no snaps when you’re trying to place most components. You’ll have to place the fixture and then move it into position. Needless to say, this is an extra step.

13. Open the section called Section At West Training. Notice that the light fixture is in the exact location where you expect it to be.
14. Select the fixture.

15. Click the Copy button on the Modify Lighting Fixtures tab.

16. On the Options bar, be sure the Multiple button is selected.

17. Copy the fixture 3’–0” (900 mm) to the right and 3’–0” (900 mm) to the left (see Figure 9.33).
The main point of having you open a section to copy the fixture is to illustrate that you're now in a full modeling environment. When you switch back to the plan, you'll see that the fixtures have been placed. In later chapters, you'll learn that the act of simply placing fixtures in the model will also add line items to schedules.

**YIKES, THIS ISN’T TO OUR STANDARDS!**

Yes, the default line thicknesses are hideous. For now, you can click the Thin Lines icon to scale back the thickness of the lines, as shown here:

Now let’s make some more fixtures.

1. In the Project Browser, go to the Level 1 ceiling plan.
2. Zoom in on the radial soffit. You see the two new fixtures.
3. Select the right and left fixtures.
4. Click the Rotate command on the Modify | Lighting Fixtures tab.
5. On the Options bar, make sure Copy is selected.
6. Rotate the fixtures 90° to create a total of five fixtures, as shown in Figure 9.34.

**NOTE** Notice that the fixtures overlap the gypsum soffit. This is because you’re actually standing on Level 1 looking up. Revit Architecture has finally taken the confusion out of the reflected ceiling-plan mystery.

Now that you have experience dealing with ceilings, let’s start working on some interior design. Ceilings are a part of this, but what about wall treatments, trims, and architectural millwork? These items will be covered in the next section.
Adding Interior Design

Congratulations! You’ve arrived at possibly the most difficult subject when it comes to 3D modeling. Why is that? Well, for starters, this is the area where nothing is easy in terms of shape, configuration, and, for some projects, the sheer amount of millwork and detail. For example, suppose you want a crown molding at the ceiling where it intersects the walls. And suppose you need the same crown at the radial soffit. Of course, the floors and walls aren’t the same material, and you need to add furniture as well.

I can go on and on listing the complications you’ll face here, so let’s just jump in. The first part of the process is adding plumbing fixtures and furniture.

Adding Plumbing Fixtures and Furniture

To begin, you’ll have to knock out the less glamorous, but all too important, task of adding bathroom fixtures.

1. In the Project Browser, go to the Level 1 floor plan (floor plan, not ceiling plan).
2. Zoom in on the lavatory area, and turn off the thin lines mode, as shown in Figure 9.35.

![Figure 9.35: The lavatory area](image)

3. As you can see, there is a callout of this area. Double-click the callout bubble to open the view called Typical Men’s Lavatory.

**NOTE** Now that you’re more experienced with Revit, you can see the benefit of having named this view something understandable at this stage in the game.

4. With the Typical Men’s Lavatory view opened, you can start adding fixtures. On the Insert tab, click the Load Family button.

5. In the Imperial Library (or Metric) directory, browse to the Plumbing/Architectural/Fixtures/Water Closets/ folder.

6. Select the file called Toilet-Commercial-Wall-3D.rfa (M_Toilet-Commercial-Wall-3D.rfa), and click Open.

7. Go to the Architecture tab, and click the Component button.

8. If you see a dialog box asking whether you want to load a plumbing fixture tag, click No.

9. In the Type Selector, make sure the 15” Seat Height (380 mm Seat Height) toilet is selected.
10. Place it along the north wall approximately 6” (150 mm) from the west wall, as shown in Figure 9.36.

![Image of Revit interface showing toilet stall placement](image)

**FIGURE 9.36**: Placing the 15” (380 mm) Seat Height toilet 6” (150 mm) from the west wall, along the north wall

Because you’re not designing a military barracks from the 1960s, you need some stalls. Unfortunately, Revit doesn’t provide any stalls out of the box, but this book you bought does! To add toilet stalls to the model, go to the book’s web page at www.sybex.com/go/revit2017ner. From there, you can browse to the Chapter 9 folder and find these files:

- Toilet Stall-Accessible-Front-3D.rfa
- Toilet Stall-Accessible-Side-3D.rfa
- Toilet Stall-Braced-3D.rfa
- Grab Bar.rfa
- Double Sink - Round.rfa

Download the files to the location where you keep all your Revit families. Then, follow along with the procedure:

1. On the Insert tab, click Load Family.
2. Browse to the location where the new families are kept and select the new files; then click Open. They’re loaded into your project.

3. On the Architecture tab, click the Place A Component button.

4. Select Toilet-Stall-Accessible-Front-3D 60" × 60" Clear.

5. Pick the corner of the bathroom, as shown in Figure 9.37.

![Figure 9.37: Placing the accessible stall](image)

**Tip:** If you’re having difficulty placing the stall directly in the corner, place it at any location along the north wall and then move it to the corner so that it looks like the figure.

The next step is to copy the toilet and add another stall. It would be nice if the family just fit, but this isn’t a perfect world!

1. Copy the toilet to the right 6’–2 1/2” (1862 mm).

2. On the Architecture tab, click the Place A Component button.


4. Click Edit Type.

5. Click Duplicate.

6. Name the new stall type 54" × 60" Clear (1350 × 1500 mm Clear). Set the width to 4’–6" (1350 mm), and click OK.
7. Place the stall in the model (see Figure 9.38).

**Figure 9.38**: The two toilets and stalls in place

**Tip** You may have to press the spacebar as you place the stall to flip it into the correct position. Again, if you’re having difficulty placing the stall directly in the corner, you can place it along the north wall at any location and then either align or move the stall into the correct position.

With the toilets and the stalls in place, you need to add a grab bar to the accessible stall. Again, Revit doesn’t provide this content. You need to either make this component yourself (this is covered in Bonus Chapter 2, “Creating Families”) or use the one from the book that you downloaded with the bathroom stalls.

To add a grab bar, follow these steps:

1. Zoom in on the accessible stall, as shown in Figure 9.39.
2. Click the Place A Component button.
3. Select Grab Bar 4’–0” (1200 mm) Length.
4. Place the grab bar along the wall (see Figure 9.39).
**NOTE** As you place the grab bar, it will look like it’s going to be embedded into the studs of the wall. Don’t worry. After you pick the point where you want the grab bar, it will move to the finished face of the wall.

**NOTE** Remember, although it kind of feels like you’re just sticking blocks into your model, these are all 3D parametric parts. This grab bar, for all you know, is 6’-0” above the ground or sitting on the floor. To adjust this, you don’t have to cut a section or go to a 3D view. You can simply select the grab bar and, in the Properties dialog box, set Elevation to 2’-0”.

Because you’re in the men’s room, you need to add some urinals. You can fit two before you start getting too close to the sink area and the guy standing next to you.

1. On the Insert tab, click the Load Family button.
2. Browse to Plumbing Fixtures ➔ Architectural ➔ Urinals.
3. Select the file called Urinal-Wall-3D.rfa (M_Urinal-Wall-3D.rfa).
4. Click Open.
5. Click the Component button, and place two urinals about 6” (150 mm) away from the front of the stall, with a 1’-0” (300 mm) space between the two, as shown in Figure 9.40.

What a relief to get those urinals in! The next step is to install a sink with two stations in the bathroom. To do this, you can use the double sink you loaded from the book’s website.

1. On the Architecture tab, click the Place A Component button if it isn’t still running.

2. In the Type Selector, find the family called Double Sink – Round 24” Depth (Double Sink – Round 600 mm Depth).

3. Place it in the corner, as shown in Figure 9.41.

   If your door is 12” (300 mm) from the left wall, then you have a problem, don’t you? Luckily, you’re using an application that allows you to stretch a component dynamically.

4. Select the sink.
5. Click the leftmost stretch grip, and slide the sink to be flush with the door opening (see Figure 9.41).

The women’s room is the same size, and it will have two stalls and a sink. Create the mirrored layout shown in Figure 9.42.
With the first-floor bathrooms done, let’s move to some of the actual rooms and offices to furnish them. The first thing you need to do is add lighting to the ceilings.

**Adding Parabolic Troffers**

As you’re starting to see, the procedure for adding a component doesn’t change based on the component you’re adding. This is great news. Adding a troffer, however, is slightly different. You do need to be in a ceiling plan, and you do need to specify the face of the ceiling.

At this point, you may be good enough at adding these fixtures to simply look at the following figures and add the lights yourself. Or, if you desire a little help, follow these steps:

1. In the Project Browser, go to the Level 1 ceiling plan. (Notice that you’re going to a ceiling plan, not a floor plan.)

2. Zoom in on the northwest corner of the east wing, as shown in Figure 9.43.

![Figure 9.43](image)

**Figure 9.43:** Placing a light in a ceiling. You’ll align it to the grid in a moment.

3. On the Insert tab, click the Load Family button.

4. Browse to the Lighting Fixtures folder.

5. Select the file called Troffer Light – 2 x 4 Parabolic.rfa (M_Troffer Light Parabolic Rectangular.rfa).
6. Click Open.

7. Click the Place A Component button; then place the fixture in your ceiling (see Figure 9.43).

8. Click the Align button on the Modify tab, as shown in Figure 9.44.

![Figure 9.44: Aligning the fixture to the grid](image)

9. Align the light fixture to the grid in both directions (see Figure 9.44).

10. Copy the light to the locations shown in Figure 9.45.

![Figure 9.45: Adding lights to the rest of the ceilings](image)
11. Add lights to the rest of the rooms in the east wing, as shown in Figure 9.45. It’s quickest to place a single light horizontally and one vertically, align them to the grids, and then make multiple copies.

12. In the Properties dialog box, click the View Range button.

13. Set the cut plane to 4’–0” (1200 mm).

Next, you need to illuminate the corridors. This can be done by adding a set of wall-mounted sconces, as follows:

1. Browse to the Level 1 floor plan.
2. On the Insert tab, click Load Family.
3. Browse to the Lighting/Architectural/Internal folder.
4. Select the file called Sconce Light - Uplight.rfa. (M_Sconce Light - Uplight.rfa).
5. Add the sconce to the corridor wall, as shown in Figure 9.46.

![Figure 9.46: Adding a sconce](image)

6. Add sconces to the walls of the hallways as appropriate, as shown in Figure 9.47.
7. In the Project Browser, double-click the 3D view called East Wing Corridor Perspective. This gives you a good idea of how the up-lighting influences the corridor (see Figure 9.48).

8. On the View Control toolbar, click the Visual Style Icon, and choose the Graphic Display Options choice at the top of the dialog box, as shown in Figure 9.48.
9. For Photographic Exposure, check the Enabled box to turn on the exposure.

Well, that corridor is looking great! It’s time now to begin looking into the offices and also to see whether you can complete a kitchen area.

**Adding Casework and Furniture**

Adding casework and furniture is the easiest part of this chapter—that is, if you like the casework and furniture that comes right out of the Revit box. Something tells me this isn’t going to be adequate. For this chapter, you’ll be using the out-of-the box items, but in Bonus Chapter 2, you’ll make some custom millwork families.

To add some office furniture, follow these steps:

1. Select the Level 1 floor plan.

2. Zoom into the northeast corner office, as shown in Figure 9.49.

![Figure 9.49](image)

**FIGURE 9.49:** Placing the credenza desk into the first office

3. On the Insert tab, click the Load Family button.

4. Browse to the Casework/Base Cabinets folder, and select the following item: Base Cabinet-4 Drawers.rfa (M_Base Cabinet-4 Drawers.rfa).
5. Browse to the Furniture/Seating folder, and open the following: Chair-Executive.rfa (M_Chair-Executive.rfa).

6. Browse to the Furniture/Storage folder, and open the following:
   - Credenza.rfa (M_Credenza.rfa)
   - Entertainment Center.rfa (M_Entertainment Center.rfa)
   - Shelving.rfa (M_Shelving.rfa)

7. Click the Place A Component button; then, in the Type Selector, select Credenza 72” × 24” (1830 × 610 mm).

8. Place the credenza desk into the room, as shown near the top of Figure 9.49.

9. On the Architecture tab, click the Place A Component button if the command isn’t still running.

10. From the Type Selector, select Chair-Executive, and place it in front of the credenza, as shown in Figure 9.50.

11. In the Type Selector, select Entertainment Center 96” × 84” × 30” (2743 × 2134 × 762 mm) and place it in the corner (see Figure 9.50).
12. Place four 36” (915 mm) shelving units across the south wall, as shown near the bottom of Figure 9.50.

At this point, it's a good idea to take a perspective shot of this office to see whether the space is developing the way you were envisioning. Although you may never put this perspective view onto a construction document, it's still a great idea to see what is going on.

1. On the View tab, select 3D View ➢ Camera.
2. Pick a point in the northeast corner.
3. Pick a second point beyond the southwest corner, as shown in Figure 9.51. The new view opens. You’ll probably want to stretch the crop boundaries.

4. In the Project Browser, right-click the new 3D view, and call it Perspective of Corner Office.
5. See Figure 9.52 to get an idea of how to stretch the window to show more of the perspective.
It’s time for a kitchen! This is such a nice office that there seems to be a need for a break area right outside. You wouldn’t want your esteemed executive to have to walk very far for a cup of coffee or a snack.

To get started, you’ll load some countertops and cabinets.

1. On the Insert tab, click the Load Family button.

2. Browse to the Casework folder.

3. Load the following families. You’ll have to choose from the appropriate folders in the Casework directory.
   - Base Cabinet-2 Bin.rfa
   - Base Cabinet-Double Door & 2 Drawer.rfa
   - Base Cabinet-Double Door Sink Unit.rfa
   - Base Cabinet-Filler.rfa
   - Base Cabinet-Single Door & Drawer.rfa
   - Counter Top-L Shaped w Sink Hole 2.rfa
   - Upper Cabinet-Double Door-Wall.rfa

4. Load the file Corner Base Filler.rfa from the Chapter 9 directory on the book’s website.

5. Open the Level 1 floor plan. Zoom in on the kitchen area, as shown in Figure 9.53.
6. Add the countertop (see Figure 9.53).

7. Press Esc twice.

8. Select the countertop.

9. Select the stretch arrows, and stretch the leg of the counter to the end of the wall, as shown in Figure 9.54.

**Figure 9.53:** Adding the countertop

**Figure 9.54:** Lengthening the counter leg to meet the corner of the wall
10. Add the Base Cabinet-Double Door Sink Unit 30” (900 mm) under the sink hole in the north leg of the counter.

11. Align the base unit under the sink.

You now have a counter and a sink base. The problem is that you have no idea how high these items are or what they really look like. That's OK—this is Revit. You just need to create two elevations for these items, as follows:

1. On the Create panel on the View tab, click the Elevation button.

2. Add an interior elevation looking north.

3. Select the elevation marker, and turn on the elevation looking west (see Figure 9.55).

4. Rename the north elevation Kitchen North.

5. With the elevation marker still selected, click the check box to the west, and rename the west elevation Kitchen West.
With the elevations in, you can flip back and forth to make sure you’re putting items in the right places and to get a good idea of how your cabinet run looks. The remainder of the procedure involves adding the rest of the cabinets. Let’s do it!

1. On the Architecture tab, click the Place A Component button.

2. From the Type Selector, select Base Cabinet – Single Door & Drawer 24” (600 mm).

3. Place the base cabinet to the right of the sink cabinet.

4. Press Esc twice, or click Modify; then open the Kitchen North elevation. Does your elevation look like Figure 9.56?

5. Go back to the Level 1 floor plan.

6. Place a Base Cabinet Double Door & 2 Drawer 36” (900 mm) in the position shown in Figure 9.57.
7. Press Esc twice, or click Modify; then select the Kitchen West elevation.

8. Move the base cabinet so there is a 1” (25 mm) counter overhang, as shown in Figure 9.58.

![Figure 9.58: The 1” (25 mm) overhang on the end](image)

9. Copy the base cabinet to the right three times (four total cabinets), as shown in Figure 9.59.

![Figure 9.59: The base cabinet run](image)

10. Go back to Level 1, and click the Place A Component button.

11. Find Corner Base Filler.

12. Place it in the model on the side of the base cabinet, as shown in Figure 9.60.
13. Select the filler.

14. Stretch the grips until the filler resembles Figure 9.61.

The bases are done! Let’s add some wall cabinets to the kitchen.

1. On the Architecture tab, click the Place A Component button.

2. In the Type Selector, select Upper Cabinet-Double-Door-Wall 36” (900 mm).
3. Place the wall cabinet in the model, as shown in Figure 9.62. (Don’t worry too much about aligning it to the cabinet below. You’ll align it in elevation.)

4. Open the Kitchen West elevation.

5. Click the Align button on the Modify tab.

6. Align the wall cabinet to the base cabinet, as shown in Figure 9.63.
7. Copy the wall cabinet to the right three times (for four total cabinets).

8. Save the model.

Your cabinets should look like Figure 9.64.

![Diagram of finished west wall of the kitchen]

Now that the kitchen is in place, it would be nice to add a tile floor only to that area. You can accomplish this without having to add extra floors to the model. You can simply split the face of the floor that is already there and add an additional material.

**Adding Alternate Floor Materials**

Carpeting doesn’t perform well in kitchens. This is information you already know. What you don’t know is how to add tile to a carpeted floor system without having to cut the existing floor and start piecing in sections of alternate materials. That’s what you’ll learn to do in this section.

**Separating the Floor**

You have a floor area targeted for a new material, and the following procedure guides you through the steps:

1. Open the Level 1 floor plan. Click the Split Face button on the Modify tab, as shown in Figure 9.65.
2. Select the entire floor. This may require finding the edge of the floor along an exterior wall (see Figure 9.65).

3. Click the Line button on the Draw panel. Draw a continuous line around the kitchen, as shown in Figure 9.66.
4. On the Modify | Split Face ➢ Create Boundary tab, click Finish Edit Mode.

**NOTE** Remember, you can’t have any overlapping lines or gaps while adding your magenta sketch lines.

Although it doesn’t seem like it, you have split the kitchen from the rest of the floor. Next, you’ll apply a material to the kitchen. The first step will be to create a suitable material to use.

**Creating a Tile Material**

There is one tile material in this model, but it would be beneficial to create a new one with 12" (300 mm) square tiles. This procedure takes the place of using hatching in a conventional drafting situation.

Follow these steps to create a new material:

1. On the Manage tab, click the Materials button, as shown in Figure 9.67.

![Figure 9.67: Clicking the Materials button on the Manage tab](image)

2. In the Material Browser, type tile in the search field at the top of the dialog box, as shown in Figure 9.68; scroll down and select Tile, Porcelain, 4in (100 mm).

3. In the Material Editor, click Use Render Appearance under Shading, as shown in Figure 9.69. Click Done, and then click OK.
The new material is locked, loaded, and ready to spill onto the floor! To do this, you'll paint to apply the new material to the kitchen. Follow these steps:

1. Click the Paint button on the Geometry panel of the Modify tab, as shown in Figure 9.70.
2. Select Tile, Porcelain, 4in from the Material Class drop-down list, as shown in Figure 9.71.

![Figure 9.71: Selecting porcelain tile](image)

3. Place your paint icon over the edge of the kitchen floor until the region becomes highlighted.


Phew! You’re gaining a good amount of experience in terms of adding components and making the interior of the building conform to your design. If you think about it, you’ve done nothing here that is out of the ordinary. You’re simply replacing everyday drafting routines with modeling routines. What a way to go!

Because there is quite a bit of building left, go ahead and load up this model with components. If you get stuck anywhere, go back and find the procedure that pertains to your problem.
Are You Experienced?

Now you can...

✔ add ceilings to a room as well as create new ceilings and modify them to suit your needs

✔ transfer ceilings from other projects by using the Transfer Project Standards function

✔ add soffits to your model by using a typical wall and offsetting the base

✔ create a plan region so you can see elements at different elevations without disturbing the rest of the view

✔ add components such as bathroom fixtures, office furniture, and lighting to your model

✔ create subregions in which to specify alternate flooring, thus allowing you to avoid hatching