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1. Overview

1.1. Why Synchro PRO?

At Synchro Software, we are passionate about improving construction project performance because we understand the
impact construction has on global resources and we recognize the importance of the industry to quality of life and economic
prosperity. We have also experienced how significantly digital technology improves results over the tried and true methods
that have been standard in the industry for generations. Imagine crystal clear communications and engaged team
collaboration. Imagine the ability to easily create a shared vision of the project among your stakeholders, the ability to
identify spatial and resource clashes in the planning phase rather than the costly construction phase, imagine a project
schedule that gives you confidence to deliver according to plan!

1.2. Why 4D?

Scheduling and planning is critical to safe, efficient, high quality construction. While using 4D, the computer becomes a
practice field where sequences, safety, special relationships and more can be viewed and discussed continuously before and
throughout the project lifetime. Because Synchro links 3D Resources (human, material, equipment, and space) to the
associated Schedule tasks, making changes and comparing baselines to alternatives is quick and easy. Testing sequencing and
running “what if” scenarios is highly efficient and engaging. Communications are crystal clear, because you can see each step
in the process. Cooperative knowledge sharing creates innovation and unique approaches that build competitive advantage.
The result is an efficient, reliable and safe project delivery process that saves time and money.

1.3. Who uses Synchro PRO?

Contractors, Subcontractors, Specialty Supplies, Consultants and Owners use Synchro for the construction of buildings,
infrastructure, roads and bridges, healthcare facilities, Industrial, Oil and Gas, Power, Alternative Energy, Marine, as well as
Mining Projects.

1.4. How does Synchro PRO apply to you?

Synchro PRO integrates with Oracle Primavera and other scheduling software but it can also be used as a

stand-alone scheduling tool. In this tutorial, you will learn how to integrate your schedule with 3D models from most CAD
systems to produce a 4D schedule and visualization in virtual reality. Whether you like to see the schedule through the model
or see the model through the schedule, the ability to visualize your plan while maintaining its integrity allows project delivery
performance to consistently and reliably exceed today’s performance standards in an immediate and dramatic way.

1.5. Course Description

This course will take you through the basics for Synchro PRO. This course is appropriate for anyone involved in construction
delivery - including schedulers, virtual design coordinators, and project managers. The course will introduce you to 4D
scheduling in Synchro. It will cover everything you need to get started working in Synchro, including importing schedules and
models, linking 3D objects to tasks, inserting new tasks, subdividing geometry, animating equipment using 3D paths, and
producing outputs.

At the end of the course you will be able to import a model and schedule, fully link the model to the schedule using colour
coding and growth simulation, review the construction sequence, and export a video to present to stakeholders.

It is time to Synchronise your projects. As always, we welcome your feedback at any time, we look forward to seeing your
results and we hope you will share your experience with Synchro Software with others to spread the word. Thank you for
investing your time in learning Synchro PRO, together we will make a positive change in how projects are planned and

delivered.
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2. Workspace Layout
This section will present the various windows in Synchro and how to reorganize and manage your workspace.

2.1. Windows in Synchro

Quick Access Toolbar

Iim-AF-S84« +~ S8+

P WBIBOWE
- ki Tyoms i -+ 3ten = 84 =

Fait Settings

Task Resaurces ek Pocus | Ganit Made

Toolbars

Navigator, Resources,
& 3D Obiects

MNavigator

Properties

Task Properties -

External Data

= e
3D Wind | e e e e |
i INndow I
3D Objects tab Task Properties
Resources tab Resource Properties
Navigator tab 3D Properties
3D Path Editor

e Quick Access Toolbar contains commonly used icons. The Quick Access toolbar can be customized by left clicking on the down arrow
and selecting More Commands.

e Ribbon contains commands, sorted by category. In the top right corner of the Ribbon is the Help menu which can be used to find
more information about a particular feature

e Toolbars contain shortcuts and useful commands found in Synchro. Right click in the blue space below the Ribbon to view and select
available toolbars. Select Customise to create your own custom toolbar of commonly used commands

e Gantt Chart window displays the list of Tasks, which can be created, modified, linked, etc.

e 3D Window displays the modelled resources at any defined point in time.

o Navigator contains project-wide datasets logically grouped by the categories shown above; for example Project Details, Task and 3D
Filters, Viewpoints

o 3D Obijects contains the list of 3D Objects and Workspaces (including those imported and those created in Synchro)

e Resources contains the list of Resources (including those imported and those created in Synchro)

e Task Properties contains data related to the selected Task(s) including Task Status (in the General panel), assigned Resources, and
Budgeted Costs

e Resource Properties contains data related to the selected Resource(s) including Costs, assigned to Tasks, and User Fields

o 3D Properties contains data related to the selected 3D Object(s) and allows the user to manipulate them using commands including
Rotate, Translate, Scale, and Measurements.

e 3D Path Editor contains data related to the selected 3D Path and allows users to edit the existing path
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2.2. Workspace Management

1. Start Synchro PRO by double clicking on the icon on your desktop
You will be presented with the following opening Synchro screen layout-

.............

Navigator Task Properties
et

External Data

Synchro
Training

3D Using Dates[Best] [1288x400]

NOTE: If you need to download the training files, select Synchro Training and this will present you with the link to the FTP
site to download the latest material

2.2.1. Resizing Windows

.
2. Place the cursor at the top of the 3D Window so the double arrow icon == appears.
3. Select it with a left mouse click, hold down and drag the 3D window up. All windows in Synchro can be resized
by this method

2.2.2. Undocking and Relocating Windows

4. To undock a window, double click in the window header.

5. Toundock a single tab, left click on the tab and keep holding the mouse button while moving the mouse. The tab

|<| 1 |

¥ | Support | Gantt | Rules

|3D Using Dates[Best] [1236x291]

Double Click
Here

will be undocked as a new window.

If you are using multiple monitors, you can then move the new window to another screen.
7. Toresize the undocked window, hover over a corner until a diagonal arrow appears, then left click and drag to the
desired size.

| 4 | 1
Rules
ates[Best] [1236x291]

¥ | Support

3D Using &

Click & Hold
Here

8. Tore-dock the window in the previous location, simply double click the window header.
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To re-dock the window in a different location, left click and drag in the window header. Move the mouse over
another window until the smart window placement icons appears. Hover over one of the icons — a blue preview of

9.

where the window will be place will be shown. Release the mouse button to place.

e | Task Propertics

30 Objects o S [ — o

Smart window
placement icon

2.2.3. Reset layout
10. If you close any of these windows, you can re-open them by selecting the appropriate icons in the Windows ribbon

Untitled - Synchro

C-Ho8#=5-
HOME GANTT 3D PLAY WINDOWS “~ HELP ™
= T 5 ENY % W & H BaEabh 2@ &0 s F OGO
Navigator Gantt Task 3D 3D 3D 3D 3D Path Resources Resource Rules Resource EWA  User Field Resource Task Resource Line Of | Browser Focused Animation Full Refresh Reset
Properties Legend Objects Properties Properties Properties Utilisation Graph  Graph Chart Usage Usage Balance Time Editor Screen  All Layout~
Main Windows Graph Windows Other Windows Layout
11. To reset the window layout to the default, select Windows=> Layout=>Reset Layout
m-Ar-T8 =2 5=
HOME TASK 3D PLAY WINDOWS Th d ) ) | | f | f
- ; is command is particularly useful if you
— = - : v = by P
= T 5 ¢y ® & & H O i | ) .
igator nt as| 'at esources Resource ules u efres esource
Navigator Gantt  Task 5D 30 | 3D 3D 3DPath R R Rul Full Refresh| 1 R cannot locate a partlcular window or the
Properties Legend Objects Properti perti perti Screen Al - Utilisation &
Main Windows Layout . layout is changed when switching from
Install ~ || Finish -> Start ~ || Project Calendar - |t | t t |
multiple monitors to only one.
3D Objects v x o Name 2 P y

Name . - IE s
s

Reset Layout
Export

<all>
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3. Importing Schedules/Plans

This section will demonstrate how to import a schedule/plan from another source and manipulate the Gantt Chart display
options.

You can import a range of different schedule/plan files into Synchro PRO. The types of plan/schedule files that can be
imported:

e Synchro PRO and Synchro Scheduler (.SP file extension)
e  Asta Powerproject

e  Microsoft Project XML

. PMA NetPoint

. Primavera P3

. Primavera P6

o |FC

NOTE: Asta Powerproject, Primavera P3, and Primavera P6 require additional set-up before schedules can be imported.
Please contact support@synchroltd.com for more information.

Synchro PRO and Synchro Scheduler are both complete CPM scheduling tools for construction — users can create a schedule
from scratch, calculate the critical path, manage resources and costs, create baselines, track progress, and compare
schedules. Synchro Scheduler is essentially Synchro PRO without 3D/4D capability and is available for free to anyone whose
company owns a Synchro PRO license.

For this training, we will import a schedule in Microsoft Project XML format

3.1. Importing a schedule from Microsoft Project XML

1. Toimport aschedule, select File=>Import then select the source program. For Microsoft Project, select
File=>Import=>Microsoft Project XML as shown below

. New ’\ Asta Powerproject

. Open 4 m Microsoft Project XML
ﬂ Save HatFcint PRAA NetPoint

E-—l Save As s

533 Log in as different User... @ Primavera P&

=p=q send... @ FC

B Import 4 W 3D

B Export 4 i} Synchro project

Print... ~5
= =

H-E] Print Preview
[~
[ J Print Setup...
|

Search Command 2 4+ Options...  Exit

2. Select Browse to locate and select the Training Project Schedule.xm/ file, then select Open
3. Select Next>
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Microsoft Project import ‘ ﬁ

How would you like to import this file?
Use the Selected Task to merge the data into the cument Project

4. This screen allows the user to choose how to

treat different attributes of the file on import. @ Append the data to the end of the cument Project
The Command for each Object can be Reframe Gantt to show imported data
individually set to Import or Skip. Choose how you would like to process each object
Keep the default settings Object Command

Tasks Import

Links Import

Task constraints Import

Costs Import

Calendars Import

Resources Import

Resource assignments Import

Activity codes Import

Codes assignments Import

User fields Import

User field values Import

Users Skip

Defaut | | Skipal |
’ < Back ][ Impart ] ’ Cancel ] [ Help ]

N

5. Select Import. A Progress bar will display Y ——— ‘ S |
while importing and the Output panel will

display what was imported and any relevant
notifications. Bk e
Storing information ...

NOTE: This data can be copied and pasted . ™=

into a text editor for future reference by
Output

using the Select All and Copy to clipboard

Import completed successfully
buttons 0 activity codes were imported

0 code values were imported

1 calendars were imported

. 118 tasks were imported

6. Select Finish 0 resources were imported

0 resource assignments were imported
0 user fields were imported

0 user field values were imported

Select All Copy to clipboard
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7. Select (left mouse click) the Gantt tab (at the bottom of the Support Panel) to display the Gantt Chart.

The imported schedule should look like this:

- |Jan 2016 |Jan 2017
(] Name Duration Start Finish | [Apr [Jul [Oct [ [Apr [aut
E| k-1 [wic 13 wk 26 wk 38 [wk 52 [wi 85 [wi 78
1 4 Office Building. Core & Shell 323d 9:00 AM 1/4/2016 5-00 PM 3/29/2017 — w Office Building,
2 4 Pre Construction 20d 9:00 AM 1/4/2016 5-00 PM 1/29/2016 v==y Pre Construction
3 STOD020 Netics to Proceed 0 Days 9:00 AM 1/4/2016 () a@hotice to Proceed
4 STOD030 Building Permit 20d 9:00 AM 1/4/2016 5:00 PM 1/29/2016 i Building Permit
5 STOD040 Award Subcortractors 10d 5:00 AM 1/4/2016 5:00 PM 1/15/2016 Mhaward Subcontractors
[ STODOS0 Perimeter Fence & 9:00 AM 1/25/2016 (7 500 PM 1/27/2016 Fq Perimeter Fence
7 STODDS0 Temporary Hard Standing 1d 9:00 AM 1/27/2016 500 PM 1/27/2016 Temporary Hard Standing
8 STOD070 Field Office P2 9:00 AM 1/28/2016 5,00 PM 1/29/2016 Fiold-Off
9 4 Material Procurement 70d 9:00 AM 1/18/2016 5:00 PM 4/22/2016 w Material Procurement
10 STOD0SO Structural Steel 65d 5:00 AM 1/18/2016 5:00 PM 4/15/2016 i Structural Steel
11 STOD0SO Glass Curtain Wall 60d 3:00 AM 1/18/2016 5:00 PM 4/8/2016 ) HGkass-Gurtain Wall
12 STOO00 Elevator 65d 9:00 AM 1/18/2016 5,00 PM 4/15/2016 i
13 STOO10 MEP Equipmert 70d 9:00 AM 1/18/2016 5,00 PM 4/22/2016 N Hiprent
14 4 Construction 257d 9:00 AM 2/1/2016 5:00 PM 1/24/2017 w Consiruction
15 4 Site Construction 247d 9-00 AM 2/1/2016 5:00 PM 1/10/2017  _ Site Coppstruction
4| n L3 4 nr L3

In Synchro, the left side of the Gantt window is called the Task List and the right side is referred to as the Gantt Chart.
3.2. Gantt Chart Navigation

8. Move the mouse into the Gantt Chart area.
9. To Pan, hold down the middle mouse button then move the mouse up, down, left and right.
10. To Zoom, roll the middle mouse button wheel forward and back to zoom in and out respectively.
11. This schedule is organized by Work Breakdown Structure (WBS). In the Gantt ribbon, ensure that Gantt Mode is set
to WBS. Schedules may also be structured via Activity Codes or List (no summaries or indent structure).

L m-Ar-Qfe-»B5-
.E. HOME TASK 3D PLAY WINDOWS
[
= == Q\é E |
an

WEBS
Screen™ =

Create Focus Maove Links Gi

= wes
Install - || Finish -> Start

. — - |

Nawgator ¥ == Adivity Code |
External Data I= L

3

12. Click on the =l minus button next to any WBS summary to collapse the schedule to that level. When collapsed, click
the [# plus button to expand the summary task.
13. Right click in the Task List and choose Collapse =All to view only the top level Task.

Jun 2015 |Jan 2016 |Jan 2017 [Jan 20

»

L] Name Duration Start Finish [Jul Joct | [Apr [ [Oct | [Apr [Jul Joct |
lwk T8 Iwk 31 k44 |wk57  [wk70  |wkB3  [wk96  |wk109 |wk122 |wk135  [wk 149
1 [ Office Building. Core & Shell 323d 9:00 AM 1/4/16 5:00 PM 3/29/17 i | O Com R

14. Right click again and choose Expand =All to see all the tasks again.
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3.2.1. Customise Columns

Synchro gives you the option to customise the columns shown in the Gantt chart by adding or removing columns, or
changing the order or names of the columns displayed.

Customise Columns

15. Right click in the heading field of the Task List and select

Available Columns Selected
“Customise Columns” (below left) to open the “Customise 5 Task Paramete__ |- D ™
” A . % Complete Name
Columns” window (right). » 3D Resources ~ 7| Duration Eom
= Actual DirectC.. | - Start
(b} Name Duration Crart Actual Duration | Finish Rename

Actual Finish

Actual Physica...
Sort Descending Actual Start

Actual Total C
Baseline Finish
Baseline Start

Sort Ascending

A v
A v

Ascending Critical Path
v Sortvia WBS Level

Customise Columns... Budgeted Dire..
Budgeted Tot.
Open Layout... Calendar 0K

Save Layout Comments
Save Layout As... Completion Va...
Constraint

Import Global Layouts... Cost Variance Help

Export Global Layauts... =

16. In the “Customise Columns” window, select a Task Parameter on the right under “Available Columns” and press the
outlined arrow (above) to move the Task Parameter to the left under “Selected”.

17. Conversely, to remove a column, highlight a Task Parameter under “Selected” and press the left arrow to move the
parameter back to “Available Columns”

18. Once you have finished adding and removing Task Parameters, you can re-order the columns by highlighting a Task
Parameter in the “Selected” Column and pressing “Up” or “Down”. Similarly, you can rename the Columns titles by
highlighting the parameter and pressing the “Rename” button.

NOTE: The first Task Parameter in the “Selected” column is the furthest left column in the Task List.
3.3. Date Display

The time and date format can be changed to match the local convention.

. . Opti &J
19. From the Home ribbon or the Quick Access i
. ) ) ) <all> #| Time D Format
Toolbar, select the & Options icon. This will P me Display
open the Options dialog which contains man » Time Display Fomat Tne Depiy Foma
P P g y Duration Display Format (2 Long date format
settings related to all aspects of Synchro Curency @ Short date format
Recent Files
including the customization of the Gantt Chart Undo Redo 7] Display Time of Day
. . G " -
and 3D view, as well as scheduling and e [22H Cook (HH:MM) DO/MM/YY ]
Synchronisation preferences. E::tetjlgzizzinrdimaﬁon Sample: 11:50 20/05/15
20. Expand the General tab, and select Time Web Browser Frst day of week
. Automatic Check for Updates
Display Format. Loginto Private Project
) ‘Wamings & messages
21. From the first drop down menu, select 24H Look 4 Feel
Clock for this training. This will set the date b St
format to DD/MM/YY. There is also the option :V' F;qm
> Synchronisation
to hide the time of day, but we will leave it on b Defauits for New Objects
. - Plug-n Modules
for this training. b Synchra Reasoner
You can leave the Options dialog open for the
next section
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4. Auto Save

This section will teach you how to use the Auto Save and Backup functions in the Options menu to ensure your will lose no data
while working on your Synchro Project.

At this stage it is worth activating the Auto Save and Backup functions.
1. In Options=>General=>Auto Save, enable Auto Save Project and designate 30 minutes (optional)

NOTE: The time specified for the Auto Save will depend on the size on the file. Larger files take longer to save and the file
will be un-editable during the auto save process, so you should pick a frequency that balances time waiting and amount
of work you are willing to lose if the file or computer crashes.

2. Enable Backup project file when opened and Browse to select a convenient location.

NOTE: You will need to empty this folder from time to time as a time-stamped backup file is created every time you open
a project. These automatically generated backups can be very useful to return to an older copy if you find a mistake later
on or want to access work you’ve since deleted. The Auto Save file and any DMP (dump) files will also save in this folder

3. If Auto Save is enabled, it is recommended to enable Delete auto saved file on normal exit. This command will delete the
Auto Saved files (but not the Backup file) when you close Synchro normally. Otherwise, the file will be available to the
last Auto Save point if necessary.

[ Options @1

zall: Auto Save
4 General
Time Display Format

Auto Save Project

Duration Display Format = 30 - Minutes
Currency Del dfi | exd
Recent Files elete auto saved file on nomal exit
lUndo Red
nde hede Backup project file when opened
Copy
b Auto Save )
Delete Object Confimmation Auto save and backup data location
Edit Al Selected |C:"-.Llsers"- | [ Browse. .. ]
'Web Browser
Automatic Check for Updates These settings are unavailable for Synchro with OODE

Login to Private Project
Wamings & mezsages
Look & Feel
> Gantt Chart
I+ 3D View
AVI Export
I+ Synchronisation
[+ Defaults for New Objects
Plug-in Modules
I» Synchro Reasoner

Rezet ] l Ewpart... [H]S l[ Help
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5. Importing Models

In this section, you will learn how to import various external 3D model files and what settings to use to optimize the model

within your Synchro Project.

Synchro PRO can import 58 file types for 3D models including DWF, DWG, DGN, SKP, 3D PDF, and IFC. Multiple file types can
be imported into the same master Synchro Project.

NOTE: For a full list of importable file types, please see Appendix A: 3D File Formats.

Additionally, there are Synchro plugins available on the Synchro website to convert Revit (RVT), Navisworks (NWC, NWD,
NWF) and Bentley (i-Model and DGN) to Synchro Project format (SPX). For more information on the Bentley and Revit

workflows, please see Appendix B and Appendix C, respectively.

5.1. Importing 3D Files

This section will define and explain various 3D import settings and teach you how and when to use each.

1. Select & File>Import> % 3D

2. Select Add files. Browse to locate the training models. By holding down the Ctrl key you can select multiple files

for import. Select the following files:

Site.dwfx
Landscape.dwfx

3. Select Open
Select Next=> to view the import settings. Ensure that your settings match those in the image below right.

Read Unit Information — when enabled, processes the unit information of
the 3D Object (i.e. cm, inches)

Read 3D Text Annotations — when enabled, Synchro will process any text
assigned to the 3D Object in the CAD file

Process User Fields — when enabled, Synchro will import system- and user-
generated parameters (or tags) with the 3D geometry as User Fields

Ignore Hidden 3D Objects — when enabled, objects that are hidden by
filters or other display controls in the 3D file will not be imported into the
SP file

Ignore Wireframe 3D Objects — when enabled, polylines, lines, circular
arcs, circular arcs, circles, elliptical arcs, ellipses, and nurbs curves objects
will not be imported into the SP file

Load 3D Objects into memory - controls whether imported objects are
automatically loaded into memory. If disabled, imported objects will not
be loaded into memory and will not be visible in the 3D window. Disabling
this option tends to reduce the time to import and is recommended
especially for large files.

NOTE: To load/unload an object from memory after importing, check the
box next to the object name in the 3D Objects window

Default Tessellation Accuracy — allows the modelling engine to determine
its own Tessellation accuracy to control Tessellation.

NOTE: “Tessellation” means the surface of the geometry is built using
triangles. High tessellation will slowly render very detailed geometry
surfaces. Low tessellation will quickly render less detailed geometry
surfaces.

Import 3D

Measurement Units
Read Unit Information

All 30 Formats

Read 3D Text Annotations
Process User Fields

Ignore Hidden 3D Objects
lgnore Wirsframe 3D Objects
[ Load 30 Objects into memory

Limit 30 Object tree levels by:
{ Dis unlimited )

Default tessellation accuracy
Custom tessellation accuracy

SKP Format
[ Process layers as fiters

<Back | [ New> ||

][Cancel ][

Help

SKP Format (Process Layers as Filters) —when enabled, processes Sketchup Layers as Filters

5. Select Next=> to view additional import settings related to the geometry location, scale and rotation. We do not

need to edit any of these settin

s for this training.
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NOTE: The Rotate (DWF Format) option can be enabled to apply a 902 rotation about the X Axis specifically to
Autodesk published DWF where the Y axis is set as vertically up.

6. Select Import. A progress bar will display while the files are importing.

7. When the import is finished the Resource Wizard will appear.

5.2. Understanding Resources

e When 3D Objects are imported into Synchro, they are just 3D Representations/ Geometry that can be
viewed and manipulated in the 3D View.

e Inorder for 3D geometry to be linked to the project schedule they must be assigned to Resources. These
can be considered ‘3D Resources’ which can be in essence a copy of the object name or several objects
grouped together as one ‘3D Resource’

e A Resource is anything utilised by a project schedule. In Synchro, Resources are categorized as Equipment,
Human, Location, or Material. Resources do not necessarily need to have a 3D representation.

5.3. Resource Wizard

This section will show you how to properly use the Resource Wizard to create resources during your 3D model import.

8. Choose Assign to a new Resource and select Next=>

Resource Wizard... &l

Assign to existing Resource
(@ Assign to a new Resource

() No assignment

< Back [ Mes > ][ Cancel ][ Help ]

Synchro Software Ltd. \ M

NOTE: Selecting “No assignment “will finish the 3D import

process without creating any Resources. These 3D objects _ ) )
'0 Some of the selected 3D Objects were not assigned to Tasks,
4

would not be able to be assigned to Tasks until Resources ' because they are not Resource representations.

were created. If you receive the warning shown to the _ ) )

] o . The 3D Objects which are not Resource representations have
right, it is likely because you chose No Assignment on been left selected. l
import. You would then need to create Resources for the

3D objects by activating the Resource Wizard manually.
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9. Enter Site for the Name and make sure the Type is set to Material,

' ™
Enter Resource details... @

NOTE: Name will be the top node of the
resource tree, so always pick something
that will help you identify the contents.

Compary ’New Compary v]

; Resources are owned by Companies. If
MName  Site

you have previously set up Companies
Tive [ Materal - for the project in Navigator =

Companies, these will be available in the

Company drop-down; otherwise Synchro
will create a New Company which can be
renamed later.

[ <Back |[ Net> | | Cancd | [ Hep |

10. Then select Next=>. The Resource Creation options will show next. This step merits further explanation in the next
section

F |
Resource Creation... @

L
ET.-. Resource

-- Resource

=)
=

@ )
b0 ok

() Assign to this Resource, dont build tree
() Add Resources undemeath, dont build tree
() Assign to this Resource, build tree

@ Add Resources undemeath, build tree

Resource tree maximum depth (0 means unlimited) 0
The curmrent 30 Object tree is 5 levels deep

<Back || Fnish | [ Cancel | [ Hep
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5.4. Resource Creation Options

The Resource Creation options can be used to help filter or group the imported 3D objects. The easiest way to describe
this is if we consider an example.

This crane model is split into 5 CAD files called 1 to 5, each containing several items. The following sections will
demonstrate the result of choosing each of the 4 Resource Creation options.

N

2

5.4.1. Assign to this Resource, don’t build tree

The first option, Assign to this Resource, don’t

build tree, creates a single resource in which MVWVVW —1

multiple objects are grouped when importing >

one or multiple 3D files.

In the example of the crane, if you chose 3 Tower Crane

Assign to this Resource, don’t build a tree, all 4
5 files will be imported and assigned to one

Resource for the whole crane, which you —————— 5§

could name Tower Crane.

5.4.2. Add Resource underneath, don’t build a tree

The second option, Add Resource
Tower Crane

underneath, don’t build a tree, creates one T T | g :
resource for each file, to which any parts are @

combined within each 3D file name. 2 2
If you chose this option in the example of

the crane, you will import files 1 to 5 and 3 3
will have 5 resources named as the CAD file

names (1, 2, 3, 4, 5in this example) under 2 i
the Resource heading Tower Crane so that 5 5

the crane is split into 5 resources, one for

each file.

PRO|13




Synchro PRO Basic Training: Importing Models

5.4.3. Assign to this Resource, build tree

The third option, Assign to this Resource, build tree, creates multiple resources with the same tree structure as exists in
the corresponding 3D objects list when importing one 3D file. When importing multiple 3D files, the tree structures will
be merged.

If you chose this option in the example of the crane, Synchro will import files 1 to 5 and create a resource for each of the
individual items of the crane, as a list under the heading Tower Crane.

WIIIII [ M—

i Tower Crane
Jig
Slewing Unit
2 Cahin
Mast Part 41
Mast Part 42
3 Mast Part A3
Mast Part 34
Mast Part 2B
4 Mast Part 3C
Mast Part 44
Mast Part 4B
5 Mast Part 4C
' Magt Part 54
Mast Part 5B
Mast Part 5C

5.4.4. Add Resources underneath, build tree

The fourth option, Add Resources underneath, build tree, creates multiple resources with the same tree structure as
exists in the corresponding 3D objects list when importing one OR multiple 3D files.

If you chose this option in the example of the crane, you will import files 1 to 5 and will have a resource for each of the
individual items of the crane with the same tree structure as the CAD data under the Resource heading Tower Crane.

Tower Crane

1
1 1ig
2 Slewing Unit
Cahin

Mast Part a1
Mast Part &2
Mast Part 43

Mast Part 34
Mast Part 3B
Mast Part 3C

2
4 3
4

Mast Part 44
Mast Part 4B
Mast Part 4C

5 MMast Part Sa
MMast Part SB
Mast Part 5C
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5.4.5. Which Option to Choose

Which option you choose depends on whether you are importing one or multiple files and how you intend to use the
models in Synchro.

Generally speaking:

e  Use the first or second “don’t build tree” option to group all the objects within a CAD file as one; for example an
equipment model with all its subparts (wheels, bolts, etc.) that does not need to be assembled in the animation,
but will be assigned to tasks as a whole;

e Use the third or fourth “build tree” option if you want to assign model objects separately to different tasks.

e The bottom option “Add Resources underneath, build tree” gives you the largest object tree and the most
options for filtering and assigning resources to tasks.

In the crane example, we would pick the first option Assign to this Resource, don’t build a tree if we just want to assign
the whole crane to the tasks that utilize it. If however, our schedule includes multiple tasks for the assembly of the
crane part by part, we should choose the fourth option Add Resources underneath, build tree.

5.4.6. Resource Tree structure

For this training we will give each individual item a separate resource

11. Select the bottom option Add Resources underneath, build tree
12. Select Finish

At this point Synchro will read-in the 3D files, analysing their content and creating associated material resources

13. In the Resources window, under Material Resources expand the Site node to see that both files have been given a
separate node in the Resource tree.

Resources v X
MName Type &
<all: 2l 2
4 Material Resources
A Site Material
[ Landscape.dwx Material
[ Site.dwhx Material

14. Right click anywhere in the Resources window and select

Expand=>All to see the full Resource tree. You will notice Hes s M.
that each object is its own resource (the bottom node of e Tywe =
the tree) zall 2ol P
4 Material Resources

A Site Material

A Landscape .dwfx Material

4 Foors (12) Material

A Floor (12) Material

4 Grass (B) Material

JFioor 15950281 | Materal

Floor [853840] Material

Floor [858325] Material
Floor [866351] Matenial =

Floor [941228] Matenial

Floor [341462] Material
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15. Open the 3D Objects window.
16. Right click in the 3D Objects window and choose Expand=>All. Here you can see that the Resource tree is essentially
a copy of the 3D objects tree. This is because we chose the Add Resources underneath, build tree Resource Creation

option.
Resources v 1 X
3D Objects v 7 x
Name =
<all: 2o o Name &
4 Material Resources <all> fel
4 Site Material 4 || Objects of scene
4 Landscape dwhx Material 1 A [4] Landscape. dwix
A Floors {12) Material 2 4 [W] Foors (12)
4 Foor (12) Material 3 4 [ Floor (12)
4 Girass (8) Material 4 4 W] Grass (8)
|Floor [595028] | waterai 5 [|Fioor [535028]
Floor [853840] Material & = Floor [853240]
Floor [858325] Material 7 [® Foor [858325]
Floor [866391] Materisl  |= |8 (] Floor [866391]
Floor [541228] Material 3 [®] Foor [941228]
Floor [941462] Material 10 [®] Floor [941462] |

5.5. Load 3D Objects

You will notice that although the 3D Objects and Resources windows are populated, there is no 3D geometry in the 3D
Window. This is because we disabled Load 3D Objects into memory when importing the files. Objects that are not loaded
into memory will not be displayed in the 3D window. Objects can be loaded into memory using the check boxes in the 3D
Objects window.

17. In the 3D Objects window, enable the check box beside Landscape.dwix. The Landscape geometry will show in the

3D Window.

3D Obijects ~ # x 3D Using Dates[Best] [611x397] v B X

Name =3
i :ali: el
V] Objects of scene

1 A Landscape . dwix

2 4 W] Floors (12)

3 A [H] Foor (12)

4 4 W] Grass (5)

5 [®] Floor [595028]

6 M Floor [253340]

7 M Floor [258325]

2 [®] Floor [266351]

3 [®] Foor [341228] |

10 [ Floor [341462] 3

11 4 [E] Paving Wallkeway (1)

12 [® Foor (8523801

13 4 W] Roads1(1)

14 [® Part [1087582]

15 4 W] Sidewalk (3)

16 [® Foor [364434]

17 [®] Foor [264994]
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18. Enable the check box beside Objects of scene to load all 3D Objects into memory

NOTE: The first click of the box may unload all objects if some objects are already loaded. A second click will then
load all objects

3D Objects = & x 3D Using Dates[Best] [780x397] v & ox
| :all.: p
4 Objects of scene

1 I [ Landscape.dwix

2 [ Site dwix

m

NOTE: Objects and/or files can be selectively unloaded from memory to help increase the performance of large files

5.6. Duplicate Names Warning

This tutorial explains how to troubleshoot the Duplicate Names Warning that occasionally occurs when using the
Resource Creation Wizard. If left unresolved, duplicate Resource names can lead to improper Synchronisation.

19. Select & File=>Import=> % 3D

20. Select Add files. Browse to locate the training models. By holding down the Ctrl key you can select multiple files
for import. Select the following files:
e Architecture.dwfx
e  Structure.dwfx

21. Select Open

22. Select Next=> to view the import settings. Settings will be saved from the last import.

23. Enable Load 3D Objects into memory

24. Select Import

25. When the import is finished the Resource Wizard will appear. Choose Assign to a new Resource and select Next=>

26. Enter Office Building for the Name and make sure the Type is set to Material. By importing the Architecture and
Structure models separately from the Site and Landscape models, we are able to create separate nodes for Office
Building and Sitein the Resources tree to aid with selection and filtering. Select Next=>

27. For Resource Creation, again select the bottom option Add Resources underneath, build tree and

28. Select Next>
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You will be presented with the following Duplicate Names in 3D file! Warning

-

N
Duplicate Mames in 3D file! léj

i Warning!

This operation will cause 3D objects with duplicate names to
be assigned to Resources. This means that some Resource
assignments will be lost if you synchronise with an updated 3D
file. Ifyou intend to synchronise with updated 3D files. you
need to ensure all names for 30 objects are unique!

These are the duplicated names:
"SubPart1"(10) P

"SubPart2" (10)
"SubPart 1" (89)

| <Back | Fish | [ cancel | [ Help |

This warning will sometimes appear when you import a file that had been exported from Revit. Within this Revit file,
there are SubParts that appear at the bottom level of the 3D object tree, which is a result of copying and pasting in Revit.
These SubParts have no unique IDs, making it nearly impossible to identify any resource. If you select Finish, 3D Objects
with duplicate names will be assigned to Resources. If you ignore this warning and begin assigning Resources to Tasks,
and later synchronise from an updated 3D file, some Resource assignments will be lost because Synchro cannot
distinguish which 3D object is assigned to which Resource as they have the same name.

It is therefore important to ensure all names for 3D objects are unique! In the case of SubParts this can be done by
limiting the 3D tree depth on import.

29. Select Back. Note that the 3D Object tree is 6 levels deep

.
Resource Creation... léj

-

+
i BT Resource

T- Resource

8
00 (0b)

w
=}

(") Assign to this Resource, don't build tree
() Add Resources undemeath, don't build ree
(7) Assign to this Resource, build ree

(@ Add Resources undemneath, build tree

. imited)
I The current 3D Objecttree is 6 levels deep i 0

| <Back | Nex> | | cancel | [ Help |

30. At this point, you could select Cancel to undo the 3D import and start again. For the purposes of training, select
Next—> and then Finish
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3D Obijects
31. In the 3D Objects window, right click and choose Collapse=>All Name
32. Right click again and choose Find 3D Object <l P
4 || Objects of zcene
1 A Architecture_dwfx _ 1
2 [> [® Curtain Panels (408)
Convert 3D Text to User Fields... 3 [> [® Curtain Wall Mullions (1087)
@5 Convert to 30 Path 4 [ E Doors (30)
@ Find 3D Object... 5 I [® Railings (14)
: [ & [H] Roofs 2)
save 28 mage.. 7 [> @ Specialty Equipment (3)
™y 3D Properties 2 [ E Stairs (4)
9 [ W] Wall Swesps (2)
10 4 [B] Walls (38) f— )

33. Type SubPartin the Find 3D dialog and select Find Next 4 8] Bsic ial ) 3

[ W] Exerior Wall - Metal Siding (21)
[ [ Interior - Blockwark 200 (11)
I> [ Interior Partition Wall - 190mm {40)
4 [|] Parapet Wall (8) /]
4 [H] Basic Wall [82206 1 i 5
EFubF‘art 1 4—' 6

[®] SubPart 2

A [W] Basic Wall [322486)
[® SubPart 1
[®] SubPart 2

4 W] Basic Wall [822672]
[®] SubPart 1
[W] SubPart 2

4 [H] Basic Wall [822749]
[®] SubPart 1
W] SubPart 2

4 W] Basic Wall [823710]
[®] SubPart 1

30 [® subPart 2

Find 3D Objects...

Find what:  SubPart Find Mext
[ Match whole word [ | Match case Find All
["|search by User Fields

You can see that the SubParts are at the bottom or 6" level of the
tree. The unique object name is at the 5" level of the tree.

ERREMNNYNBgazIsaR o

B BN

MNavigator Resources | 3D Objeds

34. From the Quick Access Menu at the top of the screen, use the drop-down arrow to the right of the Undo icon to
view the list of recent commands. Select the first item in the undo stack (import) to undo the import of the Office
Building 3D files.

SIS E

.E. HOME TASK import

import

1]
L

|
= — import
Undo 1 Action

Create Foecus Mave Links |

We will now re-import the Architecture and Structure models, but this time, limit the 3D Object tree to a depth of 5
to eliminate the SubPart duplicate names.

NOTE: SubParts are always at the bottom level of the tree, but this is not always the 6" level. When the duplicate
name warning is encountered, use the Back button in the Resource Creation dialog to see the current 3D Object
tree depth (step 29 above), then limit the tree to 1 level less than the current depth.

To re-import the models, repeat steps 19 through 21 above.

PRO|19




Synchro PRO Basic Training: Importing Models

35. When you get to the import options (step 22), set the value for Limit 3D Object tree level by: to 5

I

Measurement Units
Read Unit Information

Al 3D Formats

Read 3D Text Annotations
Process User Fields

Ignore Hidden 30 Objects
lgnore Wireframe 30 Objects
[ Load 3D Objects into memory

Limit 30 Object tree levels by:
{ D unlimited )

Default tessellation accuracy

Custom tessellation accuracy

SKP Format
[] Process layers as fiters

| <Back | [ Ned> | [ mpot | [ Cancel | [ hHeb |

36. Continue importing and creating Resources by repeating steps 23 through 28. You will not receive the Duplicate
Names warning this time and will be able to successfully synchronise the file later.
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6. 3D View

In this section, you will learn how to navigate and customize the 3D View window.

6.1. 3D Window Navigation

It is highly recommended to have a mouse with left click, middle and right click buttons, as well as a scroll wheel (that has
center click capabilities).

e Zoom All - This will show all the objects from the front as the models have been created- it can be used if the view
becomes disoriented.

O\

0  Within the 3D window click the right mouse button and select Zoom=> Zoom All

0 Or from the Ribbon, select 3D Zoom=> o Zoom All

e Rotate - Hold down the left mouse button at a point in the 3D View that you want to rotate about, then move the
mouse

e Zoom - Scroll the middle mouse button forward to zoom in and back to zoom out

e Pan - Hold down the middle mouse button and move the mouse left, right, up and down

e View Cube - Left click on points or faces on the cube and the view will rotate to that viewpoint, or hold down the left
mouse button on the circle to rotate

View Cube Manipulatar

T A S NOTE: To enable your View Cube, please select 3D=>Fast Settings.

B Other Views Background - Check the box next to “View Cube Manipulator” (shown left).

6.2. Preferences

This tutorial will teach you which custom settings are available in the 3D View Window.

e In 3D Ribbon->Fast Settings, you can change the colour of the background for the selected and other 3D views.
e The ground plane grid can be turned on and off by right clicking in the 3D Window and selecting
Visual Indicators = Grid

Wisual Indicators b ale  Axis Indicator
30 Colours k| |3E| Grid
B Change Window Caption... EE Legend
B¢ 3D Paths

Cutting Planes k
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7. 4D Linking Process — Assigning Resources to Tasks

This section will outline how to attach your scheduled tasks to the resources created from your 3D import, to create a 4D

project.

The crux of 4D is creating links between 3D representations and schedule data. When the linking process is complete, the
view of the model will be controlled by the schedule - the 3D view tells the story of the schedule. The process for assigning
Resources to Tasks follows a simple procedure, which will be explained further in the following sections:

1.
2.

3.
4.

Left click on the Task to Select/Highlight

Choose the Resource Appearance Profile (which dictates how the Resource is to behave before, during, and after the
Task)

Select the Resource

Assign the Resource to the Task

7.1. Resource Selection

This tutorial explains the various methods to select a single (or multiple) resource.

When you select a 3D Resource, it will be highlighted purple in the 3D window (or selection colour as defined in
Options—>3D View-> Colours->Selection Highlighting)

Left Click -Single left click an object in the 3D window to select. Any object that you click twice will be deselected.

NOTE: If a single left click does not select an object, right click in the 3D window and enable Selection Tool=>Select
on Click

Selection Tool P T window

t) Window Polygon
i Crossing Polygon

+ Fence
% Select only Filtered

]
 Select Click
Create Task(s) , % Select on Clic

Find 30 Object...
Save as image...

3D Properties

Shift Select - When Select on Click is disabled, holding down the Shift button on the keyboard and single left clicking
with the mouse will select objects in the 3D View. You can continue to select objects while holding Shift. Objects
that you select twice will not be deselected

Ctrl Select - When Select on Click is disabled, holding down Ctrl on the keyboard will work similar to using the Shift
selection, except that any selected object that is clicked will be deselected.

Navigator Lists - You can highlight the name of the 3D Object or Resource in the 3D Objects, Resources, or
Navigator=>3D Sets windows

Window Box - By default, + - *Window Box will be selected in 3D = Selection Tool
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Hold down both the Shift button and the left mouse button then move the mouse so you can select by a window box
Selection depends upon the direction you draw the box:

a. Top Left to Bottom Right- All objects within the window box and all that it touches that are visible.
Selection: Result:
e 1 — =
ghd Click
b.

Bottom Right to Top Left- All objects completely within the box that are visible.
Selection:

Result:

—"“-%—m Click

c. Top Right to Bottom Left- All objects within the window box and all that it touches that are visible and non-visible.
Selection: Result:
O~ 15t Click

2nd uick\é- =

NOTE-You can also hold Ctrl on your keyboard instead of Shift to select and deselect objects using the window selection
methods shown above

Cancelling Selection - If you left click anywhere within the 3D Window then press Esc on your keyboard, the selection
will be cancelled.
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7.2. 3D Sets

3D Sets, or filters, can help with the 3D Resource selection process by limiting the objects visible in the 3D window. The
most commonly used filter (the built-in 3D Object Filter) is explained here. Users can also create their own custom filters,
which will be demonstrated later in the training. For more information, please see Section 12.1 User Fields.

1. Select Navigator-> 4 3D Sets. There are 3 built-in filters.
2. Tick the box to the left of 3D Object Filter and highlight the text as shown below:

3D Sets NOTE: The 3D by Selection [System] filter is

- S automatically enabled when using the 3D =>Filters

[] 30 tySelction(Systen]  [1 [ —>Show Selected or Hide Selected commands

D Same az Tazk Filker D D

3D Object Filer O The Same as Task Filter filters the 3D to show only the
objects assigned to Tasks included in the current Task
Filter

Operation

@4ND O OR

Active colour scheme

General
3D

3. Open the 3D Sets=>General Tab and ensure that the box is
activated next to 3D

General

@ Include matches

This filters the 3D View by the 3D Obijects list. Initially © Exclude matches

everything will disappear in the 3D view since nothing is
selected in the 3D tab

Company

Filker 30 k...

[ Mame

[] Tazk Filter
[] Resources
[] Compary
D

[] Uzer Fields

Exciude 30 which fails...
Ay Filter
Al Filkers
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4. Open the 3D Sets = 3D tab. Right click within the 3D list and select 0
Collapse =All. Then click on the icon left of the Objects of scene node @ Include matches
(circled right) to expand it. © Exclude matches
4 Objects of scene
If you expand each file, you will see that you then have the layer the items t Emﬂm“md‘::";‘ Mark .
=4 ndscape.
are on. [ |:| Site.dwfx Unmark 3
P D Stnsctur dwix Collapse » Al [
Click to expand a layer and you will see the individual items which you can Expand N — !
hide or unhide as you so wish.
Enabling (checking) the box next to the File Name, Layer, or Object Name Find 3D Object.-
will show the objects associated with each in the 3D View (Disabling/un-
checking will hide these objects the 3D View): Do

5. Select Mark All to enable all objects or Clear to disable

NOTE: You can begin with all objects disabled and begin checking files, layers, or objects to add to the visible scene, or
you may prefer to begin with all objects enabled and uncheck files, layers or objects to hide them from the scene.

Use the Exclude Matches rather than Include Matches options to hide all objects checked in the filter — this inverts the
visible and hidden objects

Filter via 3D Sets vs Load/Unload in 3D Objects window: The 3D Sets filters control the visibility of an object only. Un-
checking an object in Navigator=>3D Sets hides it in the 3D window; un-checking an object in the 3D Objects window
unloads it from memory (RAM) and also hides it in the 3D window. Unloading from memory will help improve
performance on large files. When an object is unloaded in the 3D Objects window, it will not be visible in the 3D view,
regardless of whether it is included in a 3D Sets filter or not — it must be enabled (checked) in both the 3D Sets and 3D
Objects window to be visible. For visualisation purposes and ease of sorting/assigning, it is recommended to use the 3D
Sets rather than 3D Objects list. The benefits to using the 3D Sets include: can save multiple filters, can create colour
schemes to affect filtered/non-filtered objects, can show the intersection (AND) or union (OR) of multiple filters, can
filter by other attributes than just the 3D Objects list (eg. text or parameters), and can easily switch between multiple
saved filters. For more information on 3D Sets, please see the Help Section in Synchro or the PRO Advanced training
course.

TIP: You can unload selected 3D Objects from the 3D View via Right-Click-> Edit=> M Unload Selected Objects.

Edit (I Simple Manipulator
15 Advanced Manipulator Ctrl=B
o ) . .
Render Mode , 1=  Manipulator with snapping to element
Col
Visibility y & Colour
Effects 4
Visual Indicators ¥ | & FReset Transformation(s)
3
3D Colours @ Remove 5elected Objects
1 Change Window Caption...
& Load Selected Objects

Cutting PI ,
Hiting Flanes 4 Unload Selected Objects
& Enable Markup Mode

©%  Enable Snapping
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7.3. Resource Appearance Profiles

The Resource Appearance Profile selected when assigning a Resource to a task dictates how the Resource is to behave
before, during, and after the Task. The Resource Appearance Profile controls:
e when the Resource is visible (before, during, and/or after) according to one of 4 Actions (Install, Maintain, Remove, and
Temporary)

e  the colour of the Resource in the 3D view before during and after the Task.
e any growth simulation or transparency interpolation during the Task

Select the Navigator> 5 Resource Appearance Profiles button

Under System Profiles you will see 4 predefined options which will be used when assigning to tasks. The functions of
these are shown in the table below.

FOCUS TIME
lpr Lpr [pr
PRO FI LE Before Task During Task After Task
| ~ ~
. _ . =
INSTALL e - /‘
Start Appearance Active Appearance End Appearance
MAINTAIN ’ ’ ’
B e T
Start Appearance Active Appearance End Appearance
. . = ’,_.
REMOVE ’ ’ .
s . |
Start Appearance Active Appearance End Appearance
TEMPORARY - - S
— .\. - __\ - \\-
Start Appearance Active Appearance End Appearance

These are the predefined Resource Appearance Profiles you can use.

Later in this tutorial you will create your own profiles where you can:

Set the Action

Change the Colours

Add Transparency

Set Different Start & Finish Transparencies
Show Growth Simulation

®T Qo oo
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7.4. Basic Linking Process

This section will guide you through the steps to link a 3D Resource to a Task using the Training Project model.

1. Single left click to select the task Temporary Hard Standing in the Task List. It will be highlighted yellow

- an 2016 |Feb 2016
D Name Duration Start Finish @ lath  Ti1th  Tieth  [25th [1st ’ﬂn [15th [22nd
wk 1 k1 fwk 2 fwk 3 fwk 4 wk 5 [wk & wk 7 w8 w]
1 4 Office Building. Core & Shell 323d 9:00 AM 174716 5:00 PM 3/28/17 v
2 4 Pre Construction 20d 9:00 AM 1/4/16 5:00 PM 1/29/16 v w Pre Construction
3 ST00020 Notice to Proceed 0 Days 9:00 AM 1/4/16 ) a@Notice to Proceed
4 5T00020 Building Pemit 204 9:00 AM 174416 500 PM 1/29/16 ilding Permit
5 STO0040 Award Subcontractars 10d 9:00 AM 174416 500 PM 1/15/16 Augeare aciqr
g ST00050 Perimeter Fence 3d 900 AM 1/25/16 () 5:00 PM 1/27/16 P Periteter Fence
7 ST00DGD ITempwEry Hard Standing Iw 9:00 AM 1/27/16 5:00 PM 1/27/16 Temporary Hard Standing
8 STOOO70 Fisld Office 2 900 AM 1/28/16 500 PM 1/29/16 RO
9 4 Material Procurement 70d 9:00 AM 1/18/16  5:00 PM 4/22/16 L
< m ] [ Kl | v

Enable the 3D Object Filter in Navigator=> 3D Sets to limit the displayed objects in the 3D view
Check the box to show only Site.dwfx
Rotate in the 3D view so that you are looking down on the site:

® 3D Using Dates[Best

@ Include matches

] Filters[3D Object Filter] [643x293]

() Exclude matches , //
a Objects of scene
> [ Architecturs dwfx
> [ Landscape dwhx
> [ Site dwhx

> [ Structure dwfx

4

5. Left click to select the hard standing beneath the site trailers (you may need to zoom in using the mouse scroll

[ Maran | | Clear ]

wheel)
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6. From the Fast Options toolbar located beneath the ribbon, ensure that Install is selected for the Resource
Appearance Profile

D m-Ar-Qfe-E2 5+
m HOME TASK 3D PLAY WINDOWS

Appearance Profile: (Install = || Link Type: Finish -= Start -
Calendar : |Standard -

Fast Settings

Install

Install
Nraaintain v 1 x
Remoave

ATemparary

4

Finish -= Start - || Standard

7. Right click in the 3D window and select Assign to Selected Task(s) from the context menu

Assign to Selected Task(s) Ctrl+Shift+A

Unassign from "Assigned to' Task(s) Ctri=l
Create Task(s) 3

Convert 30 Text to User Fields...
L Convertto 3D Path

Find 30 Object...
Save as image...

30 Properties

8. You will notice that a the 3D Resources column in the Task List turns blue for that task, indicating that a 3D Resource
has been assigned. The column also indicates the number of 3D Resources assigned. For this task it should read “1”

ID Name Duration Start Finish Recd
7 STDODGD ITE:rru::c:lT:lr:.l Hard Standing |1d 5:.00 AM 1/27/16 5:00 PM 1/27/16
8 STOOO7O Field Office 2d 5:.00 AM 172816 5:00 PM 1525716

4 Material Procurement 70d 9-00 AM 1718716 5-00 PM 4/22/16

PRO|28




Synchro PRO Basic Training: 4D Linking Process — Assigning Resources to Tasks

Open Task Properties=>Resources (on the right of the screen) and you will see the 3D model resource that you have
assigned to that task.

Task Properties A

Resources

<all= 0o
4 Material Resources
4 Ste
4 Site dwix
4 Floors (15)
4 Foor (15)
4 HARDSTANDING (1)
Floor [854875]

The hard standing model object may have disappeared from the 3D view. Once an object is assigned to a task, its visibility
is controlled by the red Focus Time bar in the Gantt Chart. In the Gantt Chart, The Focus Time is indicated by the red

dashed line with a triangle symbol on top.

Jan 2016 Feb 2016 |
8th [25th st [Bth [15th [22nd [28th .|
Wk 3 wk 5 [wk B _ lwk7 lwk 2 lwko %
i flemporary Hard Standing
P ield-Offiee

Data Date

NOTE: The Data Date is indicated by a vertical blue dashed line. This defines the project scheduling date for progress
reporting and can be confirmed and edited in Navigator=>Project>General

9. Leftclick and hold in the Timeline where the red triangle is and move the Focus Time bar left and right. This will
move the focus time to any point in time in the schedule.

TIP: You can also single left click anywhere in the Timeline and the Focus Time will jump to that point.
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10.

11.

12.

Move the Focus Time
before the start of the
Install Temporary Hard
Standing task. When the
Focus Time is before the
start of the Task, the hard
standing object is not
visible in the 3D window
because it has not yet been
installed.

Move the Focus Time
during the Install
Temporary Hard Standing
task. The hard standing
object is visible and
highlighted green according
to the Resource
Appearance Profile to
indicate that it is currently
being installed.

Move the Focus Time after
the Install Temporary Hard
Standing task. The hard
standing object is visible
and shown in its original
colour because it has
already been installed.

27th Jan 2016

Tth [28th |
%

pora

27th Jan 2016

27th Jan 2016
27th [22th |
wh 4
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7.5. Correcting Resource Assighment Mistakes

If you realize that you have assigned a Resource to the wrong task by mistake, you can make this correction by using one

of the following options:

Right click within the Task Properties=>Resources window and select Unassign All to remove all the resources.
If you want to remove just one resource, right click on each item’s lowest level (shown as Floor [854875]) and select

Unassign
3. Also you can select the object in the 3D View, right click and Unassign from ‘Assigned to’ Task(s)

'2 Assign to Selected Task(s) Ctrl=5hift+A
*x  Unassign from ‘Assigned to’ Task(s] Ctrl=U
Create Task(s) +

Resources
4. If you have assigned using the wrong profile you can change it

by selecting the lowest tree level of the resource in Task

. . 4 Material Resources
Properties=2>Resources and selecting the correct Appearance 4 Ste
Profile from the dropdown box below. 4 Site dwhx

4 Floors (15)
) . ) ) 4 Floor (15)
NOTE: After selecting and editing an object in the Task 4 HARDSTANDING (1)
Properties = Resources window, make sure you click in the » Floor [854875]
open space in this window or the 3D window and press Esc on select Al
your keyboard to deselect it and avoid accidentally assigning it Unassign 2
to another task later &  Unassign All 1 Ctrl=Shift+<U
Appearance [ 4 Focus Time On Assignment

Profile:
Transform Assigned Resource (simple)

Transform Assigned Resource (complex)

Find...
Expand 3

Collapse 3
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7.6. Linking Options

There are 5 different ways to link the 3D models to the schedule that can be used to the user’s discretion. They are listed
and explained below.

1. Assigned from 3D Window via right click
i Select the desired task(s)
ii. Select item(s) within the 3D window so they are highlighted
iii. Right click in the 3D window and select Assign to Selected Task(s)

2. Assigned from 3D Window via drag and drop
i. Select item(s) within the 3D window so they are highlighted
ii. Hold down Ctrl and Alt keys on your keyboard and the left mouse button then drag the cursor over the
desired task, letting go to assign it

NOTE: With this method, you do not need to pre-select the desired task so that it is highlighted. The selected
Resources can only be assigned to 1 task at a time using this method

3. Assigned using ‘Ctrl + Shift + A’ quick key
l. Select the desired task(s)
Il. Select item(s) so they are highlighted
M. Click in the 3D window, then simultaneously hold down the Ctrl, Shift and A keys on the keyboard

NOTE: The selected Resources can be assigned to multiple tasks using this method. You must have clicked in the 3D
window last to use this shortcut (ie. select task first, then objects in 3D window)

4. Assigned from Resources or 3D Object window via right click
i Select the desired task(s)
ii. Select the Resources or 3D Objects tab
iii. Select item(s) so they are highlighted
V. Right click on the 3D Object/Resource name and select Assign to Selected Task(s)

5. Assigned from Resources Window via drag and drop
i Select the Resources tab

ii. Select an individual item within the Resources list or an entire level of the Resource tree (eg. file or level) so
they are highlighted
iii. Hold down the left mouse button and drag and drop over the required task

NOTE: With this method, you do not need to pre-select the desired task so that it is highlighted. The selected
Resources can only be assigned to 1 task using this method.
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Using any of the above methods, practice assigning Resources to Tasks for the following items:

Resource(s)

Task

Resource
Appearance
Profile

Double Wide Construction Trailer & Portable
Restrooms

TIP: Select these items visually in the 3D
Window, making sure to hold Ctrl or Shift on
the keyboard to select all the separate
resources before assigning

Field Office

Install

Excavationl [680854]

TIP: You can search for Resources by name
by right clicking in the Resources window
and selecting Find... or by typing in the
search field at the top of the Name column
in the Resources window
Resources v 1
Name

excavation1 [680854]

4 Material Resources
2528 A Ste
3145 A Site dwifx
3180 4 Sie (4)
38 A Excavationl (1)
3182 4 Excavation (1)
s
Using the search field will expand all in the
tree. You may wish to right click in the
Resources window and select Collapse=>All
afterwards

Foundation
Excavation

Remove

All 13 “Basic Wall” Resources that make up
the node “Site Perimeter Fence”

TIP: From the Resources window, you can
select the parent node “Site Perimeter
Fence” and drag and drop onto the task —
this will assign all the Basic Wall Resources
that make up the node

Perimeter
Fence

Install

4 Site

[ Landscape dwhx
A Site.dwix

[> Floars (15)

[» Generic Models (3)

[+ Site (4)

A Walls (13)

4 Basic Wall (13)
A|Site Perimeter Fence (13} |

Basic Wall [317646]
Basic Wall [328000]
Basic Wall [613789]
Basic Wall [628115]
Basic Wall [628162]
Basic Wall [628185]
Basic Wall [635607]
Basic Wall [35653]
Basic Wall [854096]
Basic Wall [854448]
Basic Wall [354565]
Basic Wall [854605]
Basic Wall [854631]
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8. Review and Investigate Assignments

In this section you will learn how to review resource assignments. After assigning resources to tasks, you can play the
construction sequence in the 3D View, like a movie, to review.

8.1. Saving and Opening Projects

1. Select b File > H save
You will also see the option to m] Save As.
2. Select = File = Exit
3. Start Synchro =
4. Select [5 File > Open = W Private Project then locate and select 7raining Building.spto Open.

8.2. Review

1. In 3D View right click and select Zoom=> o Zoom All
2. Rotate in the 3D window so you can see the whole site

3. Drag the Focus Time back to the start of the project and drag along to the right at your own discretion though time.
8.3. Play

The Play Ribbon contains all the commands needed to control the Focus Time. Alternatively, you can drag the Focus
Time marker along through time manually.

oy

1. From the Play Ribbon, select ) Move to Start
»

2. Select \Z/ Play

3. The speed can be adjusted by selecting from the Ribbon- Play=>Play Speed then chose an option, for example 9
Week. Note that in this instance, the red “Focus Time” line will move ahead in intervals of one week.

4. Select ) Stop
8.4. Select “Assigned To” Tasks from an Object

1. Select one of the Perimeter Fence items from the 3D Window

2. Right click in the 3D window and select ® Display ‘Assigned to’ Task(s).
This command will automatically find and highlight the task(s) that the object has been assigned to. If the task is
assigned to multiple tasks, the Task list will automatically jump to the first task. You would need to scroll through the
task list to see the other highlighted tasks

3. You can also see a list of all tasks that a selected Resource is assigned in Resource Properties=>Tasks

3D Using Dates[Best] Filters[3D Object Filter] [491x2... O x | Resource Properties v
General
Costs
Supplier
3D Objects
Tasks
<all= ol

Install Perimeter Fence

4. Leftclick in the 3D Window then press Esc to cancel all selections
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8.5. Select Assigned Resources from a Task

This section explains how to investigate which resources are assigned to a particular task.

Select the task Install Office Trailers
Move the Focus Time after the end of the Install Office Trailers task

3. Right click on the task and select =R Select Assigned Resources
This command selects and highlights all the object(s) assigned to the selected task.
4. If you cannot find the objects in the 3D window, left click one of the top corners of the View Cube to zoom to the

selected objects, or right click in the 3D window and select Zoom—)o\ Zoom All.

You can also see all the Resources assigned to a task in Task Properties=>Resources
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9. Creating New Tasks

This section will teach you how to create new tasks in the project schedule.

9.1. Inserting New Tasks Manually

Suppose that it has been decided to schedule the structural pile installation as three separate tasks. The current

schedule has only one task for all of the structural piles — Structural Piles (20d). We can divide the current task into 3 new
subtasks.

1. Select the task Structural Piles in the Task List so that it is highlighted
2. From the Task ribbon, select Create=>As Child.
o m-As-Q8e-»2 8-

m HOME TASK 3D PLAY

-
me GO [
= = = &
Above Start Cutdent an
~ < < Screen ™
fa— | Move Links
mm  Above E
— ~ || Finish -> Start
-
| =m Below
-
— Name
mm As Child
-

This will create a new task as a child task, or sub-task, of the selected task which has now been turned into a parent, or
summary task. The new task will initially be given the duration of the parent task (20d in this case)

- Feb 2016 Iar 2016
D Name Duration Start Finish ist  [8th [15th [22nd [28th [7th [14th [21st
wk5 Twk6 [wk7 [wk8 [wkd [wk10 fwk11 [wk 12
14 4 Construction 257d 9:00 AM 2/1/16  5:00 PM 1/24/17
15 4 Site Construction 247d 9:00 AM 2/1/16  5:00 PM 1/10/17
16 STOO120 Foundation Excavation 5d 9:00 AM 2/1/16 5:00 PM 2/5/16 = oundation Excavation
v [ SWAMEG  So0PMIAS
18 STO0S70 New Task 20d 9:00 AM 2/8/16 500 PM 3/4/16 B
19 STO0140 Site: Lltilities 40d 9:00 AM 2/1/16 500 PM 3/25/16

3.  With the New Task selected, select Task=>Create—>Below to insert a second new task below the first. Repeat this
step once so that there are a total of three new tasks. Tasks inserted Below will automatically be given a duration of

1 day.
- Feb 2016 }M_arQU‘lB
D Name Duration Start Finish 1st [8th [15th [22nd [29th [7th [14th [21st
w5 Twk 6 [wk7 |wkd [wk9 [wk10 fwk 11 |wk 12
17 STOO130 4 StuctwelPles 24
18 STO0970 New Task 20d 9:00 AM 2/8/16 5:00 PM 3/4/16 ] Mew Task
19 STO0980 New Task 1d 9:00 AM 2/8/16 5:00 PM 2/8/16 1 %
20 STO0S%0 New Task 1d 9:00 AM 2/8/16 5:00 PM 2/8/16 3 %
NOTE: The Task ribbon=>Create 88 Selec Al [Tk
. i 3
commands are also available by Focus Time on Task
. L. Clear Contents
right clicking on a task and
R Insert New Task H = Above Ctri+1
choosing from the Insert New | -
= Divide Duration between Children = EBelow Ctrl=5hift=I
Task-> commands .
Progress H = As Child Ctrl+5hift=Alt+I
= Baseline Selected Tasks
ASORANANANANANANANNANAN
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. Rename the first new task to Piles 1 by double clicking on the name cell or right clicking and selecting Rename Task
5. With the Piles 1 task selected, you will see this symbol —H within the bottom right of the Name cell. Move the
cursor over this symbol until it becomes a crosshair. Select this with a left mouse click, hold and drag over the
cells below until the tasks are named Piles 1, Piles 2, and Piles 3

9.2. Editing Durations
Task durations for planned (not yet started) tasks can be edited by typing directly in the Duration cell in the Task List.

6. Left click in the Duration cell of the Piles 1 task, type 8 and press Enter. If no unit is entered, the duration unit
defaults to days (d).

NOTE: Duration default units can be changed in Options=>General->Duration Display Format, for example if you
typically schedule in hours. If you wish to enter a duration with a different unit use d for days, h for hours, or m for

minutes.

7. Tasks that are adjacent to each other in the Task List can quickly be given identical Durations using the same click
and drag method as in step 5 above. Click on the crosshair at the bottom right of the Duration cell for the Piles 1 task
and drag down to change the Duration of the Piles 2 task to 8d as well.

8. Change the Duration of the Piles 3 task to 4d.

You will notice that the Duration of the Structural Piles task now reads 8d. This is because it is a summary task —
summary tasks take their duration from the elapsed duration of all of their subtasks. The Structural Piles task should be
20d — we will correct this next by adding logic links to the subtasks.

9.3. Adding Logic Links

Logic links between two tasks define a dependency between one task and another. Links are used to explicitly prevent
tasks from being worked on out of sequence or to offset the start/finish of one versus another. If a Task is rescheduled
then any dependent tasks will also be re-sequenced. More than 2 tasks can be linked simultaneously. The order in which
the tasks are selected will determine the order in which they are linked.

9. Select Piles 1, hold Shift on the keyboard and select Piles 3.
NOTE: Order matters - selecting Piles 3 followed by Piles 1 would link the tasks in reverse order

10. Choose the Finish=>Start Link type from the Fast Options toolbar. A Finish to Start link will prevent a downstream
task from being started before the Finish of the upstream task

Remaove = || Finish -> Start = | Standard -

Finish -> Start
Start -» Finish
Start -> Start
Finish -> Finish
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11. Select Gantt Ribbon=>Links=>Link As Chain
mm-AF - R84 e-»25-

m HOME TASK 3D PLAY WINDOV
||

[ ]
= b = e =

Below Start Outdent | LinkAs On WES
= < < Chain~ Screen~ =
Create Focus Move 1

(3E) Link As Chain
=:l Link Many to One
A

F% Link One to Many

The 3 tasks will be linked but not rescheduled

« | Jan 2016
Name Duration Start Finish
Piles 1 %00 AM 2/8/16 5:00 PM 217416 1 i Piles 1
Piles 2 ad 9:00 AM 2/8/16 5:00 PM 2/17/16 i Piles 2
[Files 3 J4d 9:00 AM 2/8/16 500 PM 2/11/16 ] Piles 3

12. Select F9 on your keyboard to reschedule the project. The Reschedule command is also available in the Home
ribbon. The result in the Gantt Chart is shown below (notice how the summary task Structural Piles is 20 days again)

~ | Jan 2016
Name Duration Start Finish [tar
Piles 1 .00 AM 2/8/16 500 PM 2/17/16 1
Piles 2 ad 5:00 AM 2/18/16 5:00 PM 2/29/16
JFiles 2 |4d .00 AM 3/1/16 500 PM 3/4/16

TIP: To display logic links in the Gantt Chart, go to Options=>Gantt Chart=>Links and select All under Link Display.

To assign the piles to the tasks, begin by showing them in the 3D window. 3D
: ) . @ Include matches
13. In Nawgator%".‘!D Sets=>3D, select Clear to hide all objects

(71 Exclude matches
14. Check the box next to Piles (205) to show them in the 3D view.

*

F Objects of scene
& [ Architecture dwhc
& [ Landscape dwhx
TIP: Right click in the list and choose Find 3D Object to quickly locate b [ Site.dwx
“piles” F Structure dwix
] Columns (203)
F Round {209)
= [ 200mm Diameter (2)
= [ 300mm Diameter (2)
[ Piles (205)
i+ [ Aoors (7)
= [ Roofs (2)

m

| Makal || Clear ]
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15. Click the TOP face of the Viewcube in the 3D window to view the piles from above
16. Right click in the 3D window and choose Isometric. This will make it easier to select the piles using window box
selection

TIP: You may wish to change the Selected View Background colour in the 3D Ribbon->Fast Settings to provide more
contrast between the piles and the background

17. Use window box selection from top right to bottom left (as described in section 7.1) to select the Piles in Group 1,
then assign to the task Piles 1 using the Install Resource Appearance profile.

18. Repeat step 17 to assign the correct group of piles to the tasks Piles 2 and Piles 3.
19. Right click in the 3D window and select Isometric to turn off this setting.

9.4. Model-Based Scheduling

In this tutorial, you will learn how to use Model Based Scheduling, or creating tasks from 3D Objects.

As an alternative to manually inserting new tasks as we did in section 9.1, Synchro allows you to create tasks directly from
3D items. By default, Synchro will generate the tasks in the order that you selected the items, link the new tasks, and
divide the durations of the selected task among the new tasks.

Suppose we would like to create a task for each of 3 pours of the concrete slab . 3D

on grade. Instead of inserting the tasks manually, we will select the objects in

the order we want them installed and then create tasks directly from the © Include matches
() Exclude matches

objects. This is called Model Based Scheduling.

4 Objects of scene
1. In Navigator> 3D Sets>3D show the Concrete Slab on Grade 200mm v [ Architecturs dwfx
 [J Landscape.dwix
[ Site.dwfx
P Structure dwhe
t [J Columns (203)
rl Floors (7)
4 Floor (7}
> [# Concrete Slab on Grade 200mm (3)
> [ Concrete Slab on Metal Deck 100... —
[ Roofs (2)
[ Structural Columns (63)

»

type in the Floors family of the Structure file

m

| Makan | | Clear |
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2. Select the objects in the 3D window in the following order:

3. Select the task Slab on Grade in the Task List so it is highlighted. We will insert the new tasks as subtasks of this one.
4. With the 3 slabs selected, right click in the 3D window and choose Create Task(s)=>Under selected Task.

AAVAVAVAVAVAVAVAVAVAVAVY

ﬂ Assign to Selected Task(s) Ctrl=5Shift+A
x  Unassign from ‘Assigned to’ Task(s) Ctrl=U
Create Task(s) Bl o= At root level

& saprima report "= Under selected Task

fl Convert 3D Text to User Fields.. += Below selected Task

ok nvert to 30 Path

NOTE: Selecting “Under selected Task” will create a new task as a child task. If you select “At root leve
task will become a child task. Selecting “Below selected Task” will create a new task below the selected task; neither

|//

the selected

task will be parent or child to each other.

5. The following dialog will appear. Select Yes to create a new task for each selected resource.
i - ™
Synchro Software Ltd. ‘ L_LhJ
NOTE: Selecting No will create a single task to

Multiple Resources are selected. which all selected resources will be assigned.
Do you want to create a separate Task for each Resource?

= w

You will notice that 3 tasks (titled the same as their Resource name) have been added as subtasks of Slab on Grade.
The total duration of these tasks is automatically created to sum to the parent task and they are linked as a chain.

6. Please rename the three Tasks created Floor [166617], Floor [821844], and Floor[693039] to Slab on Grade Area 1,
Slab on Grade, Area 2, and Slab on Grade Area 3, respectively.
aD

1D Name: Duration Start Finish R
3 -____
32 5T01000 Slab on Grade. Area 1 5:00 AM 6/20/16 5:00 PM 6/20/16
1 5T01010 Slab on Grade. Area 2 1d 5:00 AM 6/21/16 5:00 PM 6/21/16
34 5T01020 Slab on Grade, Area 3 1d 9:00 AM 6/22/16 5:00 PM 6/22/16

NOTE: See Options—>Defaults for New Objects—=>Creating Tasks from Resources to change settings for how tasks are
created in model-based scheduling. For example, you can choose not to link tasks when creating.

7. Drag the Focus Time forward to see the slabs installed in the order that you selected.
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10. Custom Resource Appearance Profiles

In this section, you will learn how to create custom resource appearance profiles and how to apply a growth simulation.

In addition to the default system Resource Appearance Profiles (Install, Remove, Maintain, and Temporary), Synchro gives you

the ability to create as many custom user-generated User Profiles as you’d like. These custom profiles will appear underneath

the default Resource Appearance Profiles under the label User Profiles.

You can vary the colour, the transparency, and/or add a growth simulation. You can use custom Resource Appearance

Profiles to differentiate phases and processes or work crews, as well as show the intended direction of an installation or

removal.

10.1. Transparency Interpolation

One way to indicate change over the duration of a task is Transparency Interpolation. For example, an object being

installed could start completely transparent at the beginning of the task and become increasingly opaque until it is solid
at the end of the task.

>

© N o Ww

10.

In Navigator=> & Resource Appearance Profiles, create a new user defined user profile by
right clicking in the window then selecting Add

Rename the profile Transparency Interpolation and ensure it is highlighted

In the General tab, ensure the Action is set to Install

In Active Appearance, enable Original Colour by checking the box next to it (or change the
colour if desired)

Enable Transparency Interpolation (check the box next to it)

Change the Start Transparency to 100 (%) and set Finish Transparency to 0 (%)

In Navigator-). 3D Sets, show Roofs (2) within the Architecture file.

Select Part [1084292] and assign to the task Thermal and Moisture Protection=>Low Roofing
under Construction in the Gantt Chart.

Select the task and use the Gantt=>Focus=> = Start command to jump to the start of the task.

Drag the Focus Time slowly through the task to see the Transparency Interpolation. (You may
want to zoom in the Gantt Chart to make this easier to see)

10.2. Growth Simulation

Active Appearance

1

Original Calour
L1

Colour

Original
Transparency

Start

Transparency .
; J
Interpolation

Finish

Growth Sirmulation

MNone -

Growth Direction

When a Growth Simulation is applied to a resource, the resource appears to grow incrementally in the specified direction

(or shrink, in the case of Resource Appearance Profiles with the Remove action selected) over the

course of the task. Growth Simulations can be used to quickly and easily indicate the direction of

construction.

AW

~N o

In Navigator-> ® Resource Appearance Profiles, create a new user defined user profile by
right clicking in the window then selecting Add

Rename the profile R-L Growth and ensure it is highlighted

In the General tab, ensure the Action is Install

In Active Appearance enable Original Colour by ticking the box next to it

Select Right — Left from the Growth Simulation dropdown

Active Appearance should look as the picture to the right

Select Part[1084295] and assign to the task Thermal and Moisture Protection—=>High Roofing

Move the Focus Time through the task- you will see the roof ‘grow’ as it is being installed

Active Appearance

Original Colout )
L]

Colour
Original
Transparency 0

Start
Trgnsparency

Transparency m
Interpolation

Finish

Groowth Simulation .
Right-Left ﬁ
b
Gremdh.Direction

(-1.0.0)
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10.3. Grouping Objects for Growth

Sometimes you may need to show multiple objects grow as a group using a growth simulation Resource Appearance
Profile, rather than growing individually. Grouping objects for growth allows you to show the general progression of
construction for multiple objects without needing to create a task for each. For example, suppose you wish to show all of
the pile caps being installed from right to left during a single task. If you assigned each pile cap to the task using a
Resource Appearance Profile with a Right-Left Growth Simulation, they would each grow individually which is not the
desired result. Instead, you should group all of the pile caps into one Resource before assigning to the task.

1. In Navigator9.3D Sets, select Clear to hide all objects, 4 3D

then show Pile Cap-Rectangular (47) within the Structure .
file @ Include matches

() Exclude matches

= [ Site dwhx o
P Structure dwhx
[ Columns (209)
[ Foors (7)
+ [ Roofs (2
r [ Structural Columne (63)
4 Structural Foundations (102)
t+ [] Base Plate {50)
&+ [J Foundation Slab ()
[ Pile Cap-Rectangular (47)
r [ Structural Framing (751)
& [ Walls (8) |

m

4

| Markad || Clear |

2. Select all the pile caps using window box selection.

3D Using Dates[Best] Filters[3D Object Filter] [698x396] o x

Right click in the 3D window and choose Resources Wizard
Select Assign to a new Resource and Next=>
Rename as Pile Caps, set the Type as Material, then Next=>

The Resource Creation... window will appear, select Assign to this Resource, don’t build tree - This groups all
selected 3D Objects as one resource, rather than being 47 individual resources. Then Next=>

o v oA Ww
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F B
7. The Unassignment... window appears, check Unassignment... — - u
the Unassign box, then select Finish. This
unassigns the 3D from the original resources In order to continue, the following 30 ohiects will need to be
created on import unasssigned from Resources:
Pile Cap-Rectangular [737058] -

Pile Cap-Rectangular [738487]
f Pile Cap-Rectangular [F37418]
Pile Cap-Rectangular [738263]
Pile Cap-Rectangular [B55254]
Pile Cap-Rectangular [344712]
Pile Cap-Rectangular [735771] i
Pile Cap-Rectangular [737552]
Pile Cap-Rectangular [737183]
Pile Cap-Rectangular [738726]
Pile Cap-Rectangular [801845]
] Pile Cap-Rectangular [F36123] ]

l 4 B I

m

Pile Cap-Rectangular [736153] ‘_

Lnassign

| <Back || Fnish || Camcel | [ Hep |

8. Change Appearance Profile to R-L Growth
9. Open the Resources tab and select the newly created Pile Caps in the list. You will see the objects are all
selected in the 3D View.

TIP: Right click in the Resources window and choose Collapse=>All, then expand Material Resources to see the
top level Resources. New Resources created using the method above will be at the top level of the Resource
tree.

10. Right click in the 3D View and assign to the task Pile Caps under Construction=>Concrete
11. Move the Focus Time forward over the task and you will see the pile caps growing as one resource (group)

an » | mar |Apr
D Name Duration Start Finish [Mar [may
~ |lwk 10 [wk 14 [wk 18
14 4 Construction 257d 9:00 AM 2/1/16 5:00 PM 1/24/17 | —
15 I Site Construction 247d 9:00 AM 2/1/16  5:00 PM 1/10/17 B, Move Focus Time
28 4 Concrete 84d 9:00 AM 3/14/16  5:00 PM 7/7/16 .———-——;
29 sTO0210 |Pne Caps Trod 9:00 AM 3/14/16 500 PM 3/25/16 ile Caps
30 ST00Z20 Grade Beams 10d 9:00 AM 3/28/16 5:00 PM 4/8/16 Grade Beams

H
35
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11. 3D Subdivision

In this section you will learn how to use the 3D Subdivision tools: Slice, User Slice, and Freehand.

The 3D Subdivision tool can be used to divide a model object into smaller sub-parts. The sub-parts can be selected
individually and assigned to separate tasks. This may be used, for example, to divide a single concrete slab into individual
concrete pours or split continuous columns and walls by level without having to ask the modeller or architect to make the
changes in the original file.

You will notice that the Slab on Deck, 1% Floor task is broken into 3 areas, each of which has multiple pours scheduled. There
are only 3 slab objects on that level, however. The separate pours are not modelled — therefore, we will use the 3D
Subdivision tool to create them in Synchro. There are 3 options for Subdivision Type: Slice, User Slice and Freehand, which we
will demonstrate in the following sections.

11.1. Subdivide by Slice

In Slice mode, the subdivided object is split into orthogonal uniform planes (columns, rows and layers). You simply define
how many rows, columns and layers you require. . 3D

1. In Navigator9.3D Sets, select Clear to hide all objects, then @ Include matches

show Concrete Slab on Metal Deck 100mm under Floors in the © Enclude makches

X 4 Structure dwhx -~
Structure file > O] Columns 209)
NOTE: We will only be using Floor [693311], Floor [693318], and “ , F'°°:og?m
Floor [693329] for this 3D Subdivision exercise. Please ensure Floor b [ Concrete Slab on Grade 200mm (3)
[829334] is deselected. 4[] Concrete Slab on Metal Deck 100mm (4}

Floor [853311]
Floor [653318]
Floor [653325]
O Floor [829334]
[ Roofs (2)
[ Structural Columns (63)

m

[ Makan | | Clear

2. From the 3D Ribbon select the v 3D Subdivision tool. The 3D Subdivision window will appear at the bottom of
s
your display. Ensure that the entire 3D Subdivision window is shown as below by using the = cursor to resize.

PRO|44




Synchro PRO Basic Training: 3D Subdivision

3. Select the “Area 1” slab in the 3D Window. The selected item will be displayed in the 3D Subdivision window, as
shown below

3D Using Dates[Best] Filters[3D Object Filter] [679x169] v 3 x

Select in 3D
Window
3D Subdivision v @ x
Subdivision type
l\?,l Nlone L:,l Free Hland Displavs in 3D
i 5li () User sli . ..
oo S Subdivision
Caolumns: Window

Rows:

L : [=o
Axes
| Local | Manipulate
————— (@ 5naptoFace
| World | B F
— MNaone
| Layers Up |

subdivide Multiple Objects

4. Enter 1for Column cuts
5. In Axes select World so that layers are facing up then enter 1 in the Row cuts.

3D Subdivision v 1 x
Subdivision type
(2) None () Free Hand

(@ slice ) (O User Sice
.= =
Rows: D
Layers:
Axes
= @ Snap to Face
[ World D~
() None

[ subdivide Multiple Objects
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6. Close the 3D Subdivision Window to finish by selecting the ‘X’ in the top right, then left click in the main 3D Window
and press Esc on the keyboard.

NOTE: Each Subdivision can now be selected and assigned separately.

7. Change the Resource Appearance Profile to Install in the Fast Options toolbar.
8. Select and assign the subdivided floor slab to the matching Slab on Deck, 1st Floor, Area 1 subtasks according to
the diagram above

NOTE: You can rename the subdivided 3D Objects in the 3D Objects window by right clicking on them and
selecting “Rename.” Try it now by renaming the subdivisions with their associated Task Areas (i.e. Subdivision
1,1 will be Subdivision Area 1D)

TIP: Try using the Ctrl+Alt shortcut to drag and drop the 3D object onto the appropriate task

11.2. Subdivide by User Slice

In User Slice mode, the subdivided object is split into orthogonal non-uniform planes (columns, rows and layers). The size
of each slice is defined as a proportion of the original geometry and the slices can be resized using the manipulators in
the preview window.

There are 2 subtasks for Slab on Deck, 1st Floor, Area 2 which requires a spilt that is at 75% of length of the slab rather
than directly in the middle (50%).
1. Select “Area 2” in the 3D window

From the 3D Ribbon select the v 3D Subdivision tool
In the Subdivision type box activate the Slice option
Enter 1 for Column Cuts

vk wn

Select User Slice then either-
a. Change the figure from 0.5 (50%) to 0.75 (75%) then Apply
b. Use the Arrow manipulator as shown below

3D Subdivision v X
Subdivision type _
|:::| Mone |:::| F_reE Hand Man 1pu |Elt0r -
() Slice @ User Slice
Columns: 04| 0.75 )
Raows: Qle |0
Layers: ol |0
@ 2oy D
Axes
el () Manipulate

© srepiorecs
() Mone
Layers Up

Subdivide Multiple Objects
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6. Close the 3D Subdivision Window to finish. Then left click in the Main 3D Window and press Esc on the
keyboard.
7. Select and assign the subdivided floor slab to the matching Slab on Deck, 1st Floor, Area 2 subtasks

3D Subdivision

Subdivision type NOTE: If you have several splits that you want to use the User
© None () Free Hand Slice on you can toggle between the splits with the arrow keys
1) Slice (@ User Slice as shown

Columns:

Layers: ol [fe

11.3. Subdivide by Freehand

In Free Hand mode, the subdivision planes are defined by user-drawn lines (polylines) that are then extended in a
particular direction. This can be used to split objects into irregular shapes.

From the 3D Ribbon select the v 3D Subdivision tool

1.

2. Select “Area 3” in the 3D window

3. Select Free Hand

4.  When using Free Hand slice, always make sure to select Snap to Face from the Axes box. Then in the 3D
Subdivision Window, left click the face that you will be drawing the cut on (the top face in this case)

5. Right click in the 3D Subdivision window and select Create Subdivision Polyline

6. Rotate the view so you are looking down on the slab
7. Left click at one edge to begin the polyline, then continue left clicking within the slab to add vertices to the
polyline. Finally left click on an edge to finish the polyline. Try creating the shape shown below.

Fo

Colifins

NOTE: Subdivision Polylines must extend from one edge of the object’s bounding box to another (even if the
object is irregularly shaped so that its edge is not the same as the rectangular bounding box)
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11.4. Troubleshooting

If an object disappears or displays other unexpected behaviour upon subdivision, you may need to adjust your
subdivision settings.

Select the Options icon from the Home ribbon
Expand 3D View and select 3D Subdivision
3. Within Toolkit for Subdivision Operations, change the Used Toolkit from Advanced to Simple and press OK

[ Options @ )

call +| 3D Subdivision
I+ General . . )
Look & Fesl Toolkit for Subdivision Operations
b Gantt Chart Used Toolkit | Simple -
4 3D View
Caption Text Triangulation type [Don‘t triangulate vl
Colours
Lighting Intensity Try sewing to solid
Cutting Plane
I Camera Colours
> Advanced
7 o
Printing Show Subdivision Planes
b 3D Subdivision | Line colour I:E Manipulator colour |:E
Legend 3
=10 =
Rendering Effects Plane colour I [~|  Transparency
P> Information Balloon 3D Contexd Sumoundings Transparency
Copy/Paste 30
> Manipulat
amplfl or Resources for 30 Subparts
Snapping Colours
Distance Measurement Automatically Create/Remove Resources for 3D Subparts
Measurement Display [ Assign 3D Subparts to the same Taskis) like Parent 30 Objects
Spatial Coordination
Animated Objects
I Grids Side to show slice manipulator
AV Export
I Synchronisation b |
> Defaults for New Cbjects
Dlicy i Bl il S
[ Reszet ] l E=part... ] [ [l ] [ Help ]

L

NOTE: For some files, the Advanced Toolkit may work better than the Simple and vice versa. You may also need to
adjust the Triangulation Type setting and enable/disable Try sewing to solid
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4. Select the polyline from the list box in the 3D Subdivision window and choose the Remove Selected Polyline button

3D Subdivision

Subdivision type
() Mone (@) Free Hand

i) Slice (7 User Slice

Polyline[00]((0,0.416012),(1,0.257201))

1| ] [ ¥

Remove Selected Paolyline

Right click in the 3D Subdivision window and select Create Subdivision Polyline, and then redraw the polyline as in

step 7 of section 11.3 above.

To add a second cut, right click in the 3D Subdivision window, select Create Subdivision Polyline again, and left
click on one edge and across to the other as below:

3A 3B 3C

R rs

Collghns

Close the 3D Subdivision window to finish. Then left click in the main 3D Window and press Esc on the keyboard.

7.
Select and assign the subdivided floor slab to the matching Slab on Deck, 1st Floor, Area 3 subtasks as indicated

8.
above
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11.5. Editing Subdivisions

It is possible to edit a subdivision if you decide that you need to after closing the 3D Subdivision. Suppose, for example,
that it is decided that “Area 2” should be split at 60% rather than 75%.

1. Move the Focus Time after the end of the Slab on Deck, 1st Floor, Area 2 task

2. From the 3D Ribbon select the ' 3D Subdivision tool
3. Select one of the “Area 2” subdivisions in the 3D window. You will see the object in the 3D Subdivision window, but

the Subdivision commands will not be available.

3D Subdivision v § x

Select subdivided Object

4.  Click the Select subdivided Object button to select the entire original object. You can now edit, add or remove splits.
5. Change the Columns division to 0.6 and press Apply

NOTE: Selecting None for Subdivision Type will remove all splits if needed. If you select none, or decrease the number of
rows, columns, or layers, you will be presented with a warning. If you meant to remove the subdivision, press Yes. Any
existing subdivisions will be removed, and any associated 3D Resources will be deleted and unassigned from any tasks
that may have utilised them. The 3D Object and Resource trees will be updated accordingly.

' B

'@' This operation will cause the removal of 3D objects which are assigned
b

' to Resources.

If you continue, 2 Resource(s) will lose 3D representations.

Are you sure you want to do this?

e J [

6. Close the 3D Subdivision window to finish. Then left click in the main 3D Window and press Esc on the keyboard.
7. If Subdivisions were added or removed you would need to assign the subdivisions to the appropriate tasks,
but since we only changed the size of the existing subdivisions, they have remained assigned to the correct
tasks. You can confirm this by selecting one of the subdivisions in the 3D window, right clicking and choosing
Display Assigned to Task(s)
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11.6. Subdivide Multiple Objects

Synchro also provides the ability to subdivide multiple objects simultaneously. This can be used to split many objects
along the same plane; for example, splitting slabs on many floors into the same number of pours or splitting many
columns in a building by level.

In this tutorial, we will subdivide wall panels that span from the ground floor to the ceiling so that they have separate 3D
Object representations for each floor (ground floor, first floor, and second floor).

1. In Navigator=>3D Sets, select Clear to hide all objects, then show Walls=>Basic Walls=> Interior-Blockwork 200 (11)
under the Architecture.dwfx file.
2. Select the Objects shown below in either the 3D View or 3D Sets=>3D window.

* 3D Using Dates[Best] Filters[3D Object Filter] [527x352] ~ * x
@ Include matches

() Exclude matches

4 Interior - Blockwork 200 (11) -
Easic Wall [213122]
Basic Wall [818301]
Basic Wall [318503]
Basic Wall [318505]
Easic Wall [315145] B
Basic Wall [823562]
Basic Wall [823566]
Basic Wall [224387]
Basic Wall [832887]
Basic Wall [833222]
Basic Wall [833554]

—

[ Makan | [ Clear ]

m

-

3. Select 3D Ribbon=>3D Subdivision

In the 3D Subdivision select Subdivide Multiple Objects. You will now see a blue bounding box that includes all
selected 3D Objects for Subdivision

NOTE: When Subdivide Multiple Objects is disabled, only the first object selected can be subdivided; the other
objects selected will still be shown semi-transparent as a reference, which can be helpful to guide you when making
user slices for example. When Subdivide Multiple Objects is enabled, all objects become opaque; in this mode you
cannot show additional objects as reference.

3D Subdivision o x
5. From the Subdivision Type panel, select Slice. Subdivicion type

) MNone ) Free Hand

Enter 2 for Layer Cuts Ose @ uSarsuc)e

7. Select Layers Up from the Axes box

ol [0

NOTE: If the flows are not evenly spaced, you

04» 0.333333

could use the User Slice and adjust the slits Aoy

accordingly. ©) Meripuete
() Snap to Face
8. Close the 3D Subdivision Window to finish. @ one
Then left click in the Main 3D Window and ——
preSS ESC on the keyboard Subdivide Multiple Objects
9. In the Task List of the Gantt Chart, find the

tasks: “Blockwork, Mechanical / Elevator Shaft,

» u

Ground Floor”, “Blockwork, Elevator /
Mechanical Shaft, 1st Floor”, and “Blockwork, Elevator / Mechanical Shaft, 2nd Floor”
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10. Assign the 3D Subdivisions to the associated Tasks as indicated below using the Install Resource Appearance Profile

2nd Floor

1st Floor

Ground Floor

11. Each Task should now have four 3D Objects assigned to them:

ap < [Jul2016
1D Name Duration Start Finish R 4th [11t [18th
wk 27 [wk lwk 29
70 4 Masonry 12d 9:00 AM 7/4/16  5:00 PM 7/19/16 by
71 STODS30 Blockwork / Elevator Shaft. Ground Floor 4d 9:00 AM 7/4/16 5:00 PM 7/7/16
72 STODS40 Blockwork / Elevator Shaft. 1st Floor  4d 9:00 AM 7/8/16 5:00 FM 7/13/16
73 STODS50 Blockwork / Elevator Shaft. 2nd Floor ~ 4d 9:00 AM 7/14/16 5:00 PM 7/19/16 —

NOTE: When subdividing multiple objects, all selected objects will be split into the same number of subdivisions
according to the settings specified. This may result in subdivisions listed in the 3D Objects list which do not have a
physical geometry. This will happen, for example, when all the cutting planes in the 3D Subdivision window do not
intersect each selected object.
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12. Auto-Matching with User Fields

In this section, you will learn how to implement the Auto-Matching function using User Fields.

The Auto-Matching feature in Synchro provides a facility to automatically assign Resources to Tasks using custom filters and
search rules. The match is based on Resource Names or User Fields as well as Task Names, 1D, Comment, User Fields or
Activity Codes. Using the Auto-Matching function greatly simplifies the task of linking resources to tasks.

12.1. User Fields

User Fields are custom fields created to track or filter information for Tasks, Resources, and 3D Objects that isn’t initially
captured by Synchro PRO’s default attributes. User Fields can be created when importing a schedule or 3D Model that has
these assigned parameters in their source files. Additionally, you can create custom User Fields in Synchro PRO.

Previously when we imported the 3D Models (section 5.1), we selected “Process User Fields”. In this tutorial, we will create
User Fields for select Tasks to match the existing User Field values of certain

Resources. 3D
8. In Navigator—).BD Sets, select Clear to hide all objects, then show ©) Include matches
) Exclud h
Structural Columns (63) and Structural Framing (791) under the Stucture.dwfx S '_ematc =
4 Objects of scene
file. b [ Architecture dwhe
> Land: dwfx
9. Inthe 3D View, select “Left” on the View Cube Manipulator. This will rotate t Esﬂ:;::fe
the 3D View so that you are looking at the front of the building structure. “ b Stnucture dwfx
» [ Columns (209)
> [ Foors {7)
There are over 850 3D Resources. Rather than assigning each Resource to its > [ Roofs (2)

respective Task, we can instead create a custom field or User Field for each Task . O Structursl Foundstions {102)

> [l Structural Framing (791}

b
b
b
> [¥] Structural Columns (63)
b
b
O Walls (8)

to match the User Fields already assigned to the 3D Resources.

[ Makan | | Clear ]

10. Select any 3D Object shown in the 3D View, then select the Resource Properties window and expand the User Fields
tab. For this tutorial, we want the value stored in “Task Location” (shown below).

- . . . Usger Field
3D Using Dates[Best] Filters[3D Object Filter] [533x262] 0 X | (gasiiosaion -

Type

String

Y alue

Aread

Add Change

Uzer Field Value i
Etd Extension 13
St At

lﬁ:inn Area 4 h N
Length alD
Yolume 0.04 ré
Structural Material tetal - Steel.. =

NOTE: The User Field values shown above are user defined Object Parameters in the CAD files. Upon 3D Import,
these parameters are created as User Fields in Synchro using the command “Process User Fields”.
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11. Select Navigator> 2 User Fields User Fields
12. Right click in the User Field window and select Add
13. In the Add User Field dialog window, set the Name . (" Add User Field )
to “Task Location”, the Category to “Task” and the > 3D User Feld
Ser Flel
Type to “String” (shown right). Name
Task Location
Add
Category
[Task v]
Type
[sting -]
Colour
| |
14. In the Task List, find Structural Framing, Area 1,
Structural Framing, Area 2, Structural Framing Area 3, [ ok | [ cand | [ Heb |
and Structural Framing, Area 4 under the Summary L )

Task Metals.
15. Right click in the Column Headers to Customise Columns and show the User Field 2 Task Location next to the tasks
in the Task List. (If need be, please reference section 3.2.1 : Customising Columns). Your Task List should look like

this:
» JlApr [Jul
D Name Task Location Duration Start Finish [May [Jun [ [Aug
wk 14 lwk 18 lwk 23 i 27 lwk 31
50 4 Metals 190d 9:00 AM 4/6/16  5:00 PM 12/27/16
] ST00350 Base Plates d 9:00 AM 4/6/16 5:00 PM 4/8/16 E—Ba: e Plates
52 STO0360 Structural Framing, Ares 1 ad .00 AM 4/18/16 5.00 PM 4/27/16 Structural Framing, Area 1
53 ST00370 Structural Framing, Ares 2 ad .00 AM 4/28/16 5.00 PM 5/9/16 L Structural Framing, Area @
54 5T00380 Structural Framing, Ares 3 10d 5:00 AM 5/10/16 5.00 PM 5/23/16 i| Structural Framingi Area 3
55 ST003%0 Structural Framing, Ares 4 5d 5:00 AM 5/24/16 5:00 PM 6/3/16 tructural Framing, Area 4
56 STO0400 Plumb/ Bolt / Weld Area 1 5d 9:00 AM 4/28/16 5:00 PM 5/4/16 Plumb/ Bolt / Weld Area 1
57 STO0410 Plumb/ Bolt / Weld Area 2 5d 9:00 AM 5/10/16 5:00 PM 5/16/16 1 Plimb/ Bolt / Weld Area|2
58 STOM20 Plumb/ Bolt / Weld Area 3 54 9:00 AM 5/24/16 5:00 PM 5/30/16 Pllmb/ Bolt-A\Weld Area 3
59 ST00430 Plumb/ Bolt / Weld Area 4 5d 9:00 AM 6/6/16 5:00 PM 6/10/16 - E Plumb/ Boelt / Weld Area 4
4| m 3 4 | m »

16. Left click in the Task Location column cell of the Structural Framing, Area 1 task, type in “Area 1”. For Structural
Framing Area 2, Structural Framing Area 3, and Structural Framing, Area 4, enter the User Field values “Area 2”,
“Area 3”, and "Area 4”, respectively.

17. Task User Fields can also be defined in the Task Properties window under the User

User Fields
Field tab. Select the task Plumb/Bolt/Weld Area 1 and go to Task Properties=>User User Field
Fields. Task Location -
18. Select “Task Location” from the User Field drop-down. Leave Type as String. Enter T;tp_e
Ting
the Value as “Area 1”
Value
19. Select “Add” (circled right). New string
20. Repeat steps 10-11 for Plumb/Bolt/Weld Area 2-4 assigning their respective Areas 2- | _— ]
Add | Change

i

4 under Task Location.

UserField  Value
NOTE: You can edit User Field values directly in the Task List by clicking on the cell
which holds the value and typing. Additionally, under Task Parameters=>User Fields,
select the User Field you want to edit, type the new Value and press Change to enter
the desired new value.
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21. Your Task List should now look like this:

D Name Task Location Duration Start Finish ol il [ay [dun IJUI lAug

w14 [wk 18 fwk 23 fwic 27 fwk 31

50 4 Metals 190d 9:00 AM 4/6/16  5:00 PM 12/27/16

51 ST00350 Base Plates " 9:00 AM 4/6/16 5:00 PM 4/8/16 E—Ba— e Plates

52 ST00360 Structural Framing, Area 1 Area 1 & 9:00 AM 4/18/16 5:00 PM 4/27/16 Structural Framing, Area 1

53 ST00370 Structural Framing, Area 2 Area 2 8d 9.00 AM 4/28/16 5:00 PM 5/9/16 L Structural Framing, Area @

54 ST00380 Structural Framing, Area 3 Area 3 10d 9:00 AM 5/10/16 5:00 PM 5/23/16 |i| Structural Framing; Area 3

55 STD0390 Structural Framing, Area 4 Area 4 94 9:00 AM 5/24/16 5:00 PM 6/3/16 tructural Franjing, Area 4

56 STO0400 Plumb/ Bolkt / Weld Arsa 1 Area 1 5d 9:00 AM 4/28/16 5:00 PM 5/4/16 P eld Area 1

57 ST00410 Plumb/ Bokt / Weld Area 2 Area 2 5d 9:00 AM 5/10/16 5:00 PM 5/16/16 = Plumb/ Bolt / Weld Area| 2

58 STO0420 Plumb/ Bok / Weld Arsa 3 Area 3 5d 9:00 AM 5/24/16 5:00 PM 5/30/16 B Area 3

59 ST00430 Plumb/ Bokt / Weld Area ¢ Arsa 4 5d 9:00 AM 6/6/16 5:00 PM 610416 - E| Plumb/ Bolt / Weld Area 4

4 " 3 1 (1 r

In the next section, we will use these assigned User Field values to Auto Match 3D Resources to these eight tasks.

12.2. Creating an Auto-Matching Rule

We will now create an Auto-Matching rule to assign multiple 3D Resources to the appropriate Tasks by matching their
User Field values.

Select all Resources shown in the 3D View: [Structural Columns (63) and Structural Framing (791)]
Left click on Task Structural Framing, Area 1, hold down Shift and select Structural Framing, Area 4.

NOTE: Please ensure you do not de-select the 854 Resources and 4 Tasks selected.

3. Select Home Ribbon=>Tools>Auto Matching... (@) to display the Auto Matching Dialog.

Aute Matching (Resources to Tasks)
Rules
Import ] [ Export ] [ Mew Edit emove Remove Al
Operations
grpopfﬁ::rance Install E Search Clea Assign Al
# Resource ~ Task Appearanc... * . .
NOTE: Please see Appendix D: Auto-Matching for
more information pertaining to this function and
I I not explicitly described in this tutorial.
Resource Tree Task Tree
Resource Attributes Task Attributes

4. Select New to add a new Auto-Matching rule in the Add New Rule... dialog (shown below).
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3 Add New Rule...
Name: “Structural Framing & Columns* e e

Since we have purposely selected the 3D Resources Name Structural Framing & Columns

and Tasks we want to link, enable Use only Selected i i
Summary options

Resources and Use only Selected Tasks under Summary
Options.

Use only Selected Resources Use only Selected Tasks

[ 1gnore Assigned Resources || 1gnore Tasks with Assignments
NOTE: Selecting Use only Selected Tasks/Resources will [“]Merge Resource Groups [7] tgnore Summary Tasks
limit the search criteria. If these options are not _  Relations _
) None () One-to-One @ Many-to-Many
selected, all 3D Resources and Tasks in the project will
Expression

be searched for a match. i

7. Under Relations, select Many-to-Many since we want to

match and assign more than 800 3D Resources to four I

il
a
i
e

8. Select Add. I
Add New Term...
Name | Structural Framing & Columns
Summary options
You can now define the matChmg criteria of your Auto- Use only Selected Resources Use only Selected Tasks
MatChing RUle in the Add New Term... d|a|0g For the Ignore Assigned Resources Ignore Tasks with Assignments
purposes of this tutorial, please set the fO”OWing values: Merge Resource Groups Ignore Summary Tasks
Relations
9. Under Resource Attribute: None One-to-One (@) Many-to-Many
i.  First Drop-Down= User Field Expression
ii. User Field Drop-Down = Task Location
10. Under Task attribute:
i. First Drop-Down= User Field
.. . . I
ii. User Field Drop-Down =Task Location Add sae | [ cancel
11. Please set Algorithm =Exact since we want an exact
Term
match between Task and 3D Resource User Fields. Resource attribute Task attribute
12. Operator = AND " [TJuse Parent [T Use Parent
13. Press “Save” [User field v] [User field v]
il le in the “ o ind I User Field User Field
14. You will now see your rule in the “Expression” Window: [FaskLocation 7] [faskLocaton =
Expression Type: [WIE @IH L @M
AND ( User field: Task Location = User field: Task Location
Algorithm Operator
@) Exact () Substring @Les @ AND
Options Oor
[ Add l [ Remave ] [ Remove Al ] Pkl |4 = © Anp NOT
Mir Digits: 0 : ) OR NOT
DSeparamrs:
15. Select OK at the bottom of the Add New Rule... Dialog. .
g I:‘ Case Sensitive DTF“E if Undef
OK Cancel ] [ Help
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12.3. Auto-Match 3D Resources to Tasks

We will now run our Auto-Matching rule “Structural Framing & Columns” in the Auto Matching window.

16. Select “Structural Framing & Columns” from the Rules Drop-Down.
17. Make sure Operations=>Appearance Profile is set to Install

Aute Matching (Resources to Tasks)

Rules

[Shudural Framing & Columns - ]
[ Import ] [ Export ] [ Mew ] [ Edit ] [ Remove ] [ Remove Al ]
Operations

a
m
i

bopesance il
Profile: -

18. Select Search to display the Auto-Matching results Auto Matching (Resources to Tasks) )

Rules

19. Select an item from both Resource and Task columns

Structural Framing & Columns

to populate the dialog windows beneath the search

Import Export ew Edit Remove Remove Al
resu |tS ‘ Operations
20. To confirm your Auto-Matching results, ensure the i " sewrch | [ cer | [[asod | [ coe |
following values are equal : A
# Resource ~ Task Appearanc...
i.  Resource Attributes=>User Fields—> Task Location L UB-UniverselBeam [72742¢] Structral Framing, Area 4 Instz] n
UB-Universal Beam [972414]
ii. Task Attribute=>User Fields=>Task Location WP e 7

UB-Universal Beam [764454]
UB-Universal Beam [972250]

21. Select Assign All to receive this window. Press OK. UB-Universal Beam [572254]
. - UB-Universal Beam [9721588]
& Ug-Universal Beam [371238]
Syﬂ( hro Software Ltd. UB-Universal Beam [726518] o
[
Il Resource Tree Task Tree
. <all IR EE »
i 1 Operation finished successfully. 4 UB-niversal Beam (791) 4 Censtnuction
W' 354 new assignments have been created “ 30EIEEAILE 791 | 4 Metas .
- } UB-Universal Beam [972 - } Structural Framing. Area 4
Resource Attributes Task Attributes
<all P |l L

0K Reference Level.T.0. STEEL - MECH > General [2]
End Exension:-13 Activity codes [0]

Start Extension:-13 4 User fields [1]

Jm

b » Task Location:Area 4 b Task Location:Area 4
Length:4725 > Matched resources [210]
Volume:0.02 m? Assigned resources [0]

tnictural Matedal Metal - Steel - 345 MPa i

22. Inthe Task List the 3D Resources column should be
populated for the tasks Structural Framing, Area 1-4.

23. Select the tasks Plumb/Bold/Weld Area 1-4 and repeat steps 16-21 using the Maintain Resource Appearance Profile

in Step 17.
i i . ap ~ lAor |Jul
D Name Task Location Duration Start Finish R | [May [Jun | [Aug
lwk 14 [wk 18 [wk 23 [wk 27 fwk 31

50 4 Metals 190d 9:00 AM 4/6/16  5:00 PM 12/27/16
51 STOO350 Base Plates u 9:00 AM 4/6/16 5.00 PM 4/8/16 se Plates
52 STOO36D Structural Framing, Area 1 Area 1 2d 900 AM £/18/16 5.00 PM 4/27/16 StructuraliFraming, Areg 1
53 STOO370 Structural Framing, Aca 2 Area 2 &d 900 AM 4/28/16 5.00 PM 5/9/16 Structural Framing, frea 2
54 STDO032D Structural Framing, Area 3 Area 3 10d 9:00 AM 510/16 5:00 PM 5/23/16 £ tructural Franjing, Area 3
55  STO0390 IStructulaI Framing, Area 4| Area 4 Y| 9:00 AM 5/24/16 5.00 PM 6/3/16 b raming, Area 4
56 STO0400 Plumb/ Bolt / Weld Area 1 Area 1 5d 9:00 AM 4/28/16 5.00 PM 5/4/16 pa 1
57 STOM410 Plumb/ Bokt / Weld Area 2 Area 2 5d 9:00 AM 5/10/16 500 PM 5/16/16 d Area 2
58 STOM420 Plumb/ Bok / Weld Area 3 Area 3 5d 9:00 AM 5/24/16 5:00 PM 5/30/16 Weld Area 3
59 ST00430 Plumb/ Bok / Weld Arez 4~ Area 4 5d 9:00 AM 6/6/16 5:00 PM 6/10/16 Plumb/ Bolt / Weld Area

24. The 3D Resources columns for tasks Plumb/Bold/Weld Area 1-4 and Structural Framing Area 1-4 will have the same
number of assigned Resources, respectively. (i.e. Structural Framing Area 1 and Plumb/Bolt/Weld Area 1 will have
121 assigned 3D Resources).
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13. Adding Equipment
In this section you will learn how to add Equipment to your Synchro Project.

One of the many benefits of 4D scheduling is the ability to visualize space allocation over time. In addition to construction
models (buildings, sites, etc.), Synchro gives you the ability to import equipment models such as concrete trucks, cranes, and
excavators, and simulate their motion through and around the site.

Before starting section 13, please save and close your projects and open Training Building Assigned sp. The steps to do this
are located in section 8.1.

13.1. Importing Equipment Models

Synchro has a library of equipment model files that you can download for free from synchroltd.com or by clicking the
Equipment Library icon on the Support screen. The equipment models available in Synchro’s Equipment Library have
been optimized for use in Synchro, but you are welcome to import your own models if desired.

1. Select il File=>Import=> % 3D
2. Select Add files. Browse to locate the training models. By holding down the Ctrl key you can select multiple files for

import. Select the following files:

e Detailed Crawler Crane.dwf
e  Excavator.dwf
Select Open, then Import
Activate Assign to a new Resource, then Next
Change the name to £quipment
Set the Resource Type to Equipment then Next
Activate Add Resources underneath, don’t build tree and select Finish
The equipment models will be imported to (0,0,0) and will need to be moved to the correct locations

No vk w

13.2. Resource Appearance Profiles for Equipment

You can use any Resource Appearance Profile when assigning equipment models to tasks, but creating a few especially
for equipment may improve the appearance of the 4D sequence.

1. In Navigator—)g Resource Appearance Profiles, create a new user defined profile by right
clicking in the window then selecting Add

2. Rename the profile Equipment Install and ensure it is highlighted
3. Inthe General tab, ensure the Action is set to Install
4. In Active Appearance, enable Original Colour by checking the box next to it (or change the colour if desired)
5. Create 2 more new Resource Appearance Profiles with these settings
Name Action Active Appearance
Equipment Remove Remove Original Colour
Equipment Temporary Temporary Original Colour

These Resource Appearance Profiles may be used as follows:
e Equipment Install: for the first task a piece of equipment is assigned to, plus any tasks where the equipment
should remain on the site after the end of the task
e  Equipment Remove: for tasks when the equipment should be removed from the site at the end of the task
NOTE: Equipment Install & Equipment Remove are typically used in conjunction with each other
e Equipment Temporary: when the equipment is only on the site during the assigned to task — it will not be
visible before the task starts or after the task ends
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14. Editing 3D Objects

In this section you will learn how to manipulate 3D objects by copying and pasting, translating, scaling, and rotating.

Synchro provides control over geometry by allowing you to move, rotate, and scale 3D objects using graphic manipulators.

14.1. Move and Rotate (Simple Manipulator)

We need to move the Crawler Crane to the location where it will be used. To do this, we will use the Simple Manipulator,
which gives us the ability to laterally, horizontally, and vertically move the object. We can also rotate the object around
an axis (X,Y, or Z) using the Simple Manipulator.

Select the Structural Framing, Area 1 task and select Task-=>Focus—=>Center
Select the Crawler Crane in the 3D view so that it is highlighted.

3. Rightclick in the 3D view and choose Edit%OL‘SimpIe Manipulator. The simple manipulator appears on the selected
item

NOTE: If the manipulator arrows are difficult to see or too close together, you can change the manipulator size in
Options=>3D View=>Manipulator

4. To use the manipulator, hover over the required arrow until it grows. Left click and drag to move the object along
that axis. A semi-transparent preview of where the object will move to is shown. Release the mouse to place the
object.

5. Move the Crawler Crane to the new location as shown:

Rotate

6. Use the Simple Manipulator to rotate the crane 180 degrees
around the Z axis so that it is facing the building. )
Awiz to Ratate
TIP: Alternatively, the 3D Properties=>Rotate tab can be used to Ox Oy @z
rotate a selected object. For the crane, choose Z for the Axis to

Rotate and 180° for the Angle to Rotate By, then select the Angle to Rotate By

Rotate button () 90° @ 1807 ) 2700
() Custam
7. Press Esc on the keyboard to exit the manipulator and deselect | z B |
the object
[ Rotate ]
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14.2. Move, Rotate, and Scale (Advanced Manipulator)

In addition to the Simple Manipulator, there is also the option within Edit to use the Advanced Manipulator. This has all
the features of the Simple Manipulator but has the additional options to

oy

. use plane axis movement, or

. . scale the selected object in a particular axis or overall.

To use the Advanced Manipulator, select the required icon with left mouse button, then hold and move mouse to
either translate or scale

We will use the Advanced Manipulator to move the Excavator to the correct location

1. Select the Foundation Excavation task. From the Task ribbon, select Focus=>Start to move the Focus Time to the
beginning of the excavation task
Select the Excavator in the 3D View.

Right click in the 3D view and select Edit—)OL.'Advanced Manipulator.

4. Use the Z axis translation icon (“A” in the image above) to move the excavator so it is sitting on top of the

excavation surface.
5. Use the Z axis rotation icon (“B” in the image above) or the 3D Properties=>Rotate tab to rotate the excavator

90° clockwise.
6. Use the XY plane manipulator (“C” in the image above) to move the excavator to the edge of the excavation.

The excavator should be located as shown below:
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14.3. Edit as Assigned

The Edit manipulators must be applied to an object before it has been assigned to any tasks. After an object has been
assigned to a task, it can be moved using the Edit as Assigned manipulators. The Edit as Assigned manipulators also
allows you to vary the location, rotation, or scale of an object separately for each of the tasks it is assigned to.

The same Crawler Crane is to be used on all four Metals=>Structural Framing tasks. It will need to be located in a
different location for each of these tasks, so we will use the Edit as Assigned command.

1. Select the Crawler Crane and assign it to Structural Framing, Area 1; Structural Framing, Area 2; and Structural
Framing, Area 3 using the Equipment Install Resource Appearance Profile

2. Select the Crawler Crane and assign it to Structural Framing, Area 4 using the Equipment Remove Resource
Appearance Profile

3. Select the Crawler Crane and right click in the 3D window and hover over Edit as Assigned. You will see the tasks the
selected 3D Resource is assigned to

N TN AV Ve VA VA VA YAV A VY
Create Workspace... 4
Edit »
Edit as Assigned » Task[Structural Framing, Area 1] 4
Render Maode ' Task[Structural Framing, Area 2] 3 Unassign
Visibility N Task[Structural Framing, Area 3] ] Focus Time On Assignment
Effacts , Task[Structural Framing, Area 4] 3 Edit Resource [simple)
Visual Indicators )r Edit Resource (complex)
3D Colours » Edit Resource [with snapping to element]
F Change Window Caption...
tting Plages »

4. The Crawler Crane is already in the correct location for Structural Framing, Area 1, so select Edit as
Assigned=>Task[Structural Framing, Area 2]=>Edit Resource (complex)

5. The Focus Time will snap to the
centre of the task and the
Advanced Manipulator will appear
on the 3D resource. Use the XY
plane manipulator and the Z axis
rotation icon to move the crane
to the centre of the active (green)
section of framing and rotate it so
it is facing the building as shown
to the right.
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6.

7.

8.

Repeat steps 4 and 5 for
Structural Framing, Area 3 (shown
right):

Again, repeat steps for 4 and 5
for Structural Framing, Area 4
(shown right):

Beginning before the start of Structural Framing, Area 1, drag the Focus Time through all four Structural Framing
tasks to see how the crane appears on site at the beginning of the first task, moves to a new location for each task,
and then disappears from the site at the end of the last task.
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15. 3D Paths

In this section, you will learn how to create and edit a simple 3D path.

3D Paths can be created to show the planned movement of a piece of equipment or other object. We will create a 3D Path to
show the Excavator moving during the Foundation Excavation task.

15.1. Create 3D Path

1. Select the Foundation Excavation task. From the Task ribbon, select Focus=> = Center to move the Focus Time to the

middle of the excavation task a0 PLAY WINDOWS

2. Inorder to create a more accurate path, we can turn

Il <o a9 e| s
. . . . ) 1 1 et
on Snapping. Right click in the blank space below the 1! . w
Ribbon and enable the Snapping toolbar Colours | Window Axis Zoom Front Filters | Sphere | by means o
< < Indicator~ All~ < = = Extrusion~
se Selection | Indicators Zoom | Viewpoint Create | Workspace:

NOTE: The Snapping toolbar can also be opened by

selecting the Enable Snapping command in the 3D ish -> Start ~ | Standard - Usetol Commands
Ribbon - - )
t X nght click v Fast Options |
here : Markups
5o Structural Framing, A T

3. Ensure that Enable Snapping and Snap to Face are the only options turned on
D Eﬂva et o A M O » 4= &

Enable ] Snap
to Face
Snapping

TIP: Before creating a 3D Path, click in the 3D window and press Esc on the keyboard to deselect all 3D objects.
If an object is selected when a 3D Path is created, the first point on the path will be the center of the objects’
bounding box.

4. Right click in the 3D view and select Create=> 3D Path from the context menu

5. Asyou move the cursor, object faces will be outlined in green and a green dot will preview where you can start
the path. Move the cursor so that it is over the orange Excavation surface. Double left click to place the first
point in front of the Excavator.

6. Double left click at the opposite end of the Excavtation on the brown ground surface to place the second point.
A blue line will indicate the path.
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7. Right click to finish the path.
8. Enter Foundation Excavation for the Path Name, then select OK

9. The path will be listed in Navigator—)& 3D Paths and will be displayed in red in the 3D window.

15.2. Assign 3D Path to a Resource

After a 3D Path is created, it must be associated with a particular Resource that is assigned to a particular task. When
that association is made, the resource will move along the path over the duration of the assigned to task.

1. Select the Excavator in the 3D view and assign to the Foundation Excavation task using the Equipment
Temporary custom Resource Appearance Profile since this is the only task the excavator will be used for

2. Select the Foundation Excavation task, and expand Task Properties=>Resources. You will see a list of the
Resources assigned to the selected task.

3. Expand Equipment Resources and select Excavator.dwf at the bottom level of the Resource tree so that it is
hightlighted in the list and in the 3D window
Scroll down in the Task Properties=>Resources tab to see the 3D Path panel.

5. From the drop-down list which is currently set to <Empty>, choose the Foundation Excavation path
Change the Alignment to Z Max so that the Excavator travels on top of the path.

30 Path

Foundation Excawation -
Alignment £ Max -
Reverze Direction O

7. Click in the 3D window and press Esc on the keyboard to deselect the Excavator.

8. Drag the Focus Time through the Foundation Excavation task to see the Excavator move along the path

9. We can also apply a growth simulation to the Excavation so that the earth appears to be removed as the
Excavator moves.

10. In Navigator%ﬁResource Appearance Profiles, right click the Remove System Profile and select Add which will
create a new User Profile with the same settings in the General tab (ie. Action=Remove and Active Appearance
Colour=orange). Name the new profile Excavation

11. In the General tab, set the Growth Simulation to Front — Back

12. Select the Excavation 3D object and with the Foundation Excavation task selected, in Task
Properties=>Resources, change the Appearance Profile to Excavation

13. Click in the 3D window and press Esc on the keyboard to deselect
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14. Now as you drag the Focus Time through the Foundation Excavation task you will see the earth being excavated
as the excavator moves

Start Center End

aungdation Excavation sadation Excavation FW
HEEEEEN

15.3. Edit 3D Path

When you create a 3D Path, each point along your path is stored as a “Keyframe”. You can edit the values of these

Keyframe coordinates to modify your path.

1. Open the 3D Path Editor Window 3D Path Editor T
. In Navigator =% 3D Paths, highlight “Foundation Excavation” General
3. Inthe 3D Path Editor>General, make sure it says “Foundation M ame
Excavation” Foundation Excavation

Colovr I |
Azsighed Resource
Resource
Taszk

Capture Keyfrarme

4. Under 3D Path Editor=>Keyframes, Keyframe 1 displays the starting point of the 3D Path and Keyframe 2 displays the

ending point.
General General
Keyframe Keyframe

M E = |

Dizplay settings
@ Show absolute values
(70 Show relative values

Dizplay zettings
@ Show abzolute values
(71 Shiowe relative values

Time Time

0.00 1.00

Pozition Pasition

w [ 2982 62 5 |‘ -4000.00
v [2] 22323 61 v |* -28581 61
7 |21 -339.41 z |‘ 2000.00
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For this tutorial, we want the excavator to travel along a straight path to follow the R-L growth for the task Foundation

Excavation.

3D Using Dates[Best] [491x307] o x

5.  Make sure your Axis Indicator is on: Right click in the 3D View and
select Visual Indicators=>** Axis Indicator. In the 3D Ribbon,
uncheck the box next to View Cube to ensure you are looking at
the axes.

6. Asyou can see, we want the excavator to travel along the Y-Axis.

7. Below you can see the original 3D Path(left) vs. the desired 3D Path (right).

3D Using Dates[Best] [491x307] ax 3D Using Dates[Best] [491x307] ax

We need to change the X and Z values of Keyframe 2 to equal the values in Keyframe 1 for our 3D Path to travel along a
straight line in the Y-Axis; only the Y value should vary.

3D Path Editor v B
8. Copy the X and Z values from Keyframe 1 and paste them over the cencral
X and Z values in Keyframe 2. Keyframe

9. Keyframe 2 should now have the same X and Z coordinates as

EE

Dizplay settings

Keyframe 1, but a different Y Coordinate.

10. Move the Focus Time through the task to see the excavator move )
@ Show abzolute values

along the edited path. ©) Show relative values
11. To hide the 3D Path indicators in the 3D window, right click in the Time
1.00
3D window and select Visual Indicators=> ﬁ?SD Paths -
PDSEIJ;D.-—-—-\

v | +] 29581 61

_—-_‘

NOTE: You can also edit 3D Paths using the 3D Path Manipulator. In Navigator-> " 3D
Paths, right click on Foundation Excavation and select Modify 3D Path. You will see a

Manipulator that you can drag, which will automatically update the coordinates of each
Keyframe. Press the esc key in the 3D View to get rid of the 3D Path Manipulator
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16. Copy and Create 3D Objects

In this section, you will learn how to copy existing 3D objects in your Synchro project, or create brand new objects within the 3D
View Window.

16.1. Copy & Paste

Synchro gives you the ability to copy and paste any object regardless of whether it was created in Synchro or imported.
This can be useful if you decide to add duplicate objects such as site offices or equipment after the model has been
imported.

As an example, suppose it is decided that an extra site office is needed to accommodate the BIM team, but this office
was not included in the original geometry file. We can simply copy one of the existing offices and move it to the new
location.

1. In Navigat0r9.3D Sets, select Clear to hide all objects, then show the Site file
2. Select the Field Office & Temporary Hard Standing objects as shown:

3. Right click in the 3D view and select Copy from the context menu
Right click again and select Paste
The copied site office & temporary hard standing will be created in the same location as the original site office
and we will need to assign it a resource.
5. The Resource Wizard is displayed. Select Assign to a new Resource, then Next=>
Rename B/M Office, change the Type to Material, then select Next=>
Select Assign to this Resource, don’t build tree, then Finish
The copied site office will appear in the same position as the original one and we will need to move it to a new
location
8. With the BIM Office still selected, right click in the 3D view and choose Edit—)oL'SimpIe Manipulator

PRO|67




Synchro PRO Basic Training: Copy and Create 3D Objects

9. Move the new office to a new location as shown:

10. Press Esc on the keyboard to exit the manipulator and deselect the object
11. Use the Install Resource Appearance Profile to assign the BIM Office to the Field Office task.

16.2. Creating Objects

Synchro is not a CAD authoring tool, but it does provide the ability to model a few simple objects (sphere, cylinder, box,
and irregularly shaped extrusion). This can be useful to quickly model temporary site logistics such as material laydown
areas.

There is no 3D object for the Temporary Roof at Skylight task so we will create one in Synchro. This will sit over the top of
the opening on the high roof.

1. In Navigator—).3D Sets, select Clear to hide all objects, then show Roofs in the Architecture file
Move the Focus Time to the end of the project so all the objects are shown

3. We will ensure the correct snapping options are enabled. Snapping allows for precise input of object geometry.
Disable all functions except for Enable snapping & Snap to vertex

N [[20px -][8Q O ® %N | HEE S NOTE: To see the uses of other Snapping Functions,
please visit the Synchro Help file. This can be found
Snap to in the Synchro PRO Home window under the
Enable Vertex Support tab or in Options=>Help.
Snapping

Right click in 3D View and select Create=>Box

5. Inthe 3D window move the cursor to the corner until the red marker appears (as shown below) and left click to
define the first corner

6. Then move the cursor to the opposite corner until the red marker appears and left click again to define
width/length, then move the cursor up the define a height.
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10.
11.

12.

13.
14.

=

Enter 3D Object Name... appears - change New Box to Temporary Roof
At the Resource Wizard screen select Assigned to a New Resource, then Next—>
At the Enter Resource details screen, select Next=>
At the Resource Creation screen, select Assign to this Resource, don’t build tree, then Finish
Select the Temporary Roof in the 3D View, right click and select Edit=>Colour.
a. Onthe Standard tab, you can simply change the colour or use Select to pick a colour from an object in
the 3D window
b. On the Custom tab, you can change the colour and transparency by using the scroll bars to the right or
the numeric entry

fa r
o ) (oo . s
Standard | Custom [ ok | [ Standard | Custom | [k |
Colours: Colours:
<
MNew I I Mew
Hue: 133 |2 Red: 115 |2
Sat: 198 = Green: 221 =
Current | - = D237 = Current

Change the colour to a light blue and set the transparency to approximately 50% as shown above right. Then
select OK

Click in the 3D View then press Esc on the keyboard to deselect the box and see the colour

Select the Temporary Roof object and assign to the Temporary Roof at Skylight task using the Install Resource
Appearance Profile

NOTE: Even though the roof is temporary, we are using the Install profile because the task is for the
installation of the Temporary Roof. The Temporary Roof will be assigned using a Remove profile to remove
the Temporary Roof when the Skylight is installed. The Temporary profile should be used only when an object
is used exclusively for the duration of the task it is assigned to.
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17. Synchronising 3D Models

In this section, you will learn how to Synchronise from an updated 3D Model file, check for new objects and assign them to
tasks after Synchronising.

When a design revision is made outside of Synchro, it is possible to modify the 3D Models and still retain the assigned links
between the tasks of the schedule and the objects of the model. This is called Synchronising.

17.1. Optimizing 3D Synchronisation

In order to retain the previously established links between the current model and the project schedule inside of Synchro
upon synchronizing the updated model file with the current Synchro project, the updated model needs to be prepared
to accommodate the design revisions. For optimal results, follow these four guidelines.

1. Export— All the objects that were originally imported into Synchro will need to be exported from the CAD system
again. Any objects that are deleted in the updated CAD file will be deleted in Synchro upon Synchronisation.

2. Import — All new objects will import into Synchro when you Synchronise, but they will need to be assigned to tasks.
GUIDs — All modified 3D data needs to have the same name and Global Unique ID (GUID) number so Synchro
recognizes it as the same item and will retain its assignment. GUIDs are created automatically by the CAD authoring
system (or Synchro plugins).

NOTE: You can change the geometry of an object as long as you don’t delete it and then recreate it, which would
assign a new unique ID, making it impossible to Synchronise with the original object. Splitting an object into parts in
the CAD system creates separate objects with new ID numbers, which will need to be assigned after
Synchronisation.

4. File Name — You can export the updated files from the CAD program with any file name, the original and revised
models do not need to have the same file names for Synchronisation.

TIP: If an object has been subdivided in Synchro, those subdivisions will remain as long as the object ID in the CAD
file is unchanged.

17.2. Synchronising 3D Models

+
1. To begin Synchronisation, select Navigator=> ==!External Data
NOTE: In the general panel, details about the original and last updated files can be checked.

Right click on fArchitecture.dwix] [Import] [mmy/dd/yyyy/ and select Synchronise From.

3. Browse to ArchitectureUpdated.dwrx, select Open and then Next.
When Synchronising a 3D Model, you will be presented with the same import settings that were set when you first
imported the file. These settings should match the initial import settings in Section 5.1.

5. Select the Synchronise button.
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-

Synchronisation... = =

17.3. Identifying 3D Object Changes
_ 17471 old 30 Objects.

1730 new 30 Objects.
changes made (shown right). From this Synchronisation Report, 1669 of the old 3D Dhjects are assigned to Fesources.
we can see: b. 1604 of these assignments will be retained.
ER Resources will loze their representations.

11 of the ald 30 Objects are subdivided.
11 of these subdivizsions will be retained.
Mo 30 Objects will loge their subdivisions.

After Synchronization, a report will appear summarizing the

a. 3D Objects have been deleted, (Notice: there are more
11 more old 3D Objects than new) C.

NOTE: When a 3D Object is deleted upon

Synchronisation, the Object is removed from any Tasks L RIEY Unmatched 30 Object names i
) ) q - System Panel [328408] |
it was assigned to. - System Panel [328407]

- System Panel [§28403]
- System Panel [328405]
- System Panel [§28421]
- Syztem Panel [828422]
3D Objects were deleted; they may have been merged - Doors_ExtSgl_Flush [164355]

with other 3D Objects in the CAD file. - System Panel [807761] =

b. 65 Resources have lost their (3D) representations

NOTE: This does not necessarily mean the associated

. | Create R f 30 Object: b
c. No 3D Object Subdivisions were lost fedte NiEsouices fornew iects (as subliee]

d.  Which 3D Objects were deleted or merged in the CAD

file under Unmatched 3D Object names

6. Check to “Create Resources for new 3D Objects (as sub-

|| Copy Usger Field Walues to Resources

tree)” to automatically create Resources for new 3D Objects
and put those resources in the existing resource tree. (Located at the bottom of the dialog). Select OK.

7. In Navigator=> 3D Sets select to only show ArchitectureUpdated.adwrx.

8. Drag the Focus Time back to the beginning of the project.

9. Right click in the 3D Window and select Zoom=>Zoom All

10. You should see three 3D Objects floating in mid-air. These 3D Objects were added during Synchronisation and have
not yet been assigned to tasks.

Ao Caes e [ SRCH) “'* NOTE: Any 3D Objects that have been added during Synchronisation will not

D : automatically be assigned to tasks. The easiest way to locate these Objects is to go

to the beginning of the project before anything has been installed.

For the purposes of this tutorial, please assign the exterior walls to the task Exterior
Metal Siding/ Backup Framing (Right) and the exterior doors to the task Exterior

D . Doors, Frames, Hardware.

11. Select the 3D Objects and assign them to the task Punched Windows (Right)

D Name Duration Start Finish Aol

74 4 Doors and Windows: 98d 9:00 AM 8/19/16 5:00 PM 1/3/717
75 STOO560 Exterior Doors, Frames, Hardware 4d 5:00 AM 103716 5:00 PM 10/6/16
76 STOO570 Interior Doors, Frames, Hardware 6d 9:00 AM 12/27/16 5:00 PM 1/3A17
77 STDOS80 Glass Entry Doors 7d 5.00 AM 5/7/16 5.00 PM 9/15/16
78 STDO590 Glass Curtain Wall {Front) 20d 5.00 AM 8/15/16 5.00 PM 9/15/16
79 STDOG0D Punched Windows {Left) 4d 5.00 AM 5/16/16 5.00 PM 9/21/16
20 STDOS10 Punched Windows (Back) &d 9.00 AM 9/22/16 5:.00 PM 9/29/16
a1 STDO620 |F‘unched Windows (Right) I 5:00 AM 9/30/16 5:00 PM 930416
82 STDOG3D Punched Windows (Mechanical Room)  1d 5:00 AM 1017416 5:00 PM 10417416
23 STDOE4D Glass Railings 4d 5:00 AM 1242716 5:00 PM 12/30/16
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12. Select the Punched Windows(Right) task and select Gantt=>Focus=>Center. You should see the following:

3D Using Dates[Best] [622x453] o ox
The new 3D Objects created during Synchronisation have ‘ H H H H H H H H H H ” H
been correctly assigned, however this does not account for ——
all 3D Object modifications that resulted from B 7' /‘
Synchronisation. Remember, only 11 Objects were deleted, /‘/1_‘: -——‘/
but 65 Objects lost their Resource assignments. ‘ ‘ ‘ H ‘ ’ H ‘ St ‘ | ‘ I’
%
I~
[T
RV LLEIT RN TRITE R

Let’s compare the same section of the model before and after Synchronisation. (For the purposes of this tutorial,
please use the images below for this comparison). Notice below:

r
97] o = |3] Updated Model |7 o x

HH\H'HHMHHM i UL

ﬁ_

3[ Original Model

! ! .|
| | ||

| I i T I il i

~‘ 0 ‘

| |
IIHII\HIII\HIHH\HIHHHIHIHIHHHHH T TR

i. In the Original Model (above left) there are 4 window pane sections (top & bottom)

}‘\.

ii. In the Updated Model (above right), there are only 3 of these window pane sections (top & bottom).

SUMMARY: The merging of the 2&3 Window Pane sections accounts for the 3D Objects the recorded as deleted in the
Synchronisation Report. If you select the individual Window Panes, as well as the metal borders, you will see that one
window pane section is comprised of multiple 3D Objects. Ultimately, if the Synchronisation Report records deleted 3D
Objects, this does not necessarily mean the Objects no longer exist.
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18. Baselines & Synchronising Schedules

In this section, you will learn how to create a baseline of a current schedule and compare different schedules in side-by-side 3D
windows. You will also learn how to Synchronise from an updated schedule

One of the benefits of Synchro is the ability to quickly and easily bring in updates from an external scheduling program and
see those changes reflected in the 4D model. If changes or progress updates have been made to the original source schedule;
e.g. in P6 or Microsoft Project, the updates can be brought into Synchro using the Synchronise From command in Navigator=>

- External Data. This process is similar to synchronising an updated 3D model file.

Before synchronising from the updated schedule, a Baseline (or copy) of the current schedule can be made in Synchro. A
baseline can be used to compare planned against actual in Synchro. The Baseline saves the dates and durations for all
selected tasks. After creating a Baseline, it can be displayed in the Gantt Chart in a separate colour. Additionally, the Baseline
Start and Baseline Finish dates can be viewed in the Task List.

18.1. Creating a Baseline

1. Tocreate a baseline, you must first select the tasks to be baselined — this allows you to create a baseline of only part
of a schedule if desired. To baseline the entire schedule, right click in the Task List and choose Select All from the
context menu, or press Ctrl+A on the keyboard.

2. The following dialog will appear. Choose Select all Tasks.

NOTE: The second option would result in a selection that excludes tasks hidden by a filter or a collapsed summary
task.

Select All Tasks [

(70 Select anly vizible Tazks (expanded in G antt Chart)

Bz next time

[ k. ] [ Cancel ] [ Help

3. Right click again in the task list and choose Baseline Selected Tasks
4.  You will be prompted to name the baseline. Change the name to Original Schedule

- .
Baseline name ﬁ

MName:

[¥] Askfar the nexttime

[ Ok, l [ Cancel l ’ Help
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5.

7.

8.

When the following message appears, select Yes to calculate the Critical Path

'e The Critical Path is currently not up to date.
L° 4

Refresh before Baselining Tasks?

In the current schedule, the critical path tasks are white outlined in red, whereas tasks not on the critical path are
solid green as shown below. The Baseline is directly over the current schedule, with critical tasks in solid blue, and
non-critical tasks outlined in blue but hollow.

Task on
Critical Path

Task NOT on
Critical Path

To turn off the Baseline display in the Gantt Chart go to Navigator> = Baselines and Scenarios and deselect Original
Schedule:

To turn off the Critical Path display, toggle off f Compute Critical Path in the Home ribbon.
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18.2. Synchronising Schedules (Programmes)

1. To begin synchronisation, select the Navigator-=>External Data tab.

NOTE: All files imported or exported will be listed here. If you’ve imported multiple schedules, make sure you

select the correct one.

2. Right click on [Training Project Schedule.xml] [import] [dd/mmy/yy] and select Synchronise From
Browse to Training Project Schedule Updated.xmi, select Open then Next

When synchronising a schedule, you will be asked to choose Synchronise, Consolidate, Integrate, or Skip for each

of the different schedule attributes.

-

=

Micrasoft Project synchronise from
How would you like to import this file?
Use the Selected Task to merge the data into the cumrent Project
Append the data to the end of the cumrent Project
Choose how you would like to process each object

Object Command

Tasks Synchronise

Links Synchronise

Task constraints Synchronise

Costs Synchronise

Calendars Synchronise

Resources Consolidate

Resource assignments Consolidate

Activity codes Synchronise

Codes assignments Synchronise

User fields Synchronise

User field values Synchronise

Users Skip

Defaut | [ Skipal |
[ < Back ][ Synchronise ] [ Cancel ] [ Help

]

NOTE: Schedule attributes are located in the
Object column (shown left) and include: Tasks,
Links, Task constraints, Costs, Calendars,
Resources, Resource Assignments, Codes
assignments, User Fields, and User Field values.

The Synchronisation options (Synchronise, Consolidate, Integrate or Skip) are explained in the chart below.
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SYNCHRONISE

If you choose to Synchronise, the existing schedule in Synchro will be completely replaced with the updated external schedule.

Outcome: External schedule takes precedence over Synchro schedule when Synchronising according to the following rules:
o Attributes ADDED externally = ADDED in Synchro
e Attributes DELETED externally - DELETED in Synchro
e Attributes MODIFIED externally = MODIFIED in Synchro
o Attributes ADDED or MODIFIED in Synchro = OVERRIDDEN

NOTE: In the current version of Synchro Pro 5.1, the option to Synchronise is not available for P6 global objects (such as
Calendars, Resources, Risks and Activity Codes) since these cannot be deleted. Synchronise is the default choice for Primavera
P3.

CONSOLIDATE

If you choose to Consolidate, any schedule changes made externally or in Synchro will still exist, NOTHING IS DELETED.

Outcome: Merges the External and Synchro Schedules when Synchronising
o Attributes ADDED externally = ADDED in Synchro
o Attributes MODIFIED externally = MODIFIED in Synchro
e Attributes ADDED or MODIFIED in Synchro = MAINTAINED

INTEGRATE

If you choose to Integrate, any modifications made to the selected external schedule in Synchro will be overridden. However, any

additions to the schedule in Synchro will be maintained.

QOutcome: External schedule takes precedence over Synchro schedule for all Attributes not originally created in the external
schedule.

o Attributes ADDED externally = ADDED in Synchro

o Attributes DELETED externally = DELETED in Synchro

e Attributes MODIFIED externally = MODIFIED in Synchro

e Attributes ADDED in Synchro = MAINTAINED

e Attributes MODIFIED in Synchro - OVERRIDDEN

NOTE: Integrate only affects schedule attributes associated with the selected schedule being Synchronised. Thus the option to
Integrate is most commonly used when multiple schedules have been imported into Synchro so no project data is lost upon
Synchronisation. Integrate is the default choice for Resources and Resource Assignments. The option to Integrate is unavailable
for Microsoft Project XML.

SKIP

If you choose to Skip, the associated attribute will not be modified or updated.
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Use the following flowchart to determine whether to Skip, Synchronise, Consolidate, or Integrate each attribute. For each
attribute (eg. Links, Calendars, etc) substitute the attribute name wherever “[tasks]” appears in the flow chart.

Do you wish for changes to
[tasks] in the source

program to override the
corresponding values in
the Synchro file?

Yes

Has more than one
schedule been imported to
the Synchro file?

Have you added any new No

Synchronise
[tasks] in the Synchro file? ’

Yes Yes

Integrate

Were [tasks] deleted in the No

Consolidate
source program?

Yes

Do you want the [tasks]
that were deleted in the
source program to be
deleted in the Synchro file
as well?

No

Yes

SUMMARY: Any attribute that you have added or modified in Synchro since importing will need to be considered. For
example, if you have not created any tasks, calendars etc. in Synchro but have just created Resources and Resource
Assignments, those are the only two options that you will be required to Consolidate or Integrate instead of Synchronise
to ensure that Synchronisation works correctly and that all assignments are retained.

See “"Appendix F: Synchronisation Scenarios" for further information and to test your knowledge of these options.
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- ™y
5. Since we have added new tasks and links, created oo Pt S ‘ i
resources from 3D objects, and assigned resources to
tasks, we should not use Synchronise for these options How would you like to impart this file?
Ise th h dein’s h il b idd Use the Selected Task to merge the data into the cument Project
or else the changes made In >ynchro will be overriaden Append the data to the end of the cument Project
with the changes in the Training Project Schedule
Updated.xml. We can Skip attributes that are not Choose how you would like to process each objsct
contained in the schedule. Select Skip All, and then set Object Command l
your synchronisation options as below. Consolidate will Tasks Consolidate
X . Links Congolidate
merge updates from the XML with new tasks created in e p—— Synchronise =l
Synchro. Costs Skip
Calendars Congolidate
Resources Skip
Select the Synchronise button Resource assignments Skip
7. The Synchronisation Report indicates what has been Activity codes Skip
) Codes assignments Skip
updated. You can save this report for future reference User fields Skip |
if desired by selecting Select All followed by Copy to :jser“e'd values gt‘p
. sErs ip
Clipboard
8. Select Finish to exit the report
Defaut | | Skipal |
[ < Back ][ Synchronise ] [ Cancel ] [ Help
W A

9. The Data Date has been updated (as indicated in the Gantt Chart by the blue dotted line). Before rescheduling, in
Navigator> = Project=> Details, ensure that Schedule From is set to Data Date. In Project=>Details you can also view

the new Data Date

Project

Mumber of Tazks
122

Project D ate Zero

[06 Apr 15 +[C]

Data Date

() Mutomnatic

@ Manual

[09:00 15 May 15 & E)

Schedule
@ ASAP
) ALAP

Schedule From

@ Data Date

() Project Start
() Selected Date
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10. Select F9 on the keyboard to manually reschedule the tasks that were created in Synchro.

11. In Navigator->™=Baselines and Scenarios, select the Original Schedule to display it in the Gantt Chart and see
how the schedule has changed. You can see that the Notice to Proceed has been delayed about a month, lag
has been added between Award Subcontractors and the Material Procurement tasks and tasks have been

updated for actual progress.

- Jan 2016 Apr
Name T [Feb [Mar |Mav [Jun
‘ ‘ wk 1 [wk 5 [wk 10 wk 14 wk 18 [wk 23

4 Office Building. Core & Shell
4 Pre Construction
Motice to Proceed
Building Permit
Award Subcontractors

Perimeter Fence

100 % Complete
Complete

Temporary Hard Standing
Field Office
4 Material Procurement
Structural Steel
(Glass Curtain Wall
Elevator
MEF Equipment
A Construction
4 Site Construction
Foundation Excavation
. 4SmoualPles
Piles 1
Piles 2
Piles 3

18.3. Compare Baselines using 3D Views

In addition to seeing the changes to the baseline in the Gantt Chart, it is possible to visually compare the baseline against
the updated schedule in side-by-side 3D windows. Each open 3D Window can independently be set to use either Best,
Actual, Planned, Proposed, Baseline or Original dates. This allows for the comparison of different baselines, baseline vs.
planned, baseline vs. actual, actual vs. planned, etc.

1. From the Windows Ribbon select 3D to create another 3D View (which is typically positioned above the

first 3D View) —
2. Leftclick in the title bar of the new 3D window and drag the new 3D window over the first 3D window, =
and release the mouse button over the right side of the smart window placement icon. D q ’ D
A preview of where the window will be placed will be shown before you drop it in place. =
—
3D Using Dates[Best] [1255x362] > Aox

3. Modify one of the 3D views so that you can see the whole building.
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4. Right click in the modified 3D view and select Viewpoint=> %ﬂAppIy Viewpoint to all 3D Views so that the camera
angle in both windows is the same.

5. In Navigator=> ™ Baselines and Scenarios, ensure that the Original Schedule is selected. Right-click in the first 3D
View and select Dates To Use> ™ Baseline from the context menu. This will display the geometry in the window
according to the baseline dates. The other window should be set to Dates to use=> ™ Best by default which will
show the current schedule.

6. Move the Focus Time through the project to review how the new schedule (below right) compares to the baseline
(below left).

3D Using Dates[Baseline] Baseline[Original Schedule] [685x465] ~ & x 3D Using Dates[Best] [685x465] v 8 x

7. Click the X in the top of the 3D window using Baseline dates to close it

PRO|80




Synchro PRO Basic Training: Cutting Planes

19. Cutting Planes

In this section you will learn how to create a cutting plane, which allows you to see a section or plane of your model in the 3D
Window.

Cutting planes may be used for example, to view inside of a building or underground when working in Synchro, when playing
the Focus Time, or when exporting an animation.

1. Ensure that the Focus Time is at the end of the project and all objects are shown
2. Right click in the 3D Window and select Cutting Planes=>Cutting Plane Z
3. Left click to place the cutting plane on the roof which will appear as shown below.

NOTE: To set a Cutting Plane, you must click on an object, not in empty space

4. Asimple manipulator appears. Move the cursor over the manipulator until the vertical icon ‘grows’ then hold
down the left button and drag the cutting plane up and down in the Z direction, so that you can see into the

Level 1 space.
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5. Open the Navigator-> #Cutting Planes tab and you will
see the New Cutting Plane listed.

Cutting Planes

6. Left click on New Cutting Plane and rename as Office Z1

<all= 2
7. The plane can be turned on/off by enabling/disabling » New Cutting Plane
the check box
8. The Show Plane and Show Manipulator check boxes
allow you to hide these visual indicators in the 3D view,
while still applying the cutting plane. This may be useful
when exporting an animation, for example. After
changing the preferences, press Apply
9. Right click on Office Z1 and you will see the following
options Faint
[0.0.0)

Cutting Planes

Marmalized direction

<all 0o

: [0.01]
[ Office1 Add
Rename Shows Plane
Remaove Show b anipulator

Create Copy

Apply
Invert Direction

|lze az growth direction

10. Select Invert Direction to change the direction of the cutting plane-

11. Invert Direction once again to revert back

NOTE: X and Y cutting planes can also be created, cutting planes can be rotated off-axis, and multiple cutting planes
can be applied simultaneously.
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20. Viewpoints

In this section, you will learn how to create and save a Viewpoint.

Viewpoints can store Focus Time, Camera Angle, applied 3D Sets, and Cutting Planes. A saved Viewpoint can be reactivated at
any point in one or all 3D windows. This can be useful for returning to a particular time or view after updating a schedule or
model to see what has changed, or to quickly jump to points of interest when presenting to stakeholders.

1. Adjust t.he Camera Ahgle toa desire.d view and move the Viewpoi nts
Focus Time to a particular moment in time

<all Do

Qo0
. I .
2. Select Navigator=> ®iewpoints New Viewpoint - 5:00 PM 3/23/2016

3. Right click in the top white window in Viewpoints and select
Add

4. This will create a new viewpoint. Change the name to
something descriptive

5. Inthe General panel, you will see that any currently
activated 3D Sets and Cutting Planes are saved with the

Viewpoint
o ) G [
6. Change the Focus Time in the Gantt Chart, and then edit enera
Camera Angle and turn off the Cutting Plane in the 3D Description
window. URL g
7. Toreturn to the saved Viewpoint right click on the Camera | Gt fram 30 View ]
Viewpoint name and select Activate in selected View
Time |23 Mar 16 2
Clear Markup
NOTE: If you update the Camera Angle and/or Focus Time and wish
. . SetC /F Ti
to resave with the new values, select the Set Camera/Focus Time [ —_ ]
button. You can also enable/disable Cutting Planes and 3D Sets to be Cuting Planes
. . . . <all jol
saved with the Viewpoint using the checkboxes. =
P & 3 Office1
Filters
<all: e
[ 3D by Selection [System]
[ 5ame as Task Fiter
» [ 20 Obiject Fitter
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21. Animations

In this section, you will learn how to create and edit an animation, and export it to an AVI video.

Having created your 4D schedule within Synchro it also possible to create a scheduling animation that can be communicated
to third parties or exported as a video and used as presentation material (without the need to install Synchro). Animations
can show an overview of the whole project, or you may prefer to create an animation that focuses on a few tasks or a few
days of construction (e.g. a particularly complicated sequence).

21.1. Creating an Animation

For practice, we will create a basic overview animation that spans the entire duration of the project with a camera that
slowly spins around the outside of the building.

1. Inorder to avoid clipping the sides of the view when exporting the animation, set the 3D window to roughly the
same aspect ratio as the desired output before creating the animation. To do this, undock the 3D window by double
clicking in the header bar or left clicking and dragging.

2. You will notice that the size of this 3D window is stated in the top left hand corner so you can alter the size to
the required aspect ratio size that you want. Resize the 3D window to 800 Wide x 450 High (or approximately
16:9 ratio to suit the size of your screen)

3. In Navigator> mAnimations, right click and select Add to create a new animation.
4. Select the New animation, rename it Site Tour and ensure that it is highlighted
5. From the Windows ribbon, open the & Animation Editor
6. Move the cursor into the Animation Editor (do not left click!) and roll the mouse wheel to rescale to the
required timescale, in this case 30 seconds
Animation Editor P
| 0 sec n | 10 sec . | 20 sec ] 4 30 sec 0
II"IIIIIIIIIIIIIIIIIIIIIIIIIIIIIAI’IIIIIII
|
Camera I - - -
: Scroll the middle mouse wheel in this
|
. . area to rescale the timeline 30 Seconds
ocus TImEI
|
' Mew Animation

Animations are made of a series of Keyframes which define the viewpoint (camera-angle, position and zoom) and
contents (Focus Time) of the 3D Windows at a given point in time within the Animation.

A Keyframe is added by left-clicking in either the Camera or Focus Time channels of the Animation Editor Window.
The added Keyframe records the current settings of the camera or the Focus Time. Camera Keyframes are marked
by a grey diamond in the Camera animation channel. Focus Time Keyframes are marked by a yellow diamond.

7. To define the start of the animation; move the Focus Time in the Gantt Chart to just before the start of the project.

8. Left Click in the focus time channel of the animation editor at Osec. A yellow Keyframe marker < will appear.

9. To define the end of the animation move the focus time in the Gantt chart to just after the end of the project.

10. Left Click in the focus time channel in the animation editor at 30sec. Another yellow Keyframe marker < will
appear.

11. Select and drag the red Focus Time Marker in the animation editor to review the stored timeline. This can also be

done with the options in the Play Ribbon by selecting i Play Animations. Then click Move to Start followed by Play
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12. Modify the 3D window to show the entire site as shown

3D Using Dates[Best] [750x430] B

13. To create a Camera viewpoint Left click € in the camera channel of the animation editor at Osec. This defines
the view at a particular point in time.

Animation Editor o x

0sec r |10 sec n | 20 sec n | 30 sec
1 | | | | 1 | [ | | 1 | | |

Camera >

9:00 AM 322015

g N

Focus Time

MNew Animation

14. Move the Focus Time Marker in the Animation Editor (not the Gantt Chart) forward to about 5 seconds.
15. Modify the 3D view by zooming into the work area as shown

3D Using Dates[Best] [750x430]

16. Left click @ in the camera channel of the animation editor at 5 seconds to set this view at this time.

Animation Editor o x
0sec r |10 sec i | 20 sec N | 30 sec
1 ¥ N — T T T 1 I I -
)
camera >———
N :
)
Focus Time '
i AN
Mewy Animation
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17. Move the Focus Time Marker in the animation editor forward to 10 seconds
18. Modify the 3D view by orbiting around to the side of the building as shown

3D Using Dates[Best] [750x430]

19. Leftclick € in the camera channel of the animation editor at 10 seconds to set a view at this time.

20. Repeat steps 17 — 19 four times in order to orbit around the entire building setting camera points every 5
seconds.

21. Review the animation by dragging the Focus Time Marker in the animation editor or click Move to Start followed
by Play in the Play Ribbon.

TIP: Pressing the space bar on the keyboard (while an animation is selected in Navigator=>Animations) will play
and stop the Animation.

21.2. Editing the Animation

After reviewing the animation you may find that you need to edit some of the camera angles.

Right click on the grey marker €% in the camera channel and select Snap To Viewpoint
Modify the 3D window to get the desired camera angle.
3. Right click on the grey marker €? in the camera channel and select Use Current Viewpoint.

NOTE: Snap to Focus Time and Use Current Focus Time work similarly.

You can also edit the animation by adding more points. o x
| 20 sec |
| |

4. Drag the Focus Time Marker in the Animation Editor to a point in

time in the middle of two of the camera nodes N N
5.  Modify the 3D window accordingly

6. Leftclick in the camera channel of the Animation Editor where N -
ew Animation

the Focus Time Marker intersects the camera channel.

Sometimes long tasks or gaps in the work may want to be condensed to speed them up and short tasks expanded to
slow them down. If this is the case then this can be done in the Focus Time channel.

7. Add additional Focus Time Keyframes at the beginning and end of a sequence you want to speed up or slow
down. (i.e. add Keyframe 1 at the beginning of a task and Keyframe 2 at the end of a Task)

8. To move a Keyframe, hover over it until a double arrow appears. Left click and hold while dragging to move.
Move Focus Time Keyframes closer together to speed up the activities in between. Move them farther apart to
slow down time in the animation.

NOTE: If you move a Keyframe and want following Keyframes to move with it, hold down Shift when you are
moving the Keyframe.

TIP: If many Keyframes appear to be overlaid, scroll the mouse wheel forward to zoom in on the timeline.

PRO|86



Synchro PRO Basic Training: Animations

21.3. Interpolation

At the end of the animation you may want to rotate the project for a final overview (or you can use this feature at
any time in your animation). This is achieved using a Turntable camera interpolation

Interpolation defines how the Animation transitions Add
between Keyframes. The term interpolation is used to
describe the transition from one state to another,
. . -, Remaove All
which for a Camera is from one position and angle to
another, or for Focus Time is one point in time to Generate Timeline
another. The Interpolation Type dictates how the Edit Focus Times
transition is achieved and includes Curve, Line, Step,
Turntable, and 3D Path options. By default, Interpolation Type r Step
Interpolation Type is set to Line. +  Line
The different Interpolation Types are explained in this Curve
chart:
30 Path
— A |
[]
i
%Q Zoom In
. - Zoom Out
i
i

Interpolation Camera Behaviour: Focus Time Behaviour:

Type:

Curve Linear interpolation along a calculated curve N/A
between the 2 points

Line Linear interpolation along a calculated Linear interpolation
straight line between the 2 points between 2 focus time
positions
Step No interpolation; Jump from 1% to 2™ position No interpolation; Jump
from 1% to 2" focus time
position
Turntable Camera rotation around the currently N/A

selected 3D object. When chosen, the
Turntable Options dialog is displayed to
configure the rotation

Camera follows the selected 3D Path using the
camera angle of the first Keyframe relative to the
path. When this Interpolation type is chosen a
dialog is displayed to choose the path to follow

3D Path N/A

NOTE: Interpolations are always between two neighbouring Keyframes. The interpolation type assigned to the
first (left) Keyframe defines the transition to the next(right) Keyframe
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1. To set up a Turntable interpolation, select an object in the 3D View that you want to rotate about. The camera will
rotate about the centre of the selected object’s bounding box.

TIP: If you want to spin around the entire
model, select an object that is central to
the model or spans the whole model
(e.g. the Glass Skylight).

2. Find the Glass Skylight task in the Task List, right click to Select Assigned Resources.

3. Right click on the Camera node at 30 seconds and select Interpolation Type=>Turntable

4. You will be presented with the Animation Turntable Options where you can decide on Rotation degrees, Direction
and move the Preview bar to review. Keep the settings as default then select OK

r ™
Animation Turntable Options ﬂ
Rotation degrees | = 360 ‘

Direction (@ Clodkwise

() Counterdockwise
Preview
[ 0.00
[ (08 ] [ Cancel ] [ Help

e S ——
5. Decide how long you want the rotation to last for- we will have this for 10 seconds so create another camera point

at 40 seconds in the Animation Editor

30 sec r | 40 sec
I |

Rk

6. Press Escape to cancel the 3D selection
7. Move the Focus Time to 30 seconds in the Animation Editor window and press Play in the Play ribbon to see the
effect of the Turntable.
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21.4. Exporting an AVI

Once an animation has been created, it can be exported as an AVI file which can be shared and played by a video player
on any computer.

TIP: Before the animation is exported it is recommended that a small duration of a few seconds is added to the end.
Otherwise it will snap back to the beginning once it’s been exported.

1. Dragthe Focus Time Marker to the end of the animation and Left Click in the focus time or camera channel of the
animation editor at about 45 Seconds. (This will add 5 seconds to the end of the animation).

2. At this point it’s typical that the ** Axis Indicator, *# Grid, andw 3D Path are switched off. Right click in the 3D
Window, select Visual Indicators and click on each one to deselect to make sure they are all turned off.

3. Select Navigator—)mAnimations, right click on the “Site Tour” animation and select Export AVI.
Select Desktop and create a new folder named Site Tour. Open the folder and press Save.

21.4.1. AVIResolution

5.  You will be presented with the “Export AVI” window with Resolution options shown:
6. For the purposes of this tutorial, please use:
i. Resolution — (1280 x 720) '
ii. Frame Rate — 15 [the number of JPEG images per Resolution | Content | Rendering Options | Images | Seundirack | Timeline | Textual Frames|

second] Resolution Duration
NOTE: The higher the frame rate, the better the )

Height 3720 Finish (sec)
quality of the video, but it does take longer to Fame Fate  [E1 15 _— — =
export. A good maximum frame rate is 24. Solt every (sec)

iii. Duration — Split every 10 Seconds Compression
NOTE: The maximum AVI export size is 2 GB, orec: Hleroseit Hiceo Change
splitting the video ensures that the files will not Fle for Expor
exceed this. This will also allow you to re-export C\Users\Stephen DolanDeskiop"Site Tour avi
sections Of the AVI lf you have Changed your I:lExportthe animation as a sequence of JPEG images with Good
o rOject. given quality il

iv. Compression — Codec: Microsoft Video 1 (If it is
not already set to this please select Change)
v. Compression Quality — 100

Compressor: 0
[Microsoﬁ\"ideo1 VI

Cancel

C ion Quality: 100
ompression Quality: Configure._

About .

A
E

NOTE: You also have the option to export the AVl in a JPEG format. Frame rate will determine how many JPEG files
are created per second. You can combine the images in an Animation software package if required. If you want to
export to a series of JPEGs, enable the checkbox and choose what image quality you wish to use.
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21.4.2. AVI Content

In the Content tab, you can choose what to display in the animation.

7.

10.

11.

12.
13.

14.
15.

Select the Content tab.

Export AV ===

. . .l._\um.‘_-::-_m_ I Sounmﬁ\. ";-u'?od.nl-'rum B B ) i
TIP: You can resize the size of the Export AVI ooy
1200 AM 27216
window by moving the cursor to the edges, T ‘
¥ Focused Time

holding down the left mouse button, and R 20wt
dragging to suit. A larger window may make it VEETTETE

|| Assearance Profies

easier to edit the window contents.

Select 3D Using Dates, 3D Legend, and Focused —
Time, then resize and move them in the preview s

- -
]

window.

ok Lpdate of the windaw
sortenr

ke nepact o of 30 views

NOTE: At the top of the screen is a Preview Bar
which you can move to check your animation
before export.

Select Software from the Dropdown Box

NOTE: The Drive options in the drop-down menu

depend on which drive you have installed on e —— —
your computer. Software will use the Synchro driver to export the AVI. Choose Direct X 11 if you plan to use effects
like shadows or textures.

Set Anti-Alias to 2x.

NOTE: Anti-aliasing increases the quality of the output, but greatly increases the time it takes to export.

Other Content options:
i. Lock update of the window content — this enables you to modify the size of the windows without it trying to
render every time. Unlock this to see the true view after movement, resizing etc.
ii. Keep aspect ratio of 3D views - enables same aspect ratio as the main 3D windows you created earlier. (16:9
aspect ratio in this case)
Select OK in the Export AVI window.
After each AVI has completed exporting, double click the file (or files, you should have 4 ten second AVI files) to play
the videos (for example, in Windows Media Player).

TIP: You can combine the ten second clips in movie editing software, eg. Windows Movie Maker to show the whole
animation.

Close the Animation Editor window by clicking the “x” in the upper right window corner.
Double click on the yellow area above the 3D Window to re-dock the 3D Window.
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22. Output

In this section you will learn how to save a Viewpoint as an image, how to print from the Gantt Chart, and how to export the
Gantt Chart to a PDF.

22.1. Save as Image

You can easily save an image of the 3D window to share with others. There are 2 ways to save an image.

1. If you have a saved Viewpoint that you would like to export as an image, in Navigator-> ®«Viewpoints, select the
Viewpoint name, right click and choose Save as Image
Name the file and choose the file type (PNG, BMP, or JPEG) from the drop-down list.

3. The Save as Image dialog will appear. There are options to change the image size (or keep it the same as the 3D
window), set the graphics driver Type, Antialiasing (higher values improve quality), and apply Effects including
Shadows.

NOTE: The OpenGL driver does not support Effects

Save the selected 3D view as image...

Image Size [pixels]
@) Like selected 3D View

(7) Custom Don't keep aspect ratio

Width: 1077 Height: | 209

JPEG Image Quality

Super -

Rendering Parameters

Type: [DirECtK hd ]

Antialiasing: [1}( v] ["1Enable Software

Effects: [] Ambient Occlusion [ shadows
[|Fast Silhouette Edges [ | Bloom

Image Filename

Ci'\Jsersy DocumentsYCustor

Ask the image name before raising this dialog

L A
4. Setthe options as desired, and press OK to save the image.
5. You can also save an image of the current 3D window without first creating a Viewpoint, by right clicking in the 3D

window and choosing Save as Image from the context menu.
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22.2. Printing the Gantt Chart

The Gantt Chart can be printed from Synchro to share with others without the need to share the SP file.

1.

>

© N o Wu

10.

11.

12.

13.

14.
15.

When printing the Gantt Chart, what you see is what you get,
so use Customise Columns in the Task List to choose which
columns to include in the printout

Before printing, set up the printer and page layout by

selecting File=> IJJ%:_‘?J Print Setup

For printing the Gantt Chart, set the Orientation to Landscape
A good Paper Size for printing the Gantt chart is Tabloid (11” x
17”)

Press OK to finish setup

Select File=>Print

In the Print dialog, choose the Layout tab

-

Print Setup
Prirter
MName: CuteP DF Writer V] [ Properties. .. ]
Status: Ready
Type: CutePDF Writer
Where: CPW2:
Comment:
Paper Crientation
Size: [Tabloid v] () Portrait

Source: ’N_rtomaticall)' Select

v] @ Landscape

-Neiwork... OK Cancel
Ensure that View to Print is set to Gantt - | I ]
NOTE: From the View to Print drop-down you rr.,,-n Print s |
can also select other open windows to print
. . ut
including 3D | General | Layout | Legend

View to Print Horizontal pagination
When printing the Gantt Chart, Fit to Exactly: | Gant M © Actual Size
1is a good choice for the Horizontal Vg flimees) © Fitto at most =

argins {milimetres, @ 4
pagination and Fit to: Exactly for Vertical @ Fitto exactly

. . Left: 10 Right: 10
pagination Vertical pagination
A Date Range can be applied to the schedule Top: 10 Botom: 10 @ Actual Size
if desired (eg. to export a 3 week look ) Fit to at most
ahead). To print the whole schedule, leave Date Range ) Fit to exactly L
thi i disabled [] Use Date Range
15 option disabled. o Data Date + days Print order

Select Apply to save changes to this dialog e~ ® Down, then over
before previewing or printing — ©) Over, then down
If desired, a Legend can be added to the To: [10/30/2014
printout in the Legend tab
Select Preview to view the Gantt Chart Pt | [ Cancel || Apply |

before printing "

From the preview window, select Print to return to the Print dialog

Select Print

PRO|92




Synchro PRO Basic Training: Output

16. The printout will look as below

Illll’ll

22.3. Export 3D PDF

Synchro gives you the ability to export a 3D View of the project as a 3D PDF, which can be manipulated in any PDF
compatible programs, such as Adobe Reader. This can be used to share the 3D Model with others electronically without
having to share the Synchro Project file.

1. Move the Focus Time in the Gantt Chart to show any view you would like to export.

In the Home Menu Select [E —>Export~> % 3p
In the Export 3D Window, Select Browse to choose where you would like to save your 3D PDF

i. Choose a file name r n—

- “ ” Export 3D [
ii. Set “Save as Type” to 3D PDF(*.pdf). —
ii.  Select “Save” |

4. Select the following Options File name

i. Export Mode: Export in accordance with the current Focus Time P me et e

ii.  Datesto use: Using Dates [Best] How wouid you lie to cxport 3D Objects?
iii. Check: Take into account global 3D Filter Export mode:

(7 Export to the Original Positions I

NOTE: By enabling Global 3D Filter, you will only export 3D Objects that
are loaded in the project in the 3D Objects window.

(@) Export in accordance with the cument Focus Time

(2) Export Animation
5. Select Export Datesto use  Using Dates[Best] v
NOTE: You cannot export an animation in 3D PDF format. I [ Take into account 30 view fiter I
6. When the 3D PDF has finished exporting, open your file inside of a PDF ey
compatible program to view the 3D Model. [¥] Take into aceount global 30 fiter
|
<Back || Epot | [ Cancel | [ Heb |
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23. Appendix A: 3D File Formats

Synchro can import the following file formats into version 5.0:

AutoCAD DWG

AutoCAD DXF

Autodesk DWF

Autodesk FBX

Bentley Microstation

Bentley Microstation (SS2, SS3)
Collada DAE

HOOPS stream file

Revit (2014, 2015)

Navisworks NWD, NWF, NWC (2015)
Trimble SketchUp (v7, v8, 2013, 2014, 2015)
3D PDF

ACIS Files

Autodesk Inventor Files

CATIA V4 Files

CATIA V5 Files

Dassault Interchange Format Files

I-dea Files
IGES Files
I1SO-15926
Parasolid Files
ProE/Creo Files

Rhino Files

Siemens NX Files

Solid Edge Files
SolidWorks Files

STEP Files

Sterio Lithographic Files
UGS JT

Universal 3D Files
VDA-FS Files

VRML Files

* dwg

* dxf

* dwf; *.dwfx

* fox

*.dgn

* spx (via Bentley Plug-in)
*.dae

* hsf

* spx (via Revit Plug-in)

*spx (via Navisworks Plug-in)
*.skp

*.prc; *.pdf

* sat; *.sab

*.ipt; *.iam

*.model; *.session; *.exp; *.dlv
* catpart; *.catproduct; *.catdrawing; *.catshape; *.cgr
*.3dxml

*.mfl; *.arc; *.unv; *.pkg

*.igs; *.iges

*xml

* X_t; * x_b; *.xmt_txt; *.xmt_bin
* prt; *.prt.*; *.asm; *.asm.*; *.neu; *.xas; * .xpr
*.3dm

* prt

*.asm; *.par; *.pwd; *.psm

* sldprt; *.sldasm

* stp; *.step

* st

* jt

*.u3d

* vda

*wrl; *.vrml
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24. Appendix B: Bentley 3D Workflow

24.1. Using the Bentley Microstation V8i SELECTseries Plugin

The Microstation Plugin allows DGN files to be exported out of Microstation as Synchro (.spx) files. Once exported this
.spx file can be imported into an existing Synchro Project (.sp) file.

1. There are currently two versions of the Synchro plugin: SELECTseries 2 & SELECTseries 3
You can determine your installed version of Microstation from the Help=>About dialog.
i If you have a SELECTseries 2 product, please install that version of the plugin
ii. If you have SELECTseries 3 or higher (554,SS5) product (including Microstation and AECOSim), please install
the SS3 plugin.
3. Runand install the setupMicrostationSynchroPlugin.exe (double click on the set up file and follow the on screen
instructions)
4. Once the Plugin has been installed, open up the DGN in Microstation.

M crobuation VB SEETwrer S O FarT

5. Set Utilities from the Menu Bar = Select MDL Applications.

P _bane ek e 58 RG] Vit e
Fe E& Hewot Seficen Toch s Sotmowe Tindow Heo

2. Select MDL
Applications

B - D - B e -] B WEEss]]s) % ¥ z

et Splection > Khrtfy slamat 1 141 20t [P pe—— J & ssmecon
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6. Highlight SYN_PLUGIN within Available Applications = Select Load

0%
% 1 View 1 - Right eometeic_ Master-Lofite

T ea e ARRLHO WBIDIFTAE
IR ¥ KT

= il

¢ Dependency Service 1 E S A

Crmate Bicch

2. Select Load

Ermune

ol SR oT L ]

g
g COMposSon

Subds Madeing

LR

P surfece Mideing

~

I,

TR
W

© e Msdaing
dy Terran Hodet
B Feature Modeing

o visusizatien

€/ ¢ ¢ ¢ € ¢ € ¢ ¢

M anemation

1. Highlight
SYN_PLUGIN within
Available Applications

* Ko Maderdofion = 01 W[Ef]e]]s]7]e] | X ¥ z

Eiomert Seinction » Merefy slomert 12 84 15 st MCM risaded < | @ [ssTRS0ONC

7. Highlight SYN_PLUGIN within Loaded Applications = Select Key-ins

#h _raarer-LoRiseicheme dgn (10 -V BGN] - MicaStation Vil ereer
B L& Oevert Settrgs Toe \btes Wolgmece Wndew Meb
& - sstRscon 3o~ |Eo== oG-~ H R R R R R R A ) R Ry ]

R T P X1 o1 - Fight onetie, _Master Leflise == ] | = . Master Lefise ===
Mo -a%- AL 3 TH4H WO ITALE G - AR IHBMN WEE|HT
i R
o M oL o

¢ Dependency Service 552 A

. Draming -

B Drawing Compasition

7 2\

T

1. Locate & highlight
SYN_PLUGIN within
Loaded Applications

il

==

i 5

&

3
SITTER S EXSERE TITEY,

3 - Frant, _Master-Loflise =
ARG HBHAO WEEHTEGE

LI LIETEETT T |

3 - @ - e [ metorse +] T [1]2]5]4]5]s]7]a] i X ' ¥ [sEEia Z i

et Sescson = karty slamant ta 535 uet STH_PLUGIN eaded J | & lesmascone
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8. You will now see the Synchro Plugin Window. There are a number of export options available to you:

e Coordinate System — Can be used to export in world r ~
coordinate system or in local “Global Origin” coordinates Synchro plugin A ﬁ
system. The “global origin” can be queried by typing “go=" _ i
command in Microstation. NOTE: Microstation exports files in - 5 p
local “global origin” coordinate system (export to FBX, JT, - o l-!
etc.), but when you x-ref the file into another DGN — it appears = & - - =
in global “world” coordinate system.

e Ignore Wireframe 3D Objects — Can be used to skip the import File name
of polylines, lines, circular arcs, circles, elliptical arcs, ellipses, E]
nurbs curves objects

o |gnore Text Elements — When disabled, causes Synchro to also Options
read and store any text attributes that may be defined against
the geometry when it is imported. These attributes may be -
converted into User Fields if required. @) World

Coordinate System

e |gnore Dimension Elements — When enabled, skips geometry [ Global Origin
elements with type of dimension — usually represented as
lines, arrows, labels, etc.

Ignore Wireframe 3D Objects

R . D Ignore Text Elements
o |gnore Hidden 3D Objects — When enabled, elements hidden

by their level’s global visibility and element visibility attributes
are skipped. Ignere Hidden 3D Objects

e Process Level Display - Skip levels that are not added to “Level
Display” in selected 3D View.

D Ignore Dimension Elements

Process Level Display

Process Displayset
e Process Displayset — Skip objects that are not added to O sl

“Displayset” in selected 3D View Export Named Groups
e Export Named Groups — When enabled converts Bentley Export Tags
“Named Group” to Synchro 3D Sets
P v || Export Element Properties
e Export Tags - When enabled, converts Bentley “Tagsets” and
“Tags” to Synchro “User Fields” and “User Field Values” [ Break Cells
e Export Element Properties — When enabled, converts element [ Limit 3D Object Tree Levels By: 0
properties to Synchro User Fields. Each element is analyzed to Optimise 3D Data
see if it is an instance of an “Engineering Component Class” —
if it is an EC instance, properties are converted to Synchro Tessellation Accuracy D
User Fields. A 3D Set is created for each EC Class.
o Break Cells — When enabled, creates separate nodes for each low high
3D element under leaf cell Build Resources

o Limit 3D Object Tree Levels By — This option determins the
depth of the 3D file. NOTE: This featue is especially suitable for
models containing multiple hierarchies, all of which are not Bxport Eloso ] l
required in order to map the 3D geometry to 3D resources. - S — .

e Optimise 3D Data — When enabled, will attempt to further optimize the imported model data

e Tessellation Accuracy — This option controls the precision of triangulation during conversion of geometry elements with solid
representation.

e Build Results — When enabled, creates resources by 3D entity tree on export.

9. Select the options you wish to export in Synchro Plugin Window(shown above) = Select Save As Icon
10. Inthe Save As Window, Select the location of where you wish to save, name the file and select Save.
11. Select Export on the Synchro Plugin window and the progress bar will appear to give you the status of the export.

-

_ Master-LoRiseScheme.dgn : Converting geometry...

—— st.z0%

= — -——

12. When the export is complete, you will receive a message indicating the export finished successfully. Select OK.
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24.2. Importing .sp files generated from the Microstation plugin into Synchro

1. Open up Synchro PRO, Select File = Import = Synchro Project

. Mew ’\ Asta Powerproject

. Open » m Microsoft Project XML

natFcint PMA MetPoint

I-a Save As L3 5
8 Log in as different User... & Primavera P&
=pq send... @ FC
B Import L4 %’ 3D

Export v (i}| Synchro project
@ L ool
E:‘] Frint... "‘_'
@ Print Preview
L-’lg] Print Setup...

Search Command o 4 Options... Bd
2. Inthe Import Synchro Project Window, select “Add Files.” Locate and Open the .spx File. Select Next (Below Left)
3. Select “Import” to import all available attributes. (If required, attributes can also be skipped). (Below Right)

Import Synchro Project ﬁ

it

How would you like to impaort this file ?

Use the Selected Task to merge the data into the cument Project
@) Append the data to the end of the cument Project
Reframe Gantt to show imported data

Choose how you would like to process each object

Object Command
Tasks Impaort -
Links Impart
Costs Impart i
Calendars Import
Resources Import E
Resource assignments Import
Rishs Import
Risk assignments Import
3D Entities Import h
3D Assignments Import
Activity codes Import
I Codes assignments Import I
Userfields Import
Userfield values Import
Appearance profiles Import
Assigned profiles Import -

[ Defaut || Skpal |

[ = Back ” Import ]’ Cancel ]’ Help ]

4. The progress bar will appear to display the status of the import. Upon completion, select Finish.

NOTE: In this Basic Training, new resources are automatically created to correspond with the imported 3D Models.
The Synchro file that is created using the Microstation plugin will NOT have these associated resources, so they will
need to be added.
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5. Inthe 3D Objects window, right click on the .sp model name and select “Resources Wizard”
3D Objects > 7 X
Name -
<all: jol
A Objects of scene
1 [ Ecﬂlﬂdim Mod 4w Import3D
N+ Export3D
*. Resources Wizard.., Ctrl=Shift=R
Synchronise From...
rgl Display "Assigned to’ Task(s)
6.

In the Resource Wizard Window, select “Assign to a new Resource” and Select Next.(Below Left)
7. Rename the Resource and Select Next. (Below Right)

Assign to existing Resource E Compary | Mew Compary hd

(@)Assign to a new Resource '

Name  Microstation Model

Trpe

(7 No assignment

<Back | New> | [ camel | [ Hep | [ <Back |[ MNed> | [ Canced | [ Heb

L

W

8. Select “Add Resources Underneath, Build Tree,” Select Next.

N
Resource Creation... M

-

D‘tz __:BT Resource

sn't: i_r:'rne

(") Assign to this Resource, don't build tree

(7) Add Resources undemeath, don't build ree
(7) Assign to this Resource, build tree

(@) Add Resources undemeath, build tree

Resource tree maximum depth (0 means unlimited)

The current 30 Objecttree is b levels deep 0
[ <Back " Finish ] [ Cancel ] ’ Help
o T 4

9. Select Finish to complete the process
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25. Appendix C: Revit 3D Workflow
Synchro imports DWF, DWFx, and IFC files, all of which can be exported from Revit. Additionally, you can download the
Revit Plugin for Synchro, which exports the model as an .spx file.

NOTE: Whatever is visible in your Revit 3D view is what will be exported.
25.1. Using the Revit Plugin

The Revit Plugin enables native RVT files to be exported out of Revit as Synchro Project files (.spx) that can be imported
into an existing Synchro Project (.sp) file.

NOTE: The Synchro Revit Plugin only works with Revit 2014 and 2015.

1. Download the appropriate Revit Plugin from www.synchroltd.com/downloads
2. Runand Install the setupRevit2015SynchroPlugin(x64)

3. Once the Plugin has been installed, open the RVT file in Revit.

4. Select Add-Ins=>Synchro=>Export Settings

@
Exportto Export
Synchro Settings

Synchro

5. The Synchro Export Settings dialog will appear. There are a number of options available to you:

e Include Linked Documents — If checked, exported tries to export all
linked documents in addition to master file; Otherwise, only master o5 Synchro Export Setti... l = | =] |_i2-]
file will be exported

e  Use Shared Coordinates — If checked, all linked 3D Data will be Include Linked Documents
exported using their Revit Shared Coordinates (similar to

[] Use Shared Coordinates

“Positioning: By Shared Coordinates”) option in Revit “Import/Link

RVT” dialogue). Otherwise, their origins will be used (similar to Create Viewpaints For Each Level
“Positioning Origin to origin” option in Revit “Import/Link RVT” Export Warkspaces
dialogue)

e  Create Viewpoints for Each Level — If checked, creates Viewpoints in
Synchro for each Level in Revit. Each Viewpoint is defined by a Expart Matching Uzer Figlds Only
cutting plane above and below that level. Parameters To Expart;

e  Export Workspaces — If Checked, Revit Rooms are exported as dd
Synchro Workspaces; Otherwise no Workspaces will be exported.
e  Export Matching User Fields Only — If checked, all User Field (Revit Femove

Parameter) names will be checked against strings presented in a list

box (below this option): If the User Field name contains any of the
strings from the list, that User Field will be exported; otherwise, it
will be ignored. If unchecked, all User Fields will be exported.

e  Parameters to Export — Only available when “Export Matching Using
Fields” is enabled. To enter a new String, Type it in the Text Box and
select the “Add” button to the right of the Text Box. Conversely, to b
Remove a String, highlight the String and select the “Remove” button at the top right of the List Box.

00

Cloze

NOTE: The values in the List Box are CASE-SENSITIVE. Additionally, any strings added to the List Box will remain there

until you manually remove them.
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Once you have selected your desired Export Settings, Select “Close”

7. These Export Settings will be saved for future use.

8. Please set up the 3D View in Revit according to how you wish to export your model — as you would with the
DWF/DWFx export.

9. When you are ready to export your model, Select Add-Ins=>Synchro=>Export to Synchro

! \ At this time, only 3D views can be exported to Synchro.

NOTE: If you attempt to export from a 2D View you will
receive the following message (right). Please make sure
you are exporting from an active 3D View.

10. The “Save AS” window will appear.
11. In the File Name, type the required name and select “Save”.

When the export is complete, you will have an .SPX file containing the 3D Geometry from Revit.
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26. Appendix D: Auto-Matching

The Auto Matching feature in Synchro provides a facility to automatically assign Resources to Tasks using custom filters and
search rules. The match is based on the Resource Names, Task Names, Task ID, or Task Comment.

Using the Auto Matching function greatly simplifies the task of linking resources to tasks to create a Synchro Project suitable
for scheduling and 4D Simulation

To match resources to task using the auto matching feature:

Select Home Ribbon>Tools>Auto Matching... (@ ) to display the Auto Matching Dialog

Rules

[userfield 4 |

| [ mpot | | egot | [ wew | [ Eir | [ Remove | [ Removeal | I

Operations

Use Profile: Install Clear Assign All

#  Resource ~ Task Use Profile =
Resource Tree Task
Resource Affributes Task Attributes
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26.1. Auto Matching Window dialog

The dialog contains a number of control sections:

1. Rules — defines a rule to match Resources and Tasks

e Import — Can be used to read a previously Exported 'Impon e m— —

Auto-Match rules File, via the “Import Rules from File”

Choose import file

Window.
C:\U \MatchingFilter B
i. Press the Browse button to select an XML file
containing Auto Match Rules. Select rules to import
ii. Press the Load File button to read the file and list Rule name | selectall |

InPro sample rule

its content. Resource name = Task parent name

iii. Select the desired rules to import, and press the || | Resource name !=Task comment
Resource name = Task ID and Resource name != Task ...

Import button.

v. Press Cancel to close the dialog.

Import

Cancel

e Export - can be used to save a Rule-Set to an XML File, | Export rules to file - ]

via the Export Rules dialog

Choose file to export

i. Pressthe Browse button to select an XML file to
Browse...

the Auto Match Rules

ii. Select the desired rules to export, and press the SEEEES D G

»

Rule name

Select all
Export button - ;,
InPro sample rule
= Deselect all

iii. Press Cancel to close the dialog. Resource name = Task parent name

Resource name != Task comment

Resource name = Task ID and Resource name != Task... -
sd

Level & Area
| | Area
Level
Slab#/Pour#

Task Mame = Revit Propertiv "Task" § 1
< | 1 3 . Cancel

Export

e The Add button is used to define a new rule — this will open the “Add New Rule...”window described below.

e Edit can be used to modify an existing rule — this will open the Edit Rule window which is identical to the Add New
Rule window (described below) except that it contains the saved rule.

e The Remove button will delete the currently selected rule

e The Remove All will delete all currently defined rules
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2.

Operations — applies the selected matching rule

o Use Profile — the default Appearance
Profile that will be applied to any
matches

e Search — search the Synchro project
using the currently defined rules.
After running Search, if there are
matches, the Group panel will be
populated (outlined right)

o Clear —clear any previous search
results

o Assign All — to assign all the
identified resources to tasks

o Close — exits the Auto Matching
window without making any
assignments.

Groups — Review matching search
results. Selecting a Resource (or Task)
from the Groups panel will populate
the Resource (or Task) Tree and
Attributes panels. If more than one
Resource matches a Task, the Task
will be listed only once at the top of
the group of the Resources. All
Resources in the same group must be
assigned using the same Use Profile.

Resource Tree & Task — Displays the
selected Resource or Task’s location

in the Resource Tree or WBS,
respectively.

Rules

Task ID & Revit

|

Import Export Nev Edit Remove Remove All
Operations
Use Profile: | Install Search ] I Clear ] [ Assign All l [ Close ]
#  Resource ~ Task Use Profile

ramp2 [227105] Superstructure |E‘

rampl [226783] Levels 00 to Roof

ramp [226767] Level 2 Slab 1

Pavement [270591] Level 2 Slab 2

Main ROad [271743] Level 2 Slab 3

Grass 2 [273611] Envelope

Excavation5 [226392] MEFP

Excavationd [226348] Final Finishing

Excavation3 [226298] Logistics -
< 1n | »
Resource Tree Task

=] Material Resources
=] Existing Site.dwf
(= Existing Site dwf

=] Construction Project
=] Superstructure
= =] Levels 00 to Roof

| »

company: Mew Company
name: Main ROad [271743]
User fields [0]
Matched tasks [0]
Assigned tasks [0]

=] Site (13) 4 ) Level 2 Slab 3
Resource Attributes Task Attributes
=] General [2] =] General [1]

name: Level 2 Slab 3
Activity codes [0]
User fields [0]
Matched resources [0]
Assigned resources [0]

Resource Attributes — Displays the key attributes of matched Resources including Company Name, User Fields,
Matched Resources and Assigned Resources.

Task Attributes — Displays the key attributes of matched Tasks including Name, Activity Codes, User Fields, Matched

Resources and Assigned Resources.
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26.2. Add New Rule/ Edit a Rule

To define a new rule:

1.
2.
3.

5.

6.

Press the New button in the Auto Matching window to bring up the Add New Rule window:

Enter a Rule Name
The Summary Options, when applied can be used to set the
range of your search.

e Use only Selected Resources (and/or) Tasks - applies the
search rule only to Resources/Tasks that were selected in
Synchro before opening the Auto Matching window. Leave
the options unchecked to search all Resources and Tasks
in the project.

e Ignore Assigned Resources — excludes Resources that have
already been assigned to at least one task from search

o Ignored Tasks with Assignments — excludes Tasks that have
at least one Resource assigned to them from search

o Merge Resources Groups — when enabled, groups all
Resources that contain a common characteristic used for
matching and assigns them to the same group of Tasks.
NOTE: Resources in the group don’t match all grouped
Tasks.

e Ignore Summary Tasks — when enabled, excludes WBS
level summary tasks from the search. No new Resource
assignments will be made to those tasks.

The Relations radio buttons can be used to set the default
linkage when the search is applied a match is found.

e None - a linkage is not applied between matched
Resources and Tasks

e One-To-One — Matches are linked on a one-to-one basis.
One Resource can be assigned to one Task.

Add New Rule...

MName

|:| Merge Resource Groups

() Mone

Summary options
[T Use only Selected Resources

[]1anore Assigned Resources

@ One-to-One

[T Use only Selected Tasks
|| 1gnore Tasks with Assignments

|:| Ignore Summary Tasks
Relations
() Many-to-Marry

Expression

Resource attribute
Use Parent

User Field

Type: E H L

Algorithm

(@) Exact

Options
Min Length:

Min Digits:
Separators:

Case 5ensitive

Substring LCS @ AND

Term
Task attribute

Use Parent

Activity Code

Operator

OR
AND NOT

OR NOT

True if Undef

Cancel ] [ Help ]

4

e Many-To-Many — Matches are linked on a many-to-many basis. Multiple Resources can be matched to each Task

and will be grouped together in the search results in the Auto Matching window. A Resource can also be matched

to multiple Tasks.

The Expression section allows you to define complex search criteria for the rule.

NOTE: At least one search expression must be defined before you can close the dialog, or press Cancel to stop the

Auto Matching rule creation.

Select Add to define a new Expression. This will enable the Term, Algorithm, Operator, and Options panels below.
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26.2.1. Defining Rule Search Expressions

1. The Term section allows you to specify the Resource and Task attributs to use in the search, as well as the
comparison operators to use:

-
Add Mew Term...

e The Resource Attribute section defines which Resource attribute —
will be searched (Name or User Field) _
i. User Field - select desired User Field from the drop-down list Mot Rem_c::mmw opzzsmw e
ii. Use Parent — allows the search to apply to the parent element e e s Ignore Tasks with Assigrments
if the attribute does not exist in the current Resource (when Merge Resource Groups Ignore Summary Tasks
the search is applied) None -:-;?:?:Ene Many-to-Many
iii. Type— allows you to select specific Resource Types to be Expression
included in the Auto-Matching operation: Equipment,
Human, Material, or Location
e The Task Attribute section defines the which Task Attribute (Name, — —
ID, Comment, User Field, or Activity Code) will be matched against
the defined Resource Attribute Aesource sttt Tack atirbute
i. User Field - Select the required value from the drop-down list Al Ll
ii. Activity Code — select the required code from the drop-down tj;eld ) [:::L s -
list.
iii. Use Parent —allows the search to apply to the parent element Type: [WIE [@H [@L [@M
if the attribute does not exist in the current Task —— p—
2. The Algorithm section defines how the Resource and Task attribues epest sk C1S a:]I:D
should be matched T Optfns = ,;,ANDNOT
e Exact — matches attributes exactly MinDigts: o = © orNaT
o Substring — returns a match if the Resource attribute occurs within [ Separators:
the Task attribute (i.e. “ana” is a substring of “banana” in two ] Case Sensitive [T True if Undef
different places)
o LCS — Matches the Longest Common Substring between the oK Cancel | [ teb

Resource and Task attributes. The minimum length of this substring
is defined by the Min Length option

3. The Options section of the dialog defines additional search criteria:
* Min Length — determines the minimum string length when the LCS matching is performed
o Min Digits — defines the minimum number of matching characters for a match
e Separator — If an attribute or field consists of multiple words or phrases, then the Separators option may be used to
define the delimiters used between each word or phrase. During searches, the Auto-Matching function will test
each word or phrase of the attribute, rather than the complete text defined for the attribute.

4. The Operator radio buttons are used to logically define how multiple search expressions will be combined to
determine whether or not a match exists. This allows complex search patterns to be defined for a single rule:
o AND — this Expression must be true in order for a match to be found
e OR — a match will be found if this Expression is true even if the other(s) are not
o AND NOT - this Expression must be false in order for a match to be found
¢ True if Undef - controls whether the term should be evaluated as true if the matched attribute is undefined for a
particular attribute.
(Ex: If the Task Attribute is Activity Code, when True if Undefis checked, the Expression will automatically be true for
any tasks that do not have an assigned Activity Code)
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Press Save to save the current Expressions

If you wish to continue adding more Expressions, press Add

The Remove button can be used to delete the currently selected Expression. Remove All will delete all of the

Expressions associated with the current rule.

8.  When the Rule is finished, press OK to close the dialog and return to the Auto Matching window to run a search.

26.3. Auto-Matching Search

Once an Auto Matching rule is defined, you can

run the rule to search for matches in your Synchro

Project.

Select the desired Rule from the drop down

Press the Search button

3. The groups list will display the matched

Resources and Tasks.

4. Right click in the list to select the proposed

linking Options:

o Group Relations — defines the proposed
linkage (None, One-to-One, Many-to-Many)
between the currently selected matched

Resources and Tasks.

o Overall Relations — defines the proposed

linkage for all the matching resources and

tasks

5. The Resources Tree displays a sub-tree

containing the matched resource starting

from the Resource Type

6. The Task Tree displays the matched Task and

its hierarchy.

Rules

Task ID & Revit

Import Export Nev Edit Remove Remove All
Operations
Use Profile: | Install Search I [ Clear ] [ Assign All ] [ Close
#  Resource ~ Task Use Profile =
ramp2 [227105] Superstructure |i|
rampl [226783] Levels 00 to Roof
ramp [226767] Level 2 Slab 1
Pavement [270591] Level 2 Slab 2
Main ROad [271743] Level 2 Slab 3
Grass 2 [273611] Envelope
Excavation5 [226392] MEP
Excavation4 [226348] Final Finishing
Excavation3 [226298] Logistics ad
< | 11 »
Resource Tree Task

=] Material Resources
(=] Existing Site.dwf
(=] Existing Site.dwf
(=] Site (13)

»

=] Construction Project
=] Superstructure
= Levels 00 to Roof
p Level 2 Slab 3

-

Resource Attributes

Task Attributes

=] General [2]
company: New Company
name: Main ROad [271743]
User fields [0]
Matched tasks [0]
Assigned tasks [0]

=] General [1]
name: Level 2 Slab 3
Activity codes [0]
User fields [0]
Matched resources [0]
Assigned resources [0]

7. You can change the assigned Resource Appearance Profile for each matching group by clicking within the Use Profile

column (which will display a drop-down list of the available Resource Appearance Profiles).

# Resource

~ Task

Use Profile =

1 Main ROad [271743]
Solid (3D) [D94]
Solid (3D) [3E2E]
Solid (3D) [3E29]
Site Office 2
Office Building.dwf
ramp3 [227089]
ramp2 [227105]
rampl [226783]

=] Level 2 Slab 3
Construction Project
Tower Crane
Hoists
Substructure
Excavation
Levels 00 to Roof
Superstructure
Levels 00 to Roof

Install ‘E
=] System Profiles
» Install
Maintain
Remove
Temporary
=] User Profiles
Car Movement

Roof Temp Perm

L1}

Roof Trans

Slab Growth
Slab Trans
Temporary Equipm

|

8. Press the Assign All button to apply your proposed Linkages (assigning all matched Resources to matched Tasks in

the list)

9. The Clear button will clear the list. You can then select another Rule in the dialog and repeat the Auto Matching

operation again until you reach the desirable result.
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27. Appendix E: Synchronisation -Basic Rules for Scheduling Software

P6
GUID (Global Unique Identifier) is the primary information used to compare Tasks. If the Task is not found in the GUID map,

and the option to Use Activity IDs on Synchronisation is set in Options>Synchronisation>Primavera P6, the IDs are compared. If
not found, the Activity is considered a new one. If found; the Task and GUID map are updated.

Therefore:

e [f the original schedule and P6 database are used to update, Synchro will look for GUID’s when synchronising.

e [f the original schedule has been copied then updated, a different P6 database has been used, or if the GUIDs are
not found, then Activity IDs will be compared, provided they have not been changed.

e |tis possible to change the IDs in both P6 and Synchro, as long as GUIDs remain unchanged.

e The schedules can be synchronised using a different computer and can have a different file name

P3

Comparison uses Activity IDs, therefore it is possible copy a schedule then update, provided the Activity ID’s are retained.
In P3 activity IDs are unchangeable

The schedules can be synchronised using a different computer and can have a different file name

Asta
When making copies of the original schedules that are created in other systems; the global unique ID of each task will be
changed in the process of copying.

Therefore when a copy is made and introduced into the synchronisation workflow the change will be made to the original
task’s own internal UID (unique identifier).

This will result in Synchro not recognising the task as the same, therefore all prior resource assignments will be lost. It is
essential that the original import/export schedule is used throughout the workflow. If copies are introduced, it is important
that they are only for side reference or saved as an archive as required, but at all times updates and changes are
synchronised between Synchro and the original or original updated schedule.

In essence, the original and updated schedules throughout the workflow process should be from the same source schedule
and NOT copied versions.

The programme can be synchronised using a different computer and can have a different file name

Microsoft Project XML

Synchro ONLY supports XML exported from Microsoft Project

NOTE: Synchro does not support importing/synchronising XML from P6!

MSP xml uses an attribute called Unique IDs (UID) that is used when synchronising.

You can copy and update a project provided it is the same MSP project resaved/exported in MSP then UIDs are retained.
The projects can be synchronised using a different computer and can have a different file name
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28. Appendix F: Synchronisation Scenario
(Skip, Synchronise, Consolidate, Integrate)

Summary:

This question looks at your knowledge of synchronisation options in an example scenario.
Question:

Consider the following scenario:

1. Company XYZ employs both a professional P6 scheduler and a Synchro specialist. The scheduler creates a schedule
in P6 named Schedulel.xer,

2. The Synchro specialist imports the P6 schedule into Synchro after opening a new .sp file which he saves as
Projectl.sp.

3. The Synchro specialist then imports a 3D model into the same .sp file and begins linking the 3D resources to the
tasks. For the purpose of animation, he subdivides some of the tasks and creates entirely new tasks for equipment
traveling on 3D paths.

4. Meanwhile the scheduler has updated the durations of some of the tasks in P6, added a few more tasks, and
deleted a few tasks as well. The updated schedule file is resaved as Schedulel.xer.

5.  When the Synchro specialist goes to synchronise Projectl.sp with the updated schedule, he opens
Navigator->External Data. He right clicks on Primavera=>[Schedulel][Import][Date] and selects Synchronise from.

This scenario is illustrated graphically below:

Ha
schedule
th

Synchronise

=
=]

Consolidate

=
Q

Mo

Below are simplified example schedules, with durations in parentheses after the tasks. The left one was created in P6 and
imported into Synchro to begin. The middle one is the result of modifications made to the schedule in Synchro by the
Synchro specialist, and the right one reflects the changes the scheduler has made in P6.
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Original Schedule Modified Schedule in Synchro Modified Schedule in P6
Projectl Projectl Projectl
Foundation (10d) Foundation (10d) Foundation (15d)
Walls (10d) Walls (10d) Walls (10d)
Landscaping (20d) Wall 1 (5d) Windows (5d)
Wall 2 (5d)
Landscaping (10d)
Truck Move (20d)

a) Primavera P& synchronice from ﬁ b) Primavera PG synchronise from ﬁ

| |
; ! ; |
[ | G |
‘ Which altribuses @ wonld you b b Which asibulis s how would you ke 1o synchronmse?
| |
(apoct Command Command
Tarshs Synchiamss Il Tarsks Inbisggraatis ||
Links Synchianise Lirks Infegriat
Task constraints Synchronise Task constrainks Synchronise
Costs Synchranise Costs Synchronise
| Calendars Conzolidate | Calendars Consgbdate
Congohdate: Consubdale
Intisggesatie g Intesggraatis
Activity codes Consolidate Activity codes Congakdate
Codes assignments Synchronize | Codes
User hurdedss Consohdate Ussier Seleds Coansabdaln
el walins Synchronise
( i ( |

Skip all (SR Shap all

<Back | Synchronise Cancel | Help ] <Back I Synchronize | Cancel ] Help ]

C) Primavera PG synchronise from ﬁ d) Primavera PG synchronise from ﬁ

al
———

‘ ‘Which atributes would you B o 3y i Which attributes and hew would you Bke to synehronisa?

Object Command Object Command
Tasks Integrate |I Tasks Consolidate ||
Links Integrate Links Consolidate
0 Synchiomnise Tagk congtraints Synchronise
i Synehionise o Synechromse
| Calendars Consolidate | Calendars Consaldate
Resources Conzolidate Resources Consolidate

Resource azsignments Synchronise Resource

Aty codos

Activity codes Consolidate
Cadas assignmants Synchronisa | | Codas assig ¥ i
Userfislds Consclidate Userfields Consolidate
User field valuas Synchranize User held values Synchionise
| |

Default Skip all Defaull Skip all

cBack | Synchronise Cancel _| Help ] <Back |Svynchromse Caneel ] Help |

In which of the following windows has the Synchro specialist selected the correct options to synchronise without losing any
of the work that he and the scheduler have conducted since the first version of the schedule was originally imported into
Projectl.sp?
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Answer: b)
Explanation:

The attributes of concern in this scenario are Tasks, Links, Resources, and Resource assignments. The original schedule has
been modified in Synchro, so choosing Synchronise for Tasks and Links will override and replace the modified schedule in
Synchro with the updated P6 schedule. All the subtasks and equipment movement tasks created by the Synchro specialist
will be lost. Therefore, a) is not the correct answer.

The scheduler has deleted tasks. If the Tasks and Links are consolidated, the tasks that the scheduler has deleted will remain
in the consolidated schedule because Consolidatekeeps the greatest number of tasks compared to the other options: any
tasks that are in either schedule (Synchro or P6) will be in the new schedule — no tasks will be deleted from either schedule.

Maodified Schedule Modified Schedule
in Synchro in P6

Wall 1
VWall 2
Landscaping
Truck Move

AR

Windows

You can think of it like a Venn diagram:

Consolidate will keep all of the tasks in both ovals; Synchronize would keep all of the tasks in the red oval (including the
overlap.) Note: if a task is in both schedules (the overlap in the Venn diagram), the schedule that is being synchronized from
will take precedence in determining the task duration and other attributes. Because we do not want the Landscaping task in
our final schedule, d) is not the correct answer.

The same Venn diagram does not work to explain /ntegrate because the action /ntegratetakes depends on which program
originated the change relative to the original schedule. For example, even though just looking at the Venn diagram above,
you wouldn’t guess that Landscaping and Truck Move would be treated differently when integrating, but the program
remembers that 7ruck Move was created in Synchro, whereas Landscaping was part of the original schedule that was then
deleted in P6. Tasks that were created in Synchro will be retained when /ntegrateis chosen, but tasks that were part of the
original schedule, then deleted in P6 (even though they are in the modified schedule in Synchro) will be deleted in the new
schedule as well after the Synchronize from is carried out. Therefore /ntegrateis the correct option for Tasks and Links.

If we now look at Resource Assignments, we see that b) has /ntegrate selected while c) has Synchronise. Integrate will work
the same way for Resource Assignments as for Tasks —any assignments made in either program will be retained, as long as a
deletion hasn’t been made in the source program (in this case, P6). Synchronise will override all of the 3D Resource
assignments made in Synchro (the term “Resource” in P6 refers primarily to human resources). Therefore, c) is not the
correct answer.

The correct answer is b).

The final schedule in Synchro after Synchronise From has been performed will be:

Final Schedule in Synchro
Projectl
Foundation (15d)
Walls (10d)

5
5

)

(5d
Wall 2 (5d)
Windows (5d

)
Truck Move (20d)
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29. Contact Details

Support e-Mail: Support@synchroltd.com

Synchro Software Ltd. UK Locations

Birmingham, UK

Birmingham Science Park Aston
Faraday Wharf

Holt Street

Birmingham

B7 4BB

Synchro Software Ltd. — USA Locations

Cambridge, MA
25 Mt. Auburn St.
Cambridge, MA
02138

Berkeley, CA
WeWork Berkeley
2120 University Ave.
Berkeley, CA

94704

London, UK
WeWork London
1 Fore Street
London

EC2Y 5EJ

Rowayton, CT

105 Rowayton Ave.

Rowayton, CT
06853
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