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CS 271 Visual Studio Setup Instructions 

The following consists of installation & setup tutorials for Visual Studio 2019. If you 
prefer to configure Visual Studio 2017, that version can also be used in this class. 

*Note: Although the latest Visual Studio 2022 is available, we will be using Visual 
Studio 2019 (or 2017) for this class 

If you want to use Visual Studio via Citrix, please see the bottom of this page. 

Coming out of this module you should have done the following: 

• Set up Microsoft Visual Studio 
• Install and configure Kip Irvine's libraries 
• Started a new Assembly code project 
• Verified that Visual Studio is installed properly 

Please also note that your Visual Studio install will need to be "Activated" with your 
Product Key.  You can retrieve this key at any time through the Microsoft Azure 
interface by looking in "All Services --> Other --> Education --> Software" and clicking 
on the Visual Studio product. 
 

Installation on PC 

Part 0: For Linux or Mac Users Only (Windows Users may skip this part):  

Setting Up a Virtual Machine 

Option 1 (Virtual Box): 

This video will show you how to set up a virtual machine running Windows if you are 

using Linux or Mac. Doing this will allow you to run Visual Studio and MASM inside of 

your virtual machine. 

https://www.youtube.com/embed/JWmGpMM-P_c 

Option 2 (VMware):  

OSU students get free access to virtualization products including VMware Fusion (for 

Mac OS) and VMware Workstation (for Linux). Both of those tools are available for 

download at the VMware Academic Site. The Linux version supports Ubuntu, RHEL, 

CentOS, Oracle Linux, and SUSE. 

After downloaded VMware products, use the following video to complete the Virtual 

Machine setup (Note: you may skip the VMware download part). 

https://www.youtube.com/watch?v=mtxtqw95484 

 

https://aka.ms/devtoolsforteaching
https://aka.ms/devtoolsforteaching
https://www.youtube.com/embed/JWmGpMM-P_c
https://e5.onthehub.com/WebStore/Welcome.aspx?ws=09227ff6-f355-de11-9e9c-0030485a8df0
https://www.youtube.com/watch?v=mtxtqw95484
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Part 1 

Visual Studio is now available through the Microsoft Azure program.  

Step1: To get started, visit https://azureforeducation.microsoft.com/devtools and log in 

using a Microsoft account. Ironically, Microsoft requires that you log in with a non-OSU 

email (if you have an existing account you can use it) and then verify your OSU email to 

obtain access. Once you are logged in, the main portal should look similar to the 

following: 

 

Step 2: In order to access the Visual Studio download, go to Software, type “Visual 

Studio” in the search bar, and locate “Visual Studio Enterprise 2019”. You can view your 

assigned license key. 

https://azureforeducation.microsoft.com/devtools
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Step 3: To download Visual Studio Enterprise 2019, go to 

https://docs.microsoft.com/en-us/visualstudio/releases/2019/release-notes, and select 

“Enterprise 2019” in the dropdown list. And your download should start shortly.  

https://docs.microsoft.com/en-us/visualstudio/releases/2019/release-notes
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Step 4: Once download is finished, follow instructions to install the software on your PC 

(Note: you will need the 5X5 license key in step 2.) When you install Visual Studio, you 

will be asked to select your intended workload (e.g. how do you plan to use Visual 

Studio). You should select "Desktop development with C++" as that is the best option 

for our purposes. I suggest installing either the 2019 or the 2017 versions, since the 

newer versions of Visual Studio have better compatibility with Windows 10. 
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Part 2:  

In this video, Stephen Redfield explains how to install and configure the libraries 

provided by the textbook's author. http://www.asmirvine.com/ 

Note that the textbook website now contains updated libraries for Visual Studio 2019 so 

you can follow that tutorial directly (click the following link to view the video). 

Note:  

1. You may skip 64-bit and 16-bit tutorial as we will only use 32-bit program for this 

course 

 
2. If your antivirus reports a virus on the project that you download, you may: 

a. Modify the setting and allow it to run 

b. Use the sample project under \Irvine\examples\Project32_VS2019 

instead 

 

https://media.oregonstate.edu/media/1_u2rpcwp3 

http://www.asmirvine.com/
https://media.oregonstate.edu/media/1_u2rpcwp3
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Part 3:  

This last video shows how to start a new Assembly code project and verify that Visual 

Studio is installed properly. 

https://media.oregonstate.edu/media/1_5qfbq9od 

 

Using Citrix (not required) 

Citrix is a software product that allows you to access programs on a remote computer 

as if you were sitting at the desktop. Personally, I strongly recommend that students 

install Visual Studio on their local computer, rather than using Citrix. However, if you 

want to try it, you should be able to access Visual Studio on our OSU Citrix Servers as 

follows: 

Once download, open Citrix, choose the “Desktop” choice at the top of the screen after 

you are logged in and then the “MIME EECS Desktops” choice.  

 

This will create a session as if you were logged on to an on-campus lab computer.  In 

the Citrix session, download the updated zip file here and extract it to 

https://media.oregonstate.edu/media/1_5qfbq9od
http://engineering.oregonstate.edu/computing/citrix/
http://classes.engr.oregonstate.edu/eecs/winter2022/cs271-001/Project32_VS2019.zip
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Z:\bin\CS271\ 

You will have to make this folder (it does not exist by default). All your projects should 

live in this directory, since in order to execute code on Citrix the executable should be in 

the bin folder or a subdirectory thereof. Also note that you need "execute" permissions 

in the 'bin' folder, which may or may not be set by default. If you are having trouble with 

this folder, they can create/reset it here. 

NOTE 1: You do not have to download/install the Irvine .msi file if you use the Citrix 

machine (in fact it won't let you). But you will have to transfer it from the network drive 

V:\Irvine (which should be mapped to "\\stak\engr.oregonstate.edu\" to the network drive 

Z:\Irvine and update the project properties.  Once you get to the point where you're 

opening a project, do the following: 

1. Open the Project.sln from "Z:\bin\CS271\Project32_VS2019 " after you've 

extracted it to this location (one of the videos shows you this). 

2. Select Project (from the top menu) -> Project Properties 

3. In the project properties window select "Linker" 

4. On the right you should see "Additional Library Directories:" and c:\Irvine part of 

the listing here 

5. Change c:\Irvine to Z:\Irvine 

6. Now select "Microsoft Macro Assembler" from the same part you selected 

"Linker" 

7. Under "Include Paths" change c:\Irvine to Z:\Irvine 

8. File->Save All 

9. Close Visual Studio, and re-open Project.sln from the same directory. 

NOTE 2: Be aware that the files will NOT reside on your home computer, and if you 

want them on your computer/laptop you'll have to transfer them using an SFTP utility. 

 

Common issues with Visual Studio setup 

1. LNK1104 cannot open file 'Irvine32.lib' 

If you're getting this error, it's likely that you did not extract the Irvine library files into the 

correct folder. Ensure that the folder structure is such that the Irvine32.lib file exists in 

the C:\Irvine\Irvine32.lib folder and try again. The most common issue is that you will 

end up with the following incorrect path due the zip extraction process: 

"C:\Irvine\Irvine\Irvine32.lib". 

2. "File not found" or "cannot execute the specified program" errors 

https://teach.engr.oregonstate.edu/teach.php?type=reset_userbin
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Visual Studio generates executable programs (.EXE files) that run when after you 

assemble your source code for your programming assignments. Even after working fine 

for a while, at some point you may see an error message that the file cannot be found, 

or your program prints the message "The system cannot execute the specified 

program." This probably means your antivirus program has falsely identified your 

executable program as a threat (false positive) and block it from running. Exclude your 

entire CS271 folder (and all its subfolders) from being virus scanned, and you should be 

able to proceed without further antivirus interference with your work. 

3. INCLUDE errors: By installing additional extensions beyond what is required for 

this course, the INCLUDE structure may be prone to error. 

Please ensure that the path "C:\Irvine" is explicitly written in the Project Properties in the 

two fields specified below: 

To enter the Project Properties select the "Project" menu, then select "Project 

Properties".  Or, right click "Project" in the Solution Explorer and select "Project 

Properties" 

o Configuration Properties ➝ Linker ➝ "Additional Library Directories" 

should be: "c:\Irvine;%(AdditionalLibraryDirectories)" (without quotes). 

o Configuration Properties ➝ Microsoft Macro Assembler ➝ "Include Paths" 

should be: "c:\Irvine" (without quotes). 

4. Eliminating the "... exited with code 0." message 

If when you run a program, the message ".... (process xxxxxx) exited with code 0." 

becomes annoying, here are the steps to keep that message from showing: 

o From with Visual Studio select the "Debug" menu, then select "Options". 

o Under Debugging > General, ensure "Automatically close the console 

when debugging stops." is checked. 

o Run your program again. The message should be gone. 

5. Syntax Highlighting 

By default, Visual Studio does not include syntax highlighting for Assembly code. This 

can sometimes make it more difficult to read your source code. To enable syntax 

highlighting in Visual Studio 2015 or later, you may want to install AsmDude: 

o From within Visual Studio select the "Extensions" menu, then select 

"Manage Extensions". 

o Search for AsmDude, select it, click Download, and wait for it to complete. 

o Close Visual Studio and a VSIX Installer dialog will pop up asking for 

permission to install AsmDude. Let it do so. 
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o Reopen Visual Studio. MASM syntax highlighting support should now be 

installed. 

o Disable syntax highlighting options that interfere with the INCLUDE 

Irvine32.inc statement: Go to Tools>Options>AsmDude, find the 

Intellisense section, and uncheck the "Show in error list" and "Decorate 

with Squiggle" options for Undefined Labels, Clashing Labels, and 

Undefined Includes, then click OK. 

o If you are unable to complete Project 0, disable AsmDude. 

o If you use the dark Visual Studio color scheme, you can change the color 

of certain text to be more readable. Go to Tools>Options>AsmDude and 

change the color for Mnemonic. 

o Special note: if you are an advanced Visual Studio user and want to use 

its native (and imperfect) MASM syntax highlighter, you must choose it or 

AsmDude -- you cannot use both at the same time. 

6. "Inconsistent Line Endings" error from Visual Studio 

A fairly catch-all solution to this is eliminating any non-Unicode characters from 

your .ASM file. To do this... 

o Copy the entire body of your .ASM file. 

o Paste it into a non-formatting text editor like Notepad. Save this copy to be 

sure you don't lose anything. 

o Open a new, working project (copy one known to work from a different 

folder, or use the clean template from the Canvas site) 

o Copy everything from the Notepad file into this new, clean project file and 

try running again. 

7. Windows Environment Variables 

It is recommended you do not try to locate, read, or alter any environment 

variables created and assigned by Visual Studio. VS has a complex way of 

managing them while it is running, and using them is way beyond the scope of 

what is needed in CS 271. 

 

Visual Studio Debugger Settings 

You may follow instructions here to customize your debugger settings:  

http://asmirvine.com/debug/vstudio2019/index.htm 

 

http://asmirvine.com/debug/vstudio2019/index.htm

